×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged Kunena Latest 2.0.1 inserts noindex meta tag

More
8 years 2 months ago #1 by cybnet
Today I've been investigating why the visits to my website has been dropped and discovered that I have the meta robots set to "noindex,follow" in the home page. Joomla global configuration is set to use "index,follow", the menu item (featured articles) is set to use global configuration, even if I set the menu item to use other configuration, or if I set other global configuration, I always have meta robots set to "noindex,follow" in home page. The only way I have to don't have this proble is deactivating kunenalatest module (also if I deactivate kunena system plugin but in this case the module doesn't work, having kunena system plugin enabled and kunenalatest module disabled solves the problem so I think is a bug in kunenalatest module and not in the plugin).
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 384M | Max file upload: 55M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : efxto | author: Juan Padial | version: 1.0 | creationdate: 30.06.2012

Kunena default template details : eFXto Forex 1.0 | author: Juan Padial | version: 1.0.0 | creationdate: 2012-07-01

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1 | UddeIM 2.8

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 2.0.1

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by AJ2
I have the same problem. noindex on root / index.php only.
All visitors gone. :( :(

I disabled and removed the latest module from root and activate index and follow in menu item.
Hope google will index the page real soon. And hopefully, the page will be on nr 1 position where it was before this disaster. This cost me about 90% of my daily visitors.

Still kunena rocks.

cybnet wrote: Today I've been investigating why the visits to my website has been dropped and discovered that I have the meta robots set to "noindex,follow" in the home page. Joomla global configuration is set to use "index,follow", the menu item (featured articles) is set to use global configuration, even if I set the menu item to use other configuration, or if I set other global configuration, I always have meta robots set to "noindex,follow" in home page. The only way I have to don't have this proble is deactivating kunenalatest module (also if I deactivate kunena system plugin but in this case the module doesn't work, having kunena system plugin enabled and kunenalatest module disabled solves the problem so I think is a bug in kunenalatest module and not in the plugin).

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 384M | Max file upload: 55M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : efxto | author: Juan Padial | version: 1.0 | creationdate: 30.06.2012

Kunena default template details : eFXto Forex 1.0 | author: Juan Padial | version: 1.0.0 | creationdate: 2012-07-01

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1 | UddeIM 2.8

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 2.0.1

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #3 by cybnet
Hi AJ2, I think Google will restore our position soon, anyway this a very big problem that needs a quick solution. I hope kunena team come here soon, confirm this bug and solve it.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #4 by AJ2
I have resubmitted the sitemap, put some indexing service on root domain so I know for sure, it will be back soon.
Also, Once I discovered the noindex on root domain, I activate the index and follow option in joomla menu. After activating this, the latest forum post module gives an error on the page. So I deleted the module. Now the problem is solved.
Still not back in Google index but this will come.
Hopefully they will fix this bug real soon.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago - 8 years 2 months ago #5 by cybnet
After 1 day without kunanalatest module my home page is again in Google in the same position and my visitors are coming back!!!! Great!!!

has some one from kunena team read this topic? Why has it been moved to Add-ons category? I think Add-ons category is not the right category because I think the bug is not in the module itself, I think the problem is in kunena API. Anyway, whatever the right category is, I would like to see some comments about this topic.
Last edit: 8 years 2 months ago by cybnet.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago - 8 years 2 months ago #6 by Infield
After upgrading Kunena to 2.0.1 and module Forum Latest 2.0.1, I saw my site fall from #2 in Google page rank to oblivion.
I found the page source displayed <meta name="robots" content="noindex, follow" /> despite all the Joomla Global Config settings being set to "index,follow"
I found after elimination that unpublishing the module Kunena Forum Latest,that the page source was returned to the proper setting of "index,follow". Re publishing the module causes the page source to revert to "noindex,follow"

Do we have a bug or am I just unlucky?
Last edit: 8 years 2 months ago by Infield.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #7 by cybnet
I've been trying to fix the problem myself with no success. I'm getting a little desperate. No one else has this issue?

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago - 8 years 2 months ago #8 by cybnet
Finally I've found a temporal solution. In my case I use the module with latest topics output. For other module's configuration this solution may don't work.

Open: joomla_site/components/com_kunena/views/topics/view.html.php
Change line 315 from:
$this->document->setMetadata ( 'robots', 'noindex, follow' );
To
//check if we are in kunena latest topics page
if(JRequest::getCmd('option','') == 'com_kunena' && JRequest::getCmd('view','') == 'topics'){
  $this->document->setMetadata ( 'robots', 'noindex, follow' );
}
Last edit: 8 years 2 months ago by cybnet.
The following user(s) said Thank You: ChaosHead, Parsec

Please Log in or Create an account to join the conversation.

More
More
8 years 2 months ago - 8 years 2 months ago #10 by Corradini
Thanks to save my life... ;) :laugh:
i had the same problem and it is two days i'm looking for the possible cause... finally i found this topic!!::):):)
Once i disabled the module, robot meta went back to index,follow!

Now i'll see if my users will come back :unsure:

Edit:
cybnet, i tried your hack with same configuration but it doesn't work for me... thanks anyway!!!
Last edit: 8 years 2 months ago by Corradini.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.233 seconds