Kunena 7.0.9 & Kunena 6.4.14 – Security Updates Released

The Kunena team has announce the arrival of Kunena 7.0.9 [K 7.0.9] in stable which is now available for download as a native Joomla extension for J! 5.4.x/6.0.x./6.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 / K 6.4 and issues discovered during the last development stages of K 7.0

The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Fatal Error: Class 'JMailHelper'

More
14 years 5 days ago - 14 years 5 days ago #134234 by skybax
Fatal Error was detected!

Fatal Error: Class 'JMailHelper' not found in components/com_kunena/libraries/forum/message/message.php on line 196

The error was detected in the Kunena Component.

Any way to fix this ?
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 100M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ja_rutile | author: JoomlArt.com | version: 1.0.0 | creationdate: 19 Sep 08

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.2 | creationdate: 2012-09-02

Kunena version detailed: Kunena 2.0.2 | 2012-09-02 [ Botschafter ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 2.7

Third-party SEF components: None

Plugins: Search - Kunena Search 1.7.0

Modules: Kunena Latest 2.0.2 | Kunena Stats 2.0.2 | Kunena Search 2.0.2

Last edit: 14 years 5 days ago by skybax.

Please Log in or Create an account to join the conversation.

More
14 years 5 days ago #134237 by xillibit
Hello,

Can-you describe exactly how to reproduce this issue ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
14 years 4 days ago - 14 years 4 days ago #134240 by skybax
the error appears when a user post a message on a topic started by someone else and it tries to send the email notification to the subscribers.

If i post on a topic with no other members talking it doesn't show the error


And this is how the code looks
Code:
$topic = $this->getTopic(); if (count ( $emailToList )) { jimport('joomla.mail.helper'); if (! $config->getEmail() ) { KunenaError::warning ( JText::_ ( 'COM_KUNENA_EMAIL_DISABLED' ) ); return false; } elseif ( ! JMailHelper::isEmailAddress ( $config->getEmail() ) ) { #LINE 196 KunenaError::warning ( JText::_ ( 'COM_KUNENA_EMAIL_INVALID' ) ); return false; }
Last edit: 14 years 4 days ago by skybax.

Please Log in or Create an account to join the conversation.

More
14 years 4 days ago #134249 by sozzled
I don't know anything about this PHP class. However, I suggest that you uninistall (or upgrade) your version of Kunena Search plugin. See the important note about using old, out-of-date (and incompatible) software in the release notes for K 2.0.2.

Please Log in or Create an account to join the conversation.

More
14 years 4 days ago #134261 by skybax
i already uninstalled the 1.7.0 version and added 2.0.2

Please Log in or Create an account to join the conversation.

More
14 years 4 days ago #134299 by skybax
If i set Send E-mails to Users to No the users can post if i set it to Yes the Class 'JMailHelper' error appears

@xillibit if you need any more info just say

Please Log in or Create an account to join the conversation.

Time to create page: 0.235 seconds