×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Cannot break/continue 1 level in components/com_kunena/librarie​s/bbcode/bbcode.php on line 131

More
8 years 2 months ago - 8 years 2 months ago #1 by PCC
I'm doubting this has anything to do with Kunena, since it's so isolated, but I'm hoping someone might have a suggestion.
I've got one user on an entire forum that cannot view his profile tab since K2.x
He gets the following error;


He's the only one on the site that gets this. I did however just make him an admin, but other existing admins do not have any issues.
Any ideas?
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 5M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : footballcardcentral25 | author: Fins and Fur Hosting | version: 2.5 | creationdate: 2012-02-06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.6.2

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 8 years 2 months ago by PCC.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by sozzled
Three things:

(1) Is there some reason you enabled Community Builder integration when you do not have that component installed?

(2) Have your tried using the K 2.0 Blue Eagle template instead?

(3) As long as you are happy not using an alias menu to access your forum, I'm happy for you. I wouldn't recommend doing things that way but that's not my decision in your case. (But it may be a contributing factor that you should not overlook).

Likewise, I'm not exactly sure what is causing this particular problem (or why it only seems to be happening to only one member of your community). No doubt, the development team may have some input to this question.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #3 by PCC
Hi Sozzled,
I guess I didnt realize how significant an alias menu was, just over looked it.
I changed all that and turned off the Community Builder, which must have been turned on accidentally during the upgrade. But neither of those fixed the issue.
I have avoided the Blue Eagle template because everything in there says NOT to use it.

I'm noticing now that I'm getting the same error this member gets on his profile page but I get it when I try to enter one of two certain forums. They both give me the error and when I look how they are set up, they appear to have the same settings and permissions as the rest of the forums.
This is really stumping me.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago - 8 years 2 months ago #4 by sozzled

PCC wrote: I ... turned off the Community Builder, which must have been turned on accidentally during the upgrade.

... ???

PCC wrote: I have avoided the Blue Eagle template because everything in there says NOT to use it.

... please show us where you read that? Perhaps you are confusing the term "deprecated" with "do not, under any circumstances, use this, at your own peril" ... maybe? See the discussion Templates and Features in 2.0

The K 2.0 Blue Eagle template was designed for K 2.0. The K 1.7 Blue Eagle template - the one that you are using - should work, but it's not what we would describe as being "totally, 100%, fully compatible" with K 2.0.

Let's eliminate the possibility that your issue is the result of a Kunena template that may not be "100% compatible" and then we can examine other possibilities for why you're having problems.

I, too, am puzzled by this error that you're getting. If unresolved, please post your updated configuration report. I'm sure it will contain some fascinating information for the development team.
Last edit: 8 years 2 months ago by sozzled.
The following user(s) said Thank You: PCC

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #5 by PCC

Please select your old template instead of Blue Eagle 2.0. By doing this, Kunena turns on a legacy mode. Legacy mode loads all the images and CSS from your template, but takes everything else from Blue Eagle 2.0. This feature should work with most of the templates, but not all.


Here's an updated copy of my CR

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 5M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : footballcardcentral25 | author: Fins and Fur Hosting | version: 2.5 | creationdate: 2012-02-06

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.6.2

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #6 by sozzled

Please select your old template instead of Blue Eagle 2.0. By doing this, Kunena turns on a legacy mode. Legacy mode loads all the images and CSS from your template, but takes everything else from Blue Eagle 2.0. This feature should work with most of the templates, but not all.

Hmmm ... I'll have to find who wrote that and verify the information. Where does this quotation appear?

The intention is that, if you're upgrading from an older version of Kunena and you have a custom, third-party or privately-created, template then some of those older custom templates should work. If, howevr, you were using an unmodified K 1.7 Blue Eagle template, you are better advised to use the updated K 2.0 Blue Eagle template instead.

The wording is a little clumsy and confusing but the gist of it is that K 2.0 Blue Eagle template is a better template to use (for the time being) until we are in a position to offer you something even better (in K 2.1).

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #7 by PCC
Yeah after reading your post on the template it started to make sense. Your right, the wording on the administration side is pretty clumsy.

sozzled wrote: Hmmm ... I'll have to find who wrote that and verify the information. Where does this quotation appear?


It's located at Admin >> Components >> Kunena Forum >> Template Manager >> Blue Eagle 2.0 >> Edit


Do you know if my latest config report showed anything fascinating like you mentioned that might reveal why were getting these errors.
I'm considering running the upgrade again by uploading fresh files and overwriting everything, but I dont know if were dealing with a configuration issue, or a bad file, or...

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #8 by PCC

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #9 by Kaeros
This may sound crazy, but go into your forum setup, and turn of the eBay auto embedding. Fixed the problem on mine..

I did a google search for components/com_kunena/libraries/bbcode/bbcode.php and found where someone had it posted and parsed by line numbers, line 131 is a close for something to do with the eBay functionality. Went to my backend settings for the forum and turned that stuff off, and voila.

Hope it works for you and helps to get the issue cleaned up!
The following user(s) said Thank You: tinny, neujensl

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #10 by PCC
That worked :woohoo:
I had a couple categories that wouldnt let me in and gave the error, it cleaned that problem right up. I wonder why it effects certain categories.
I got one member that cant access his profile because of the error, I need to get a hold of him and have him check that too.

Anyway, thank you much for that. I was actually preparing to leave Kunena behind and go back to SMF. I'm blown away over the way the Devs turn their heads.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.180 seconds