×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question sh404SEF Aktifken Mesaj Önizleme Sorunu - Çözüldü

More
10 years 11 months ago - 10 years 11 months ago #1 by Firardaxman
Uğur hocam senden Allah razı olsun. Bu konu ile de ilgilenmeni rica ediyorum. Bu kadar kişiye cevap vermek, bu konularla ilgilenebilmek görüyoruz ki gerçekten kolay iş değil. Bu kadar fedakarlık gösteren biri için keşke bizde bişeyler yapsak, yapabilirmiyiz diye düşünüyorum şimdilik elimizden çok çok minnet duymaktan ve samimiyetle Allah razı olsun demekten başka bişey gelmiyor.

Uğur hocam bu anlatacağım hatanın çözümü benim için olduğu kadar bir çok kullanıcı içinde çok önemli. Bu konuya biraz daha önem verebilirsen bizleri çok sevindirirsin. Bu hatanın çözümü için denemediğim yöntem, yapmadığım deneme yanılma yolları kalmadı. Aklıma gelen her tütlü yöntemi denedim. Kurcalamadığım yeri kalmadı. Yine de olmadı.

Forumun geçmişi FireBoard forumun ilk sürümlerinden yükselte yükselte Kunena 1.0.8 sürümüne kadar gelmiştir. Belki aklına veritabındaki hatalardan olabileceği gelebilir. Veritabanındaki tablolarla hiç bir sıkıntının olmadığından emin olabilirsin.

Bu sorunu yaşayan bazı kullanıcılar site haritasını yüklediklerinde hatanın meydaha geldiğini yazmışlar. Muhtemelen Xmap veya Joomap birleşenini kullanmışlardır. Ben bu birleşenleri kurmadan da denedim aynı problem devam etti.

Sorun sh404SEF birleşeni ve sh404sef Plugin for Kunena 1.0.8 aktifken Kunena Forum yeni mesaj yazımlarında önizleme yapmıyor.

Yazılmış mesajlar değiştirden editlendiğinde önizleme yapıyor ama yeni mesajlarda önizleme yapmıyor.

ARTIO JoomSEF birleşeninde ise hiç bir şekilde önizleme yapmıyor. Ayrıca ARTIO JoomSEF birleşeni ektifken sağ köşedeki mesaj id numarasına tıklandığında forum anasayfasına dönüyor. Mesaj id numarasına tıklanınca forum anasayfasına dönme hatası ARTIO JoomSEF birleşeni ve Kunena Forum Plugini kullanan tüm sitelerde var. Fireboard içinde aynı hata geçerli. ARTIO JoomSEF kullananlardan bu hata ile karşılaşanlardan bazıları eklentisini kurunca düzeldiğini söylemişler fakat dediğim gibi denemediğim yöntem kalmadı ve benim denemelerimde aynı sorun devam etti. Bu nedenle daha az hata veren sh404SEF birleşenini kullanıyorum. sh404SEF birleşenininin sh404sef Plugin for Kunena 1.0.8 eklentisini sef_ext içine atınca forumda SEF şimdilik gayet mükemmel işliyor. Eklenti sadece bu sef_ext klasörü içine atılırsa tarayıcıda başlıklar link ile aynı görünüyor fakat eklenti meta_ext klasörünü de atılırsa tarayıcıda başlıklar düzeliyor. Bendeki durum bu şekilde. Tarayıcı başlıkları düzgün. Görmek isteyenler: Firardaxman.Com

Sorun forumun kullanımını olağanüstü şekilde etkilemekte konunun önemine binean Uğur hocam senden çok rica ediyorum konuya biraz daha önem vererek çözüme kavuşturman. Şimdiden yapacağın ve yaptığın büyük emekler ve fedakarlıklar için çok çok teşekkür ederim..
Last edit: 10 years 11 months ago by ugur.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #2 by ugur
Mesajı görünce korktum bu nedir diye ;)

components/com_kunena/template/default/js/kunenaforum.js

96 sıradakini bul
jQuery.ajax({url:"index2.php",

Bununla değiş
jQuery.ajax({url:"https://siteadı.com/index2.php",

siteadını yaz kaydet dene bakalım sonuç nedir.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #3 by Firardaxman
Uğur hocam bu cevapta zamanı da haraka oldu. Gece yarısı olduğu için ancak yarına cevap gelir derken saat 02:40 da hızlı cevap verdiğiniz ayrıca saolun. Sorun düzeldi. Çok teşekkür ederim.

Eğer ARTIO JoomSEF de mesaj id numarasından forum anasayfasına dönme hatası olmasa SEF olarak kullanacağım. Sorun düzelene kadar sh404SEF kullanmak daha mantıklı.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #4 by ugur
Last edit: 10 years 11 months ago by ugur.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #5 by s10nefer
aynı sorun bendede var ben artio kullanıyorum söylediğiniz kod değiyikliğini yaptım ama nafile load imaj görünüyor gerisi gelmiyor

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #6 by guerilla
s10nefer wrote:

aynı sorun bendede var ben artio kullanıyorum söylediğiniz kod değiyikliğini yaptım ama nafile load imaj görünüyor gerisi gelmiyor


Code:
jQuery.ajax({url:"index2.php",


Bununla değiş
Code:
jQuery.ajax({url:"index.php",

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #7 by voltran
Taşekkürler ben seni tanıyorummm Uğur hocam her yerde karşıma çıkıp illa senmi problemlerimi çözecen alla alla ya çok teşekkür ederim international the HELPMAN= Uğur Uygur :laugh:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.065 seconds