×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

Solved Google maps in Forenbeitrag einfügen

More
7 months 2 weeks ago - 7 months 2 weeks ago #1 by WezWeb
Hallo!

Auch ich schaffe es leider nicht die Karte richtig dargestellt zu bekommen... Google API ist (so glaube ich) richtig konfiguriert! Es erscheint die Meldung: Nicht in der Lage, Speicherort zu bestimmen, siehe Anhang.

In der Vorschau funktioniert der Link zu Google-Maps 100%. Auch hier funktioniert es tadellos!
Wo habe ich was übersehen? Ich bin dankbar für jede Antwort!

Gruß Marco


Unable to display Google Map.
[/b],
Attachments:
Last edit: 7 months 2 weeks ago by WezWeb.

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago #2 by rich
Bitte in Zukunft keine neuen Fragen in Themen erstellen, welche bereits als gelöst markiert sind. Diese sind nur noch zum lesen gedacht.

Warum bettest du den Code von Google Maps so wie hier noch zusätzlich in Codetags ein? Falls du dann eventuell auch noch die URL Tags verwendest, funktioniert es nicht.
[b][map type=ROADMAP zoom=8]Amsterdam[/map][/b]

jpgjpg wrote: Warum kompliziert, wenn's doch viiiiel einfacher geht !
Ein Klick auf das Editor-Icon "map" und zwischen den beiden Tags ganz einfach den Ort oder die Adresse eingeben - fertig, Karte erscheint, perfekt !!

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago - 7 months 2 weeks ago #3 by WezWeb
Ich habe keine neue Frage gestellt... Ich suche seit 3 Tage nach der Lösung welche ich nirgendwo finde. Ich nutze den ICON von KUNENA und trage da meine Stadt ein. Das Ergebnis hatte ich als Anhang beigefügt. Es erscheint die Karte im Bereich Helsinki mit der Meldung: "Nicht in der Lage, Speicherort zu bestimmen".

Die Codetags sind reingekommen weil ich eigentlich nur den Code fett erscheinen lassen wollte...

Zudem habe ich festgestellt, dass ich auch kein Bild einbeddden kann. Scheint ein generelles Problem bzw. eine Einstellung zu sein.

Es wäre super, wenn Sie mir die Lösung zu dem Problem geben könnten.

Vielen Dank!
Last edit: 7 months 2 weeks ago by WezWeb.

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago #4 by rich
Oft haben Benutzer zwar die selben Probleme, welche aber durch verschiedene Ursachen ausgelöst werden. Dadurch vermischen sich dann oft Themen, wo verschiedene Problembehebungen notwendig sind und es kann sehr unübersichtlich werden.

Grundsätzlich habe ich mal festgestellt, dass die Fehlermeldung falsch übersetzt wurde. Die Fehlermeldung sollte lauten „Angegebener Ort kann nicht ermittelt werden:“ anstatt „Nicht in der Lage, Speicherort zu bestimmen:“

Welche Kunena Version und welche Templates (Joomla und Kunena) verwendest du? Hilfreich wäre auch, wenn du einen Konfigurationsbericht erstellen würdest.

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago - 7 months 2 weeks ago #5 by WezWeb
zuerst mal Danke für die Unterstützung und bevor ich es vergesse; einen guten Rutsch ins neue Jahr und alles Gute!

Zum Einsatz kommt:
Joomla!-Version 3.8.3
PHP-Version 7.0.26
Kunena 5.0.12

Das Forum finden Sie auf
z-classic.nr1-inter.net/z-forum
Ich habe zur Verdeutlichung des Problems (vorläufig) ein Eintrag für Amsterdam hinzugefügt
z-classic.nr1-inter.net/forum/ausflugsziele/12-test

Ich habe den kompletten Konfigurationsbericht angehängt.

In der Vorschau funktioniert der Link zu Google Maps einwandfrei.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 50000 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.12 | creationdate: 2017-11-24

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.0.12 | 2017-11-24 [ Linsang ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 7 months 2 weeks ago by rich. Reason: Konfigurationsreport eingefügt und Anhang gelöscht

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago - 7 months 2 weeks ago #6 by rich
Ich habe deinen Konfigurationsbericht richtig eingefügt und den Anhang entfernt. Den Konfigurationsbericht solltest du nicht als Anhang hochladen. Anhänge kann man nämlich auch runterladen.

Danke, jetzt ist alles klar. Du hast keine Berechtigung, Google Maps anzeigen zu lassen.

Geocoding Service: This API project is not authorized to use this API. Please ensure this API is activated in the Google Developers Console:

Du musst die Google Maps Geocoding API in der Entwicklerkonsole anfordern und aktivieren. Hier bekommst du, was du benötigst:
Api Key anfordern. Diesen Schlüssel musst du dann in der Konfiguration eintragen.
Last edit: 7 months 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago - 7 months 1 week ago #7 by WezWeb
Alles Gute für 2018!

Genau da liegt das Problem... Ich habe die Google Zugangsdaten (API-Schlüssel) erstellt und aufgrund des Test noch keine Einschränkung konfiguriert. Trotzdem funktioniert es nicht. Lasse ich den Code weg oder setze einen anderen Code ein, erscheint keine Karte sondern eine Meldung: Hoppla! Ein Fehler ist aufgetreten. Google Maps wurde auf dieser Seite nicht richtig geladen. Technische Details dazu entnimmst du der JavaScript-Konsole.

Google Maps JavaScript API ist aktiviert.

Daher vermute ich ein Fehler in meiner KUNENA-Konfiguration.
Last edit: 7 months 1 week ago by WezWeb.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago - 7 months 1 week ago #8 by rich
In der Kunena-Konfiguration kannst du, außer einer Eingabe eines falschen Codes, keinen Fehler machen. Allerdings sehe ich, dass es in deinem Forum jetzt richtig funktioniert. Was war der Fehler?
Last edit: 7 months 1 week ago by rich.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #9 by WezWeb
Ich habe über die englischsprachige Google-Seite auf meinem Account ein neuer Key angelegt... Diese (standardmäßig als API key benannt) hat auf Anhieb richtig funktioniert. Danach habe ich den Schlüssel welche auf der deutschen Seite konfiguriert wurde gelöscht.

Trotdem vielen Dank!

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #10 by rich

Ich habe über die englischsprachige Google-Seite auf meinem Account ein neuer Key angelegt

Dann ist also doch der alte Schlüssel daran schuld gewesen. Vielleicht wurde dieser einfach nicht erkannt, oder nicht mehr akzeptiert. Aber das ist egal, wenn es mit dem neuen Schlüssel jetzt funktioniert.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.127 seconds