×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Question Foren geteilt nach Menüpunkten darstellen

More
5 years 2 weeks ago #1 by Fenris Ulfur
Hallo.

Ich war auf der Suche nach einer Möglichkeit Kunena zu klonen.. Durch einen Thread im Archiv bin ich aber auf eine einfachere Lösung gestossen, die mir sehr gefällt. (sieht hier: www.kunena.org/forum/german-k-2-0-and-k-...-mal-kunena-moeglich )

Das klappt soweit wunderbar. Das einzige Problem das ich habe ist das mir jetzt überall die "obere Menüleiste" fehlt, sprich Neues Thema, Ohne antwort, Meine Themen, Profil, Suche oder der Button "Alles als gelesen markieren", etc.
Es wird also nur stur die Kategorie des Forums angezeigt, was schon einmal klasse ist um ein Forum in verschiedene Menüpunkte aufzuteilen.

Kann man diese "Leiste und Button" auch auf solch einen einfachen Wege überall wieder anzeigen lassen?
Wenn ja, wie?

Danke für Zeit und Mühen

Fenris

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago #2 by rich
Ich nehme mal an, dass du die neu erstellten Menüpunkte in ein anderes Menü verschoben hast. Wie du es richtig machst, kannst du hier sehen:
www.kunena.org/docs/Men%C3%BCprobleme

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #3 by Fenris Ulfur
Hallo rich.

Der Meistro persönlich, da bin ich also richtig :)

Nein, ich habe nichts verschoben, daher stehe ich auch auf dem Schlauch.
Vielleicht zur Vorabinfo.
Joomla 3.4.3, Kunena 4.0.5, sonst keinerlei Erweiterungen von Dritten.

Wie ich vorgegangen bin:
Joomla Backend
Menüs -> Kunenamenü
Neu -> Titel "Testkat" -> Menüeintragstyp: Kategorie anzeigen -> Kategorie ID: Die Kategorie ausgewählt die dargestellt werden soll -> Speichern&Schließen
Menüs -> Mainmenü
Neu -> Titel "Testkat1" -> Menüeintragstyp: Systemlink -> Menüalias -> Alias verlinken mit: Alias des vorher neu erstellten Menüpunktes bei Kunenamenü gewählt -> Unter Manüzuordnung die Stelle ausgewählt an der sie erscheinen soll -> Speichern&Schließen

Im Frontend sehe ich allerdings leider keine Menüleisten wie oben beschrieben.

War das falsch verstanden meinerseits?

Danke Dir

P.S. Kann Dir gerne einen Testaccount erstellen für Backend um mal drüber zu sehen wenn du soviel Zeit entbehren kannst?

MfG
Fenris
Last edit: 5 years 2 weeks ago by Fenris Ulfur.

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago #4 by rich
Du kannst mir einen Testaccount erstellen. Wenn du die Zugangsdaten in folgende Codetags einbettest, dann können diese Daten nur du und wir Moderatoren sehen.
[confidential]Zugangsdaten[/confidential]

Aber ich denke, dass ich deinen Fehler auch so schon gefunden habe.

Menüs -> Kunenamenü
Neu -> Titel "Testkat" -> Menüeintragstyp: Kategorie anzeigen -> Kategorie ID: Die Kategorie ausgewählt die dargestellt werden soll -> Speichern&Schließen

Einen Schritt hast du vergessen. Du darfst den neu erstellten Kunnena-Menüpunkt nicht als oberste Menüebene lassen (siehe Bild). Du musst „Forum“ auswählen.

Attachments:
The following user(s) said Thank You: Fenris Ulfur

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #5 by Fenris Ulfur
Genau das war es :)

Vielen Dank rich.

Dann kann ich weiter basteln.

MfG
Fenris

P.S.: Vielleicht noch kurz. Wenn ich alle unter den Punkt Forum schiebe dann werden diese auch immer in der Leiste allsamt angezeigt und die Leiste füllt sich bis ultimo. Wenn ich einen neuen Punkt erstellt und diesen als SubSub also Forum->Punkt1->->Punkt2 erstelle wird mir immer nur der eine angezeigt? War zwar nur nen Versuch, aber war das so gewollt? (wenn nicht, auch egal, find ich gut^^)
Last edit: 5 years 2 weeks ago by Fenris Ulfur.

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago #6 by rich
Ich wusste nicht, dass du diese zusätzlichen Tabs nicht in der Leiste haben willst. Es gibt zwei Möglichkeiten diese zu entfernen. Entweder du blendest diese einzeln via css aus, was jedesmal zusätzliche Arbeit bedeutet, oder du verwendest statt „Alias“ Links, die Variante mit externen URLs.

Das hat auch den Vorteil, dass du dafür nicht extra jedesmal einen neuen Kunena-Menüpunkt erstellen musst. Lies bitte im ersten Absatz Pukt 4 noch mal durch. www.kunena.org/docs/Men%C3%BCprobleme

Zitat:
Manchmal ist es nicht möglich, einen Menüeintrag-Alias“ zu erstellen, da das Ziel in der Liste nicht enthalten ist, z.B. wenn man direkt auf eine Kategorie verlinken will. In diesem Fall kann man auch den Menüeintrag „Externe URL“ verwenden. Um den richtigen Eintrag zu finden, ruft man die betreffende Kategorie auf und kopiert den Link von der Browser Adressleiste. Wenn die Adresse z.B. „www.deinewebseite.de/forum/kategoriename“ lautet, dann reicht es, nur “forum/kategoriename“ zu kopieren und als Zieladresse anzugeben.

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #7 by rich
Nachtrag:
Ich empfehle dir, falls du die Methode mit den externen URLs verwendest, trage nicht die komplett Webseiten URL ein, sondern nur den hinteren Teil, der zum Forum führt (relative URL). Es würde zwar genauso funktionieren, aber wenn du mal mit deiner Webseite übersiedeln willst, müsstest du diese Links alle korrigieren.
Last edit: 5 years 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago #8 by Fenris Ulfur
Hallo rich.

Danke für den Hinweis, habe das auch gleich mal probiert um zu sehen wie es klappt und wie es wirkt. Habe hier allerdings zwei Probleme ausgemacht.

Ich habe also wie vorher die Menüpunkte neu angelegt und statt den Alias Externe genutzt. Mein erster Versuch war wie beschrieben (in meinem Fall jetzt einmal) nur das /forum/testkat und als zweites forum/testkat2 eingetragen.
Aktualisiere ich dann die Seite und klicke auf den ersten Link macht er auf, wie er soll.
Klicke ich dann auf den zweiten steht in der Browserzeile: https://meinedomain/index.php/forum/testkat2/forum. Klicke ich nun wieder auf ersten es reproduziert, hier ist der Link dann https://meinedomain/index.php/forum/testkat2/forum.
Es hängt mir am Ende also immer einmal /forum dran, was nicht sein sollte.

Und das nächste ist das die einzelnen Reiter immer noch angezeigt werden würden.

Verwende ich stattdessen komplette Links, dann klappt es.
Aber auch hier blenden die Reiter nicht aus, sondern stehen der Reihe nach wieder aufgeführt da.
Index habe ich im Kunenaforum hierbei versteckt. Verstecke ich allerdings auch die beiden Punkte bekomme ich keinen Zugriff und stattdessen Fehler 404.

Habe auch immer mal den Cahce geleert im Browser und andere Browser versucht, aber war das gleiche Ergebnis.

Werde die Tabs wohl dennoch hinnehmen, da es auch ne Art Schnellauswahl wäre für den User ohne wieder über das Mainmenue zu müssen.

Was mir noch aufgefallen ist: "Alles als gelesen markieren", sowie "Schnellsprung" werden ebenfalls nicht angezeigt.

MfG
Fenris

Please Log in or Create an account to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #9 by rich

Es hängt mir am Ende also immer einmal /forum dran, was nicht sein sollte.

Verwende ich stattdessen komplette Links, dann klappt es.
Aber auch hier blenden die Reiter nicht aus, sondern stehen der Reihe nach wieder aufgeführt da.

Das kann ich nicht nachvollziehen, irgendetwas läuft da schief. Aber so wie ich es verstehe, hast du trotz URL Link den Kunena-Menüpunkt erstellt. Da hatte ich mich wohl etwas ungenau ausgedrückt.
Aber egal, mache es so weiter, wie du es vorher gemacht hattest (mit Alias), da es im Prinzip der korrekte Vorgang ist.

Verstecke ich allerdings auch die beiden Punkte bekomme ich keinen Zugriff und stattdessen Fehler 404.

Das ist richtig, da durch verstecken auch der Zugriff gesperrt wird. Diese Adresse lässt sich dann nicht aufrufen.

Was mir noch aufgefallen ist: "Alles als gelesen markieren", sowie "Schnellsprung" werden ebenfalls nicht angezeigt.

Ja, dies wird nur auf der Index Seite angezeigt, da mit dieser Funktion sämtlich Beiträge in allen Kategorien als gelesen markiert werden. Du hättest keine Kontrolle darüber, was du alles als gelesen markierst. Du kannst in einer Kategorie nur die Beiträge der aufgerufenen Kategorie als gelesen markieren.
Der Schnellsprung sollte vorhanden sein, nur findest du diesen in den Kategorien unten.

Werde die Tabs wohl dennoch hinnehmen, da es auch ne Art Schnellauswahl wäre für den User ohne wieder über das Mainmenue zu müssen.

Normalerweise ist anzunehmen, dass es bei so einem Forumaufbau nicht allzuviele Kategorien gibt, da ansonsten das Mainmenü irrsinnig lang werden würde. Aber hinnehmen musst du ungewollte Tabs nicht. Diese lassen sich ganz leicht ausblenden.
Wenn du ins Kunenamenü gehst, siehst du bei jedem Menüpunkt rechts die ID. Deinen Beiträgen entnehme ich, dass du das Template Blue Eagle verwendest. Gehe in die Kunena Templateverwaltung, markiere Blue Eagle, dann klicke auf CSS bearbeiten > markiere die custom.css > CSS Bearbeiten.
Dort fügst du einfach folgenden Code ein und speicherst (die IDs musst du von deinen Menüpunkten nehmen).
.item710 { display: none; }
Du kannst auch gleichzeitig mehrere Menüpunkte mit diesem Code ausblenden z.B:
.item717, .item710 { display: none; }
Du kannst diesen Code aber auch ans Ende in deine Joomla custom- oder template.css einfügen.
Last edit: 5 years 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 3.878 seconds