×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Question Bouton "pièce jointe inactif"

More
4 months 2 weeks ago #1 by Supradine
Bonjour

J'utilise Joomla 3.9.28 et Kunena 5.2.5.

Mon bouton pièce joint est inactif ( quand je clique dessus rien ne se passe ) et je n'arrive pas à l'activer. Je suis sous chrome et j'ai essaye en edge... même résultat.

Merci pour votre aide

Voici le code du bouton :
<button class="btn art-button" id="kshow_attach_form" type="button"><span class="glyphicon glyphicon-paperclip" aria-hidden="true"></span> Pièces jointes</button>
                                    <div id="kattach_form" style="display: none;">
                                        <span class="label label-info">Extensions de fichier autorisées: jpg, jpeg, gif, png, txt, rtf, pdf, zip, tar.gz, tgz, tar.bz2</span><br><br>
                                        <span class="label label-info">Taille max. pour les fichiers <br><em>en Kilobytes</em>: 2.9 MB Taille maximum de images<br><em>en Kilobytes</em>: 0.1 MB</span><br><br>
                                        <!-- The fileinput-button span is used to style the file input field as button -->
                                        <span class="btn btn-primary fileinput-button">
                                            <span class="glyphicon glyphicon-plus" aria-hidden="true"></span>
                                            <span>Ajouter des fichiers</span>
                                            <!-- The file input field used as target for the file upload widget -->
                                            <input id="fileupload" type="file" name="file" multiple="">
                                        </span>
                                        <button id="insert-all" class="btn btn-primary art-button" type="submit" style="display:none">
                                            <span class="glyphicon glyphicon-upload" aria-hidden="true"></span>
                                            <span>Insérer tous</span>
                                        </button>
                                        <button id="remove-all" class="btn btn-danger art-button" type="submit" style="display:none">
                                            <span class="glyphicon glyphicon-remove" aria-hidden="true"></span>
                                            <span>Supprimer tous</span>
                                        </button>
                                        <!-- The container for the uploaded files -->
                                        <div id="files" class="files"></div>
                                        <div id="dropzone">
                                            <div class="dropzone">
                                                <div class="default message">
                                                    <span id="klabel_info_drop_browse">Vous pouvez déposer des fichiers ici ou utiliser le bouton Ajouter des fichiers.</span>
                                                </div>
                                            </div>
                                        </div>
                                    </div>
 

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #2 by xillibit
Bonjour,

Il y a surement une erreur javascript, dans la console de développement de votre navigateur sous l'onglet javascript regardez si il y a des erreurs. Si il y en a pouvez-vous les  ajouter dans votre réponse ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago - 4 months 1 week ago #3 by Supradine
Merci pour votre aide, voici le résultat dans la partie console... aucune idée si ca a un rapport avec le bouton en question

Failed to load resource: the server responded with a status of 404 ()
jquery-ui.min.js:1 Failed to load resource: the server responded with a status of 404 ()
jquery.fileupload-min.js:1 Uncaught TypeError: b.widget is not a function
    at jquery.fileupload-min.js:1
    at jquery.fileupload-min.js:1
    at jquery.fileupload-min.js:1
jquery.fileupload-process-min.js:1 Uncaught TypeError: Cannot read property 'fileupload' of undefined
    at jquery.fileupload-process-min.js:1
    at jquery.fileupload-process-min.js:1
    at jquery.fileupload-process-min.js:1
jquery.fileupload-image-min.js:1 Uncaught TypeError: Cannot read property 'fileupload' of undefined
    at jquery.fileupload-image-min.js:1
    at jquery.fileupload-image-min.js:1
    at jquery.fileupload-image-min.js:1
upload.main-min.js:1 Uncaught TypeError: Cannot read property 'fileupload' of undefined
    at HTMLDocument.<anonymous> (upload.main-min.js:1)
    at l (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at Function.ready (jquery.min.js:2)
    at HTMLDocument.A (jquery.min.js:2)
jquery-ui.css:1 Failed to load resource: the server responded with a status of 404 ()
Last edit: 4 months 1 week ago by Supradine.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #4 by xillibit
Bonjour,

Le script jquery-ui.min.js est introuvable, ensuite les scripts suivants sont dépendant entre du coup ça génère des erreurs

Est-ce que vous pouvez regarder si le script jquery-ui.min.js est bien présent ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #5 by Supradine
Merci de votre réponse,

Sous \plugins\kunena je ne le trouve pas, mais il existe sous d'autres répertoires.
- \media\com_hikashop\js
- \media\com_acymailing\js\jquery
- \media\com_acym\js\libraries
- \components\com_jce\editor\libraries\jquery\js

Dois-je refaire l'installation, c'est une migration d'une version 3 (de mémoire)

Merci

Please Log in or Create an account to join the conversation.

More
4 months 3 days ago #6 by xillibit
Bonjour,

Je viens de vérifier jquery-ui.min.js est chargé en même temps que le chargement de jQuery dans Kunena. jQuery est bien chargé dans votre page avant les scripts de Kunena ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 months 2 days ago - 4 months 2 days ago #7 by Supradine
Bonjour,

J'ai trouvé, c'était jquery qui n'était pas a jour.

Impossible de mettre [reglé] dans le titre du sujet.

Merci pour tout.
Last edit: 4 months 2 days ago by Supradine.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.099 seconds