×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese gestellt werden.
Aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern. Eröffnet dazu bitte ein eigenes neues Thema.

Question [erledigt] Beiträge nach verschieben verschwunden

More
10 years 6 months ago - 10 years 6 months ago #1 by Michigs
Hallo zusammen,

in meinem Kunena-Forum gab es 94 Beiträge. Die Anzahl wird mir auch beim "Nachzählen der Forenstatistik" angezeigt: "Allgemeine Statistik: Antworten insgesamt: 94".

Auf der Forum-Frontpage werden aber nur noch "Gesamte Beiträge: 76" angezeigt.

Folgende Aktion habe ich vorab durchgeführt:

Ich habe eine Kategorie mit Unterforen über das Pull-Down-Menü im Backend (unter Forum-Administration) in eine andere Kategorie verschoben. Die Beiträge wurden dann auch dort als Unterkategorie angezeigt, aber nicht so wie ich wollte. Daher habe für die verschobenen Beiträge wieder die ursprüngliche Kategorie ausgewählt. Nun sind die Beiträge nicht mehr im Back- und Frontend zu finden. :S
Das einzige was noch an die Beiträge erinnert ist die oben genannte Zahl "94" :(

Wenn ich auf "Bereinigen der Foren" klicke, kann ich die verschwundene Kategorie noch sehen, aber wie gesagt in der "Forum-Administration" ist die Kategorie + Unterforen aus dem Pull-Down-Menü verschwunden. Ich habe alle Foren bereinigt und das Forum de- und dann wieder installiert. Aber das hat nicht geholfen. Hat jemand eine Idee, wie ich die Beiträge wiederholen kann?

Vielen Dank
Michael
Last edit: 10 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago - 10 years 6 months ago #2 by rich
Erstmal herzlich willkommen Michael!

Ich befürchte, dass du diese Beiträge gelöscht hast. Du hast die Foren bereinigt, das bedeutet nichts anderes, als dass Themen, in denen über einen gewissen Zeitraum nichts geschrieben wurde, gelöscht werden. Standardeinstellung sind 30 Tage.
Damit die richtige Statistik wieder angezeigt wird, musst du danach die Statistiken nachzählen lassen.
Falls du vorher keine Sicherung deiner Datenbank gemacht hast, kannst du diese Themen als "nicht mehr vorhanden" verbuchen.
Last edit: 10 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #3 by Michigs
Hallo Rich,

ich habe die 3 goldenen Computerregeln befolgt: 1) speichern 2) speichern & 3) speichern. Insofern habe ich einen Dump vorab gemacht. Eben habe ich einen neuen Dump gemacht und ab Zeile 5246 alle(!) 94 Einträge gefunden. Natürlich nicht so schön formatiert (diverse \\\\ dadrin). D.h. alle Einträge stehen noch in der Datenbank.

Beim bereinigen der Foren habe ich den Defaultwert auf 10.000 erhöht. Das sollte reichen. Ich habe diese Funktion einmal durchlaufen lassen, in der Hoffnung, da tut sich etwas und die Beiträge sind wieder im Forum.

Beigefügt habe ich ein jpeg vom Backend: nach ausführen der Funktione "Nachzählen der Forenstatistik. Ergebnis: 94 Einträge, wie im Dump zu finden. Im Frontend werden nur 76 Beiträge gezählt und auch nur angezeigt. Wie geschrieben, ich hatte eine Kategorie verschoben und dann die Verschiebung über das Pulldown-Menü wieder rückgängig gemacht und zack waren die Beiträge nicht mehr im Frontent zu finden.

Mir ist auch aufgefallen, das beim Funktionspunkt: "Bearbeiten einer Kategorie" -> Name des Forums und dessen Beschreibung -> Aktuell: das Pulldown-Menü nicht mehr die gesuchte Kategorien enthält. Die verschwundenen Katagorien werden aber noch unter "Bereinigen der Foren" -> "Zu bereinigende Foren auswählen:" im Pulldown-Menü angezeigt.
Hilft das weiter?
Vielen Dank
Michael
Attachments:

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago - 10 years 6 months ago #4 by Michigs
Kleiner Nachtrag zum ebigen Beitrag:
über die Backend-Statistik: "Beliebteste Themen" sind von den Top5 zwei verschwunden.
Die funktionieren 3 Links habe am Ende diese Variablen:

1)...com_kunena&Itemid=81&func=view&id=58&catid=32
2)...com_kunena&Itemid=81&func=view&id=48&catid=32
3)...com_kunena&Itemid=81&func=view&id=41&catid=32

Die verschwunden beiden aus den Top5 enden wie folgt:

4)...com_kunena&Itemid=81&func=view&id=15&catid=23
5)...com_kunena&Itemid=81&func=view&id=12&catid=21

Diese Werte finden sich auch im aktuellen Dump
z.B. zu 4) INSERT INTO `jos_fb_messages` VALUES (12,0,12,21,...

Der Link funktioniert aber leider nicht mehr :dry:

Ich arbeite mit Version 1.5.9.

Viele Dank
Michael
Last edit: 10 years 6 months ago by Michigs.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #5 by rich
Hasllo Michael,

der Unterschied in der Statistik ergibt sich dadurch, da im Backend alles angezeigt wird und im Frontend nur was frei gegeben ist. Hast du einige nicht veröffentlichte Themen?

Aber wie es scheint, wurde bei dir durch das Verschieben einiges durcheinander gewirbelt. Wenn du einen Dump hast, ist es kein Problem, die Themen und Beiträge wieder her zu stellen.

Dazu bräuchtest du nur vom gestrigen Dump folgende Daten zurück kopieren. Dann wäre der Zustand von gestern wieder hergestellt.
jos_fb_categories
jos_fb_messages
jos_fb_messages_text

Wenn aber heute schon wieder neu gepostet wurde, dann fehlen diese Beiträge wiederum, wobei du diese mit phpmyadmin auch einzeln zurück kopieren könntest. Hast du einen Testserver?

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #6 by Michigs
Hallo Rich,

die 94 Beiträge waren alle freigegeben und wurden auch angezeigt. Daneben gibt es auch stillgelegte Kategorien. Ich habe eben zum Test "alle" vorhandenen Kategorien/Foren im Backend freigegeben, aber das hat nicht geholfen. Im Frontend und im Backend wird die Kategorie mit den Unterforen nicht angezeigt.

was mich eben wundert ist:

in der Ausgangssituation hatte ich 2 Kategorien mit jeweils ca. 10 Unterforen:

1.Kategorie + 1-10 Unterforen
2.Kategorie + 1-10 Unterforen

jetzt habe ich im Backend (auch im Frontend)nur noch:

1.Kategorie + 1-10 Unterforen

die zweite Kategorie mitsamt den 10 Unterforen ist aus dem Backend unter der "Forum-Administration" und im Frontend verschwunden. Auch im Pulldown Menü im Backend unter "Forum-Administration" ist die 2.Kategorien als Auswahl verschwunden.

Im Backend aber unter "Foren Bereinigung", kann aber noch die 2.Kategorie + 1-10 Unterforen ausgewählt werden. Das finde ich merkwürdig.


Das Einspielen der 3 Tabellen:
jos_fb_categories
jos_fb_messages
jos_fb_messages_text
möchte ich gerne versuchen. Ich habe mittels phpmyadmin die jos_fb_categories ausgewählt und auf importieren geklickt. Dabei wird allerdings der ganze Dump eingelesen. Das möchte ich nicht, da ich an dem Tag doch etwas mehr geändert hatte.

Ich kann Hilfe gebrauche, wie ich die drei Tabellen isoliert importieren kann.
Ich habe da einen SQL Befehl gegoogelt:

LOAD DATA LOCAL INFILE 'c:/temp/xxxxxxx' INTO TABLE mydb.xxxxxxxx;

Habe aber noch keinen Testserver :S und bin mir daher nicht sicher, ob das auch der richtige Weg ist. Alternativ könnte ich vielleicht aus dem Dump die Tabelleninformationen für die 3 Tabellen isoliert abspeichern und dann nur die importieren.

Reicht es wenn ich diese Infos + die Infos für die anderen beiden Tabellen in eine Text-Datei zusammen kopieren und dann nur diesen Inhalt über phpmyadmin importiere?

Oder gibt es vielleicht doch eine ganz einfache Alternative die 3 Tabellen direkt zu importieren?

Viele Dank
Michael

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago - 10 years 6 months ago #7 by rich
Hallo Michael,

dass mit den verschiedenen Statistiken lass jetzt einfach mal beiseite. Es muss irgend etwas gewaltig daneben gegangen sein, denn mit dem Pulldown Menü kannst du normalerweise keine Kategorien miteinander vermischen. Aber du hast selbst den richtigen Ansatz gefunden, wie du es auf relativ einfache Weise wieder her stellen kannst.

Wenn du mysqldumper benutzt, dann kopiere über diesen mit "Wiederherstellen bestimmter Tabellen" einfach aus dem funktionierenden Dump diese drei Tabellen wieder zurück und alles ist fertig.

Wenn du nur phpmyadmin hast, wird es etwas komplizierter.

1.) Zuerst mach wieder eine neue Datenbanksicherung.
Danach leerst du die Datenbank und kopierst du den alten Datenbankdump zurück, bei dem noch alles funktioniert hatte.

2.) Danach hast du deine Webseite samt Forum wieder in dem alte Zustand, wo noch alles funktioniert hatte. Überprüfe, ob alles vorhanden ist und wenn alles in Ordnung ist, dann exportierst du mit phpmyadmin nur diese drei besagten Tabellen als zip oder gzip komprimiert und speicherst sie am Desktop ab.

3.) Nun machst du das ganze wieder rückgängig und spielst wieder die aktuelle Datenbank auf den Server, dann hast du wieder den "Jetztzustand" mit den verschwundenen Kategorien.

4.) Jetzt wählst du mit phpmyadmin wieder nur diese drei Tabellen aus und machst sie leer. (Wenn alles richtig gemacht ist, dann hast du danach zwar dein Forum, aber keine Kategorien und Beiträge mehr.)

5.) Wenn das geschehen ist, dann als letzten Schritt einfach nur über "importieren" mit phpmyadmin, die am Desktop abgelegten Tabellen (aus Schritt zwei) hochladen und das war es auch schon.
Du hast die Beiträge wieder und deine Änderungen bleiben erhalten. Nur, was in der Zwischenzeit gepostet wurde, ist danach weg. Falls es da welche gibt und du willst diese unbedingt haben, dann müsstest du diese Beiträge extra einzeln ex und importieren.
Last edit: 10 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #8 by Michigs
Hallo Rich,

jetzt habe ich wieder alle Beiträge :silly:

Vielen Dank für die ausführliche Anleitung. Mit phymyadmin hat es problemlos funktioniert.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #9 by rich
Freut mich, dass es geklappt hat. :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.114 seconds