×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese gestellt werden.
Aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern. Eröffnet dazu bitte ein eigenes neues Thema.

Question [Gelöst] Fatal Error kunena.debug.php on line 58

More
10 years 11 months ago - 10 years 11 months ago #1 by phutter
Hallo,
ich benötige dringend Hilfe.
Ich habe heute mein Forum auf Kunena 1.56 von 1.011 upgedatet und anschl. die deutschen
Sprachfiles eingestellt. Es schien auch alles zu klappen, aber als ich das Forum aufrief, war nichts wie zuvor, statt der erwarteten Kategorienübersicht kamm eine Seite voller Fehlermeldungen .
Forum Themen Antw. Letzter Eintrag
variable value
$0 "
key value
$file "/homepages/5/d178495571/htdocs/cms/components/com_kunena/lib/kunena.debug.php"
$line "44"
$function "debug_callstackinfo"
[args] Nested Array
"
$1 "
key value
$file "/homepages/5/d178495571/htdocs/cms/components/com_kunena/lib/kunena.debug.php"
$line "66"
$function "trigger_dberror"
[args] Nested Array
"
$2 "
key value
$file "/homepages/5/d178495571/htdocs/cms/components/com_kunena/template/default_ex/listcat.php"
$line "257"
$function "check_dberror"
[args] Nested Array
"
$3 "
key value
$file "/homepages/5/d178495571/htdocs/cms/components/com_kunena/kunena.php"
$line "620"
[args] Nested Array
$function "include"
"
$4 "
key value
$file "/homepages/5/d178495571/htdocs/cms/libraries/joomla/application/component/helper.php"
$line "162"
[args] Nested Array
$function "require_once"
"
$5 "
key value
$file "/homepages/5/d178495571/htdocs/cms/includes/application.php"
$line "124"
$function "renderComponent"
$class "JComponentHelper"
$type "->"
[args] Nested Array
"
$6 "
key value
$file "/homepages/5/d178495571/htdocs/cms/index.php"
$line "68"
$function "dispatch"
$class "JSite"
$type "->"
[args] Nested Array
"
Installed version: Kunena 1.5.6 | 2009-10-02 | 1806 [ Speaker ] | php 5.2.11 | mysql 5.0.67-log

Fatal error: Unable to load messages.\nDB function reports no errors in /homepages/5/d178495571/htdocs/cms/components/com_kunena/lib/kunena.debug.php on line 58




Es wäre sehr nett, wenn mir jemand helfen könnte, im Forum habe ich diese Fehlerkonstellation nicht gefunden.


Mit freundlichen Grüßen

Peter
Last edit: 10 years 11 months ago by phutter.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #2 by rich

Ich habe heute mein Forum auf Kunena 1.56 von 1.011 upgedatet und anschl. die deutschen
Sprachfiles eingestellt.

Was meinst du mit "Sprachfiles eingestellt"? Da gibt es keine Einstellungen.
Können wir davon ausgehen, dass vorher Joomla 1.5.x mit Kunena 1.0.11 gelaufen ist und du Kunena 1.5.6 darüber installiert hast?

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #3 by phutter
ja ich habe ursprünglich Kunena wie von Dir beschrieben upgedatet. Inzwischen aber habe ich auch die Version erst deinstalliert inkl Löschen der Dateien in der DB und dann neu installiert, ohne das dies das Ergebnis geändert hat.
Einstellen der Sprachfiles heisst hier kopieren der Sparchfiles ind die Verzeichnisse.
Die Sprachfiles scheinen nicht schuld zu sein, da der Fehler auch in der englischen Version auftritt.

Wer den Fehler live sehen will, schaue unter www.phutter.de dort unter dem Menüpunkt Forum (obere Leiste)
Mit freundlichen Grüßen

Peter
Last edit: 10 years 11 months ago by phutter.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #4 by phutter
Durch Ausprobieren habe ich jetzt eine Zwischenlösung erreicht.
Ich habe im Backoffice den Punkt Aktuelle Beiträge anzeigen auf NEIN gestellt, und schon wurden die kategorien richtig angezeigt. Der Fehler scheint also in der Statistik zu liegen [Vermutung off)

Ich brauche allerdings immer noch Hilfe, da der Fehler natürlich wieder auftritt, wenn jemand auf Aktuelle Beiträge klickt.
mfg

Peter
Last edit: 10 years 11 months ago by phutter.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #5 by rich

Der Fehler scheint also in der Statistik zu liegen [Vermutung off)

Versuche mal die Statistik zu deaktivieren. Im Backend ganz unten.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #6 by rich
Schau mal, was ich gefunden habe. Hier dürfte es sich um ein ähnliches Problem handeln.

www.kunena.com/forum/138-support/31365-upgrademigration-problem
Last edit: 10 years 11 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #7 by phutter
Hallo Rich,
nun habe ich die korrekte Fehlermeldung:

Fatal error: Unable to load messages.

DB function failed with error number 1054
Unknown column 'moved' in 'where clause' SQL=SELECT a.id, a.thread, a.subject, b.lastpost FROM jos_fb_messages AS a JOIN ( SELECT thread, MAX(time) AS lastpost FROM jos_fb_messages WHERE time >'1253675930' AND hold='0' AND moved='0' AND catid IN (1,2,8,9,10,12,13,14,15,16,17,18,19,20,21,23) GROUP BY 1) AS b ON b.thread = a.thread WHERE a.parent='0' AND a.moved='0' AND a.hold='0' GROUP BY a.thread ORDER BY b.lastpost DESC LIMIT 100
SQL =

SELECT
a.id,
a.thread,
a.subject,
b.lastpost
FROM
jos_fb_messages AS a
JOIN ( SELECT thread, MAX(time) AS lastpost
FROM jos_fb_messages
WHERE time >'1253675930' AND hold='0' AND moved='0' AND catid IN (1,2,8,9,10,12,13, in /homepages/5/d178495571/htdocs/cms/components/com_kunena/lib/kunena.debug.php on line 152

Vielleicht kannst Du oder ein anderer mir ja einen Tipp geben.
Thx für die bisher geleistete Hilfe

Mit freundlichen Grüßen

Peter

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #8 by phutter
Mein Problem ist dank mathias gelöst.
Es fehlte, warum auch immer, das Feld Moved in meiner Message - Tabelle.
Folgender Befehl brachte Abhilfe:

ALTER TABLE `jos_fb_messages` ADD COLUMN `moved` TINYINT(4) NULL DEFAULT '0' AFTER `hits`, COMMENT=''

Danke an alle die mir geholfen haben.

mfg

Peter

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.121 seconds