×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

× This category is for K 1.7 issues only.

Question Before you install Kunena 1.6 - check list

More
10 years 6 months ago - 10 years 6 months ago #1 by Matias
In most of the sites Kunena 1.6 installation or upgrade should work without getting any issues. But as nothing never goes as planned, I wrote a checklist that tries to solve most common issues before they happen.

Kunena 1.6 requires relatively new version of Joomla and also requires that your template, modules and plugins are compatible with Mootools 1.2. You can install Kunena into site that has incompatible software -- but you cannot have them in the same page together with Kunena.

Also all software that integrates with Kunena need to be upgraded and verified to be compatible to Kunena 1.6 before it can be safely installed. In worst case these old extensions can break the whole site.

It is HIGHLY RECOMMENDED to install Kunena 1.6 first into a COPY of your site. It allows you to make notes, ask our support and fix any potential issues (upgrade process, JavaScript conflicts, CSS issues, menu issues etc) while your real site is up and running.

Do not install Kunena 1.6 with Google Chrome -- Joomla 1.5.20 has redirection bug that makes the installation to fail.

Installation / upgrade steps:
  1. Take a backup
  2. Put our site offline
  3. Upgrade to Joomla 1.5.20 or newer (in Joomla 1.6 installation fails with K1.6.0 -- looking into it)
  4. Upgrade your template and its plugins (or make sure that your template is Mootools 1.2 compatible)
  5. Upgrade your SEF component (if you have any) and make sure that it supports Kunena 1.6
  6. Upgrade your AlphaUserPoints, CommunityBuilder, JomSocial and UddeIM components
  7. Upgrade all other software (optional)
  8. Enable System - Mootools Upgrade Plugin and test if everything works in your site (JavaScript)
  9. Check that your menu module supports Menu Aliases / Menu Links
  10. Take a backup
  11. Uninstall FireBoard / Kunena 1.5 modules and plugins
  12. Uninstall FireBoard / Kunena 1.5 to remove old files (optional)
  13. Install Kunena 1.6
  14. Install Kunena 1.6 modules and plugins (optional)
  15. Test that everything works when you're in Kunena (template, menus, BBCode editor etc)
  16. Take a backup
  17. Put your site back online
Last edit: 10 years 6 months ago by Matias.
The following user(s) said Thank You: mesutk, mickaoy, Tiago Wakabayashi, danielthai, rivbir786
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.053 seconds