×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K 1.7.2: Userlist columns not sortable

More
7 years 6 months ago - 7 years 1 month ago #1 by D4Real
I am using Chrome to view my site. When I click on the user list, the tool tip tells me I can click on a column to sort by it, but clicking the column heading does nothing.

How can I find out where the issue lies?

Kunena 1.7.2
Joomla 2.5.1
Last edit: 7 years 1 month ago by sozzled. Reason: Change topic icon to "solved"

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #2 by sozzled
G'day, D4Real, and welcome to Kunena.

Table sorting is handled by Javascript. It sounds like you have a Javascript issue with your site.

Please see msg #1 in the topic If you are having problems with Kunena, please read this first .

Please read the posting guide printed at the top of this page. The same information is shown in the Index page. I am guessing that the problem is a Javascript issue. I hope that the information I have given you helps.
Last edit: 7 years 6 months ago by sozzled.
The following user(s) said Thank You: D4Real

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #3 by D4Real
Ah, I see. So 112 is not 1.2

And I do not have system - mootools upgrade in my plugins list.

So, the issue is with my template since the header has .js version 112, and it doenst look like there is an easy way to just click upgrade i imagine?

Im not finding too much about upgrading mootools since i do not have the system - mootools upgrade

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #4 by sozzled
Although it's not common to find these kinds of Javascript issues cropping up in J! 2.5, it's not impossible if other Joomla extension developers devise their own Javascript "features" that actually have the effect of clobbering Joomla. These are matters that you really need to verify with the developers of those Joomla extensions that you are using.

I don't know anything about your website - you have not, for example, provided us with your Kunena configuration report - but, even if you gave us more details I still believe that we have identified the cause of the issue even if we have not pinpointed the exact Joomla extension that is responsible for making a mess of things. That, unfortunately, is something that only you are in a position to isolate. For background reading on some of these various problems, you may find this topic useful: Which came first? The template or the forum?
Last edit: 7 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #5 by D4Real
I turned on debugging and see no errors in the Early diagnosis of potential problem situations section.

I see that in the config above:
[u]System - Mootools Upgrade:[/u] Disabled | [u]System - Mootools12:[/u] Disabled
however, as I said, I do not have these in my plugin listing and can not find anything about installing them.

EDIT: I found packages for the 2 plugins. Enabled them and there has been no change.

I double checked the reference of what i thought was 112 earlier, but it appears to be a css version? It was on a listed on a css file i have.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 10M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : joomlage0039-microlite | author: Joomlage | version: 1.6 | creationdate: 05-05-2011

Kunena default template details : nts_kdark | author: 9ThemeStore | version: 1.7.0 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIm 2.6

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Enabled | Kunena Discuss 1.7.2

Modules: Kunena Login 1.7.2

Last edit: 7 years 6 months ago by sozzled. Reason: Minor edit/change topic subject

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #6 by Jiminimonka
EDIT your post fast and remove the
CODE
brackets from your Kunena config report - all the CONFIDENTIAL that only Kunena admin are meant to see is now visible to anyone.

Just paste the config report, un-edited into the bottom of your post.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
Last edit: 7 years 6 months ago by Jiminimonka.
The following user(s) said Thank You: D4Real

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #7 by D4Real

D4Real wrote: I turned on debugging and see no errors in the Early diagnosis of potential problem situations section.

I see that in the config above:

[u]System - Mootools Upgrade:[/u] Disabled | [u]System - Mootools12:[/u] Disabled
however, as I said, I do not have these in my plugin listing and can not find anything about installing them.

EDIT: I found packages for the 2 plugins. Enabled them and there has been no change.

I double checked the reference of what i thought was 112 earlier, but it appears to be a css version? It was on a listed on a css file i have.


I analyzed my site in Chrome using inspect element, switched to the scripts tab and found the mootools scripts that are running and it says:
MooTools={version:"1.4.3"
MooTools.More={version:"1.4.0.1"

So I imagine I am meeting the mootools 1.2 requirement?

When viewing the page in IE, everything works fine until I goto sort the userlist by a column. When i click the heading, nothing happens and error on page appears in the lower left throwing out

Webpage error details
Message: 'task' is null or not an object
Line: 4
Char: 242
Code: 0
URI: /media/system/js/core.js
Last edit: 7 years 6 months ago by D4Real.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 5 years 1 month ago #8 by sozzled
D4Real: You have the necessary Joomla Mooltools library installed, there is nothing else that you need to enable in J! 2.5.1. You have only read a small part of what is discussed in Common causes of Mootools (Javascript library) issues and Kunena . So let me paint the picture for you.

If you are running J! 2.5.1, for the sortable columns to work when you display the Kunena user list, you need the following Javascript libraries:
<script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
type="text/javascript"></script>
  <script type="text/javascript" src="https://xxxxxxx.xxx/components/com_kunena/js/mediaboxadvanced/js/mediaboxAdv.js"></script>
  <script type="text/javascript" src="https://xxxxxxx.xxx/components/com_kunena/template/default/js/default-min.js"></script>
This is what we find on your site:
<script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="https://usedprostock.com/components/com_kunena/template/default/js/debug.js" type="text/javascript"></script>
  <script src="https://usedprostock.com/components/com_kunena/js/mediaboxadvanced/js/mediaboxAdv.js" type="text/javascript"></script>
 
  <script src="https://usedprostock.com/components/com_kunena/template/default/js/default.js" type="text/javascript"></script>
  <script src="/plugins/system/jcemediabox/js/jcemediabox.js?version=112" type="text/javascript"></script>
  <script type="text/javascript" src="https://usedprostock.com/modules/mod_swmenufree/transmenu_Packed.js"></script>
  <script type="text/javascript" src="https://usedprostock.com/modules/mod_swmenufree/jquery-1.2.6.pack.js"></script>
<script language="javascript" type="text/javascript" src="/templates/joomlage0039-microlite/js/jscolor/jscolor.js"></script>
  <script type="text/javascript" src="/templates/joomlage0039-microlite/js/UvumiDropdown.js"></script>
If I had to guess what was responsible for your problem, I would say it's probably swMenuFree . Try uninstalling swMenuFree and see if that cures the problem. We have also received reports about JCE MediaBox causing problems with Joomla; that's another very likely possibility. Last, but by no means least, it's also possible that the Joomla template you are using has introduced Javascript that is incompatible with Joomla 2.5.1. This is something else that you may need to eliminate as the cause of your table-sorting problem.

The easiest way to prove that this is not a Kunena problem is to make a clean standard install of Joomla 2.5.1, add Kunena 1.7.2 (and make no other changes at all!) and then you will know if the user list column headers toggle as sort filters.

Does this sound like a reasonable plan to you, D4Real?
Last edit: 5 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #9 by D4Real

sozzled wrote: Does this sound like a reasonable plan to you, D4Real?


Ill do some playing around and see what I can do. You pointed out the 2 main components that I use to make my site do what I want, so if thats the case, I may run into issues being able to actually give it up. If I can at least pinpoint which one, I will contact the developer to see if something can be done to make it compatible.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #10 by sozzled
D4Real: The only point that I am trying to make is that, in the past, those two components have caused problems with Joomla (and, of course, that means how Joomla works so that Kunena can run). Follow these two links for more evidence of the problems we've received in the past: Link 1 ; Link 2 . I am not saying that I know for sure that these are the cause of the problem but I am suggesting that they are prime suspects for investigation.

You have a Javascript library loaded by a Joomla extension that is interfering with Joomla Mootools. You need to identify what it is.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.107 seconds