×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category is only for reporting defects or problems with Kunena 1.6 test versions with Joomla 1.6. This is NOT a support forum - there is no support for test versions. Users should NOT install K 1.6 alpha or beta test versions on websites with live production data.

Question Access Levels on K1.6.3 and J 1.6.1

More
8 years 8 months ago #1 by mve
Hi

I am designing a Joomla site based on 1.6.1 of the J release. I know that 1.6 should be used as a test and really this project is starting as a test site but will eventually turn into a production site. I want to add a forum and then integrate with CB. Looking around I found Kunena. However when I have installed it and create categories and forums in K I cannot assign everyone to view the forums and categories. Similarly if I assign public access it defaults to nobody. If I choose public front viewing and super users as admins then the public access level is set as super users. It seems that the admin permission writes to the public viewing or over riding it. I have read forum posts on here about this and just wondered whether this bug is a Kunena bug or a Joomla bug and if there is any lead time on this getting fixed?

thanks
The topic has been locked.
More
8 years 8 months ago #2 by brian.campo
Was anyone able to resolve this. I am getting the same issue and have tried reinstalling and several other things with no luck.
The topic has been locked.
More
8 years 8 months ago #3 by PlaneCDR
I am getting the same error. No idea on a timeline for Kunena 1.6.4 so I figure there will be no support regarding this issue with Joomla 1.6.
The topic has been locked.
More
8 years 7 months ago #4 by mve
Just updated to 1.6.3 still no luck. According to Joomla now they are no longer developing 1.6.x after 1.6.3 the next release will be July 10th and will be Joomla 1.7.0

Any Idea on when this can be fixed?
The topic has been locked.
More
8 years 7 months ago - 8 years 7 months ago #5 by oc666

mve wrote: Just updated to 1.6.3 still no luck. According to Joomla now they are no longer developing 1.6.x after 1.6.3 the next release will be July 10th and will be Joomla 1.7.0

Any Idea on when this can be fixed?

Hey All,
The problem is caused by the bad value of Public in the "Public Access Level" list. The value should be "0" but have the value of "1".
I've a hack to solve this. This hack done in the client.
USE AS FOLLOW:
  1. Use FireFox & FireBug
  2. Go to kunena configuration in the admin panel.
  3. Edit your category.
  4. Go to the "Settings" tab.
  5. Press right click on the option "Public" in the select list of "Public Access Level" and press on "Inspect Element" menu item.
  6. This would popup your firebug console.
  7. Update the value of the option "Public" to "0" (the original value is "1"), so the HTML would look like this:
    <option value="0">Public</option>
  8. Don't refresh the page but press "Save & Close" in the toolbar.
  9. After all of that, you should see your category in the category manager list with the public access of everyone.

If this works for you, consider to donate to my volunteer work via my blog (in my signature) :)

Best Regards,
oc666
Last edit: 8 years 7 months ago by oc666.
The topic has been locked.
More
8 years 7 months ago #6 by mve
Hi Tried this and yes it gives everyone access to the category & forums but cannot assign an admin access level. Any ideas?

thanks
The topic has been locked.
More
8 years 7 months ago #7 by ssnobben
Hope this will be solved in new version...

rgds
The topic has been locked.
More
8 years 7 months ago #8 by Mortti

mve wrote: but cannot assign an admin access level. Any ideas?

This problem is still in our tester's version of K 1.6.4 (in J!1.6.3)... there is not efect for the admin access level... I hope dev's can fix that soon.
The topic has been locked.
More
8 years 7 months ago #9 by xillibit
Yes, you are right, i'am looking that if i can find a fix

I don't provide support by PM, because this can be useful for someone else.
The topic has been locked.
More
8 years 7 months ago - 8 years 7 months ago #10 by Mortti
I have reported this a long time ago... but only for the Matias I think (too many report in skype B)) ... :unsure: my mistake...
Last edit: 8 years 7 months ago by Mortti.
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.108 seconds