×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

Question Forum Menu Item URLs vs Actual Kunena URL

More
9 years 6 months ago - 9 years 6 months ago #1 by BigDutch
Using Joomla 1.7.0 and Kunena 1.7.0 and Xmap 2.0

I created have a menu item : 'Kunena Forum' > 'Category' > Chose my category from the item list, published, made the alias 'discussion-board' and saved it

In the front end the hypelink is www.mydomain.com/discussion-board but when this is clicked it
is directed to www.mydomain.com/forum/{my-category-name-selected-in-menu-item}.

In real world usage practice this works fine, if not expected, however in the Xmap sitemap (with Xmap - Kunena Plugin enabled) i choose my main menu including the aforementioned Kunena menu item (and do not include KUNENA menu itself). I see all my Kunena topics using the url format as follows :

www.mydomain.com/discussion-board/{topic_id}-{topic_title} but when clicked this actually becomes
www.mydomain.com/forum/{category_name}/{topic_id}-{topic_title}

Again not a problem from my perspective, however google webmaster has highlighted to me that it is being redirected and that mysitemap should go straight to the final destination.

Any ideas ?
Last edit: 9 years 6 months ago by BigDutch.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #2 by Matias
XMAP plugin doesn't work for Kunena 1.7 because of a small bug in it. I've just written improved plugin for Joomla! 1.5, but I've not yet converted it to Joomla! 1.7.

If someone wants to do the task for me, J!1.5 version can be found in: www.kunena.org/forum/168-k-16-and-k-17-s...in-kunena-170#107782

Your issue is separate to XMAP: please edit Kunena Menu (menu in Joomla) and rename alias 'forum' to 'discussion-board'. I think you should also change your own menu item to be menu alias instead of Kunena category type.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #3 by BigDutch
In the not too distant future i will have 5 area menu's each with content centric to that area, so each menu will have a link to a dedicated forum (ie category) in kunena. So when in area a, you click discussion board, you find yourself looking at posts about area a, in area b you get posts about area b, the latest module would be filtered along the same lines.

I can fix as you say right now because i only have 1 category and the site only caters for one area, but is my future 'plan' scuppered ?

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #4 by Matias
OK, I get what you're doing and that works, but there may be further issues with XMAP plugin because I just figured out that it doesn't support what you're doing (the old one doesn't even support Kunena 1.6 well enough).

Ron has done something similar in www.playshakespeare.com

There's one forum, but every play has also link to Kunena forum category.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #5 by BigDutch
ok i created a category forum link in my kunena menu, then made an alias in my main menu, that all performs fine in the front end. Perhaps as you have suggested the XMAP plugin has a problem as there are now no forum posts in the sitemap, even though both main menu and kunena menu items are listed.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.056 seconds