×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Trying to install Kunena - having problems with directory permissions

More
10 years 5 months ago - 10 years 4 months ago #1 by tbarlow
I am trying to install Kunena In too my Joomla Site and when I do I get this erro when I have debug on

-1 - An error has occurred.
Unable to create target folder


Call stack
# Function Location
1 JAdministrator->dispatch() /user/homepages/virtual/eacentral/eabytes/administrator/index.php:67
2 JComponentHelper->renderComponent() /user/homepages/virtual/eacentral/eabytes/administrator/includes/application.php:136
3 require_once() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/application/component/helper.php:162
4 JController->execute() /user/homepages/virtual/eacentral/eabytes/administrator/components/com_installer/admin.installer.php:44
5 InstallerController->doInstall() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/application/component/controller.php:236
6 InstallerModelInstall->install() /user/homepages/virtual/eacentral/eabytes/administrator/components/com_installer/controller.php:71
7 JInstaller->install() /user/homepages/virtual/eacentral/eabytes/administrator/components/com_installer/models/install.php:86
8 JInstallerComponent->install() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/installer/installer.php:332
9 com_install() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/installer/adapters/component.php:293
10 JFolder::copy() /user/homepages/virtual/eacentral/eabytes/administrator/components/com_kunena/install/kunena.install.php:149
11 JError::raiseError() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/filesystem/folder.php:64
12 JError::raise() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/error/error.php:171
13 JException->__construct() /user/homepages/virtual/eacentral/eabytes/libraries/joomla/error/error.php:136


When Debug in joomla is off I only get the

-1 - An error has occurred.
Unable to create target folder


Now heres the kicker when I give all folders full write access it will install just fine witch makes me think that it is a permssion prob but I really don't want to have my site open to everyone that will leave the server open to hackeking so what do I do to fix this?

thanks

tbarlow
Last edit: 10 years 4 months ago by sozzled. Reason: Changed subject to imrpove search relevance

Please Log in or Create an account to join the conversation.

More
10 years 5 months ago - 10 years 5 months ago #2 by sozzled
Replied by sozzled on topic Re: Securing Kunena
Please read Securing Kunena in the Wiki. :)
Last edit: 10 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #3 by tbarlow
Replied by tbarlow on topic Re: Securing Kunena
ok well I read that and its still doing the same thing?

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #4 by xillibit
Replied by xillibit on topic Re:Securing Kunena
Hello,

This issue isn't related to security...

I have modified a bit Kunena 1.5.9, i hope that will solve your issue :

xillibit.perso.sfr.fr/ftp/com_kunena_v1....-21-with_fix.tar.bz2

Tell me if this has worked after an new installation

I don't provide support by PM, because this can be useful for someone else.
Last edit: 10 years 4 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #5 by RedElectro
Replied by RedElectro on topic Re:Securing Kunena
This didn't work for me personally. I was getting an error on the actual .tar file when trying to extract it.

Uploading to Joomla, I got another error saying "Unable to write entry" and then this...

Warning: file_put_contents(/tmp/install_4b8c1cc774255/:K�]�]u��nZ���Ρ���J�����=��d�����w���$��?����K ݄�����hh�t��]d�4�~�cRO(妍) [function.file-put-contents]: failed to open stream: Is a directory in /****/*****/public_html/libraries/joomla/filesystem/file.php on line 298




Completely out of my depth! While I think the Kunena forum is fantastic, is there not a way of making the installation easier? I don't have these problems with anything else.
Last edit: 10 years 4 months ago by RedElectro. Reason: to include actual error code.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #6 by sozzled
Replied by sozzled on topic Re:Securing Kunena
RedElectro: I sympathise with your frustration and, while the questions I am about to ask you may seem pointless, I would like to help obtain the best advice for you.

I understand that you are trying to install Kunena when you encounter these problems.

What are the directory and file permissions on your website?

What version of Kunena are you trying to install? Which installation kit are you using?

What version of Joomla are you running?

What version of PHP are you using?

What kind of webserver is involved and what kind of database system is being used?

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #7 by RedElectro
Replied by RedElectro on topic Re:Securing Kunena
Hi Sozzled thanks for the reply...



I have gone through each relevant directory/sub directory and set the Perms to 777

I am trying to install Kunena 1.5.9 and I currently have 1.5.6 installed.

I am running Joomla 1.5.15

Apache version 2.2.14

PHP version 5.2.11

MySQL version 5.0.89-community



Hope this helps?

Thanks in advance

Red.
Last edit: 10 years 4 months ago by RedElectro. Reason: to make post more accurate.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #8 by sozzled
Thank you very much for your reply. You clearly meet and exceed the minimum technical requirements for Kunena. It's a bit of a puzzlement why your installation fails. The evidence seems to suggest that it's a directory permissions problem.

I noticed, from an earlier message, you said something about a .TAR file. Are you trying to install Kunena 1.5.9 from a .TAR file? Have you tried to use the .ZIP installation kit instead (this is a long-shot, I know, but I've heard other people have had problems installing with a .TAR archive)? Let's at least eliminate this possibility.
Last edit: 10 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #9 by RedElectro
I originally tried the zip file and had issues. It was Xillibit's post above that prompted me to try the tar install.

I have set the permissions in the components/com_kunena and administrator/com_kunena to 777 almost every file and every folder and I'm still not having any success.

It's got me completely puzzled.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #10 by sozzled
Yes, but you still haven't answered my question. Now that you have changed directory and file permissions, have you attempted to use the .ZIP file installation and, if so, what are the specific "issues" that you encounter?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.123 seconds