×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Stuck on Installation (Creating version table)

More
8 years 8 months ago #1 by binaryorganic
I'm trying to install Kunena 1.5.14 onto a fresh Joomla installation (1.5.21) and I'm getting stuck during installation. I get an all white screen with a single line that says "Creating Version Table" With a green checkmark next to it. Kunena shows as installed in the components menu but informs me that the installation is incomplete. I've uninstalled and tried again and receive the same message.

Ideas?
Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #2 by sozzled
Does your website meet the minimum technical requirements ... even for K 1.5.14?

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #3 by binaryorganic
Yes, I meet all requirements that I am aware of.

MySQL 5.0.77
PHP 5.2.6

My PHP.ini initially didn't have the values that were recommended, but I have since changed them and verified that they are recognized via the PHP information tab in Joomla:

php max_execution_time 120
php memory_limit 64M
safe_mode off (this was already off)

Also, everything shows as writable in the "directory permissions" tab of the Joomla Info screen.

After the php.ini changes I am still getting the same issue on installation. Just a little green checkmark next to the words "creating version table".

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #4 by xillibit
Hello,

In extensions menu, do you see link to Kunena ? When you go in kunena configuration panel do you see any error ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #5 by binaryorganic
Yes, as i said in my original post:

"Kunena shows as installed in the components menu but informs me that the installation is incomplete."

Specifically, I get the following messages:

Your Kunena installation is incomplete!

Because of the above errors your Forum is now Offline and Forum Administration has been disabled.

Possible reasons for this error:
1) Kunena installation process has failed or timed out (try to install it again)
2) You have manually modified or removed some of the Kunena tables from your database
You can find solutions to the most common issues on our community documentation wiki: Kunena Documentation Wiki
Our support forum can be found from: www.kunena.com

Installed version: Kunena 1.5.14 | UNKNOWN | 0000 [ NOT INSTALLED ] | Copyright: © 2008-2009 Kunena | License: GNU GPL

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #6 by fatmanmedia
hi,

i'm having the exact same issues, i'm installing this on a dedicated server with the specs exceeding the mins required.

it's also on a fresh install of joomla 1.5.22.

fats

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago - 8 years 8 months ago #7 by sozzled
There are a couple of defects in K 1.5.14 (see Installation of 1.5.14 in preparation for Agora conversion error ). It's never easy giving people bad news but I have some bad news for you. K 1.5.14 cannot be installed on clean J! 1.5 website. Even if you upgrade from an older version of Kunena, the upgrade installer has a small issue with the final stage of the K 1.5.14 upgrade. However, the upgrade seems to complete. I just don't know if it completes successfully.

I can understand that this causes a problem with new installations of Kunena and I am not enjoying writing those words at this time. I am fairly sure that these problems will be resolved in some way in the future but, for now, this leaves people who want to start to use Kunena with a very difficult choice. Should people wait for a newer version, K 1.5.15 (say), in order to be able to install on a new site; or should people use the version before K 1.5.14 (K 1.5.13), start with that, and be exposed to the security issues that were associated with that version?

For a long time we have urged people to not use K 1.5 for new site installs. For a long time we have urged people to start with K 1.6 in preference to using K 1.5. For a long time, too, many people have written that they are unable to use K 1.6 because they were "waiting" (for what, I don't know) or they had site templates (or other Joomla extensions) that included Javascript libraries that were incompatible with Mootools 1.2.4 .

If people feel helpless and stuck because of the choices they have made, if people are unable to resolve these Javascript library conflicts themselves, we can put people in contact with professional services that will overcome these issues. It must be remembered though that when I write "professional services" I am referring to services that people have to pay for.

But there are always alternatives and most of these alternatives involve no cost other than your patience and perseverance.

Use the current opportunity to move away from K 1.5. K 1.5 does not have a future. The future lies with K 1.6.

Even though the current problems with K 1.5.14 are only temporary, I expect, make the most of this opportunity to move forward and use K 1.6.3 instead. Yes, there may be issues, but do not shrink from the challenges of those issues. Those other issues can be solved quickly. Using K 1.5.14 is an issue that may not be solved quickly. Your decision should be based, largely, on how long you are prepared to wait.

You can also use this time as an opportunity to rid yourself of old and outdated software from your website and make sure that these kinds of issues never come back again.

As I mentioned earlier, I do not enjoy being the "bringer of bad news" but I hope that I have written something that will help you.
Last edit: 8 years 8 months ago by sozzled.
The following user(s) said Thank You: fatmanmedia

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #8 by fatmanmedia
thanks for that, i went with 1.5.14 due to the fact that when ever I installed 1.6.3 all i would get is server 500 errors.

will explore this further.

thanks again

fats

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #9 by urednik
I migrated to 1.6
Had the 1.5.11, have a server that meets all the technical criteria, but see what happened:

1. 1.5.11 < 1.6.2 or 1.6.3 was unsuccessful, the installer (migrator) got stuck after three tasks and the admin website was continuously refreshing.

2. 1.5.11 < 1.5.14 was partly successful, but saying that there was something wrong with my 1.5.11 installation, so I should downgrade. I tried several settings (of course had also plugins disabled etc.) but I could not find what was wrong. I saw the 1.5.14 worked ok (everything worked except the components main control panel), so I thought I try to do it and try to go on.

3. 1.5.14 (with partial error) < 1.6.3 was unsuccessful (got stuck after 10 tasks)

4. 1.5.14 < 1.6.2 partly successful (all the first migrate screen tasks completed, but the kunena cpanel reads: An incomplete installation of Kunena 1.6.2 build 3894 was found in your system. This means that the installation either failed or was interrupted.). I got all the content migrated into new jos_kunena tables.

5. I installed on my J. 16 site the fresh Kunena 1.6.3 (had problems with the menu item - had to delete it in MYSQL) and imported CATEGORIES table from my upgrade (1.5.14 < 1.6.2 partly successful) as well as replaced following whole tables (could not import them entirely* because INDEX of the table was different): messages, messages_text, ranks and users.

*for example from messages I could have imported only 356 from 995 rows, saying error - duplicate entry, although the table was entirely emptied by me before.

It seems that Kunena now runs ok, but I have three questions:
  1. Is my installation now ok?
  2. Why was my 1.5.11 installation broken?
  3. What the hell is INDEX in MYSQL and why could I not import those rows from Kunena 1.6.2 to 1.6.3?

Thank you, thank you and thank you if anyone can assist by mi problems!!! :woohoo:

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #10 by urednik
Ok, as I see you are not able to answer these questions. Are they to difficult or to stupid?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.087 seconds