Introduction:

The Kunena team is thrilled to announce the final release of Kunena 5.2.6, a native Joomla extension for Joomla 3.9. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the last development stages.

You need Joomla 3.9 to run Kunena 5.2.6, the minimal requirement for Php has been increased to 7.0.4. Kunena 5.2.6 can runs too with Php 8.0.

For users of template Blue eagle5, please update to release of Blue eagle5 v1.6.6 or more recent before updating Kunena to 5.2.6. This template isn't designed to works with Bootstrap 4, please stay with default Boostrap version from Joomla!.

What's different?

Upgrading to K 5.2.6 involves changes that may affect Kunena's interoperability with other extensions installed on your site. For this reason it is advisable that you first test K 5.2 on a test site before you upgrade your live production site(s). At this stage the team is not treating interoperability with other Joomla extensions as the topmost priority. The main priority at this time is about installation/upgrade and operability as a standalone Joomla component.

Main changes in K5.2.6 :

Fixed

  • #8216: Crypsisb3 & Crypsisb4 : The BBcode editor loads no toolbar (crypsisb4 missing style to diplay bbcode correctly)
  • #8223: Wysiwyg : You can't Submit the message
  • #8228: Wysiwyg: Remove attachment from message, duplicates the code tags (fix install all)
  • #8229: Quick Reply and go to editor - only the CKEditor receives the content
  • #8224: BBcode and Wysiwyg etitor: Remove single images from messages do not work correctly
  • #8225: Typo in administrator en-GB.com_kunena.views.ini line 922
  • #8221: Insert images in messages works only with the CKEditor
  • #8216: Crypsisb3 & Crypsisb4 : The BBcode editor loads no toolbar (missing images in crypsisb4)
  • #8216: Crypsisb3 & Crypsisb4 : The BBcode editor loads no toolbar
  • #8214: Only with Crypsisb3 & Crypsisb4: It does not switch to another editor
  • #8211: Temporary rendering error at editor
  • #8208: Only with PHP 8 : Warning at bullet list
  • #8205: Only with PHP 8 : Warning: getimagesize - when protect attachment is on (apply the fix too in crypsisb3)
  • #8205: Only with PHP 8 : Warning: getimagesize - when protect attachment is on
  • #8204: Only with PHP 8 : Warning: Undefined array key at quoted text
  • #8166: [CKEditor] CKEditor bug using lists
  • #8170: Error when trying to view profile of banned user
Added
  • Reintroduce the editors available in Kunena 5.1.x to let users replace CKeditor
Changed
  • Disable the WYSIBB option in template settings untill that last bug with it are fixed

See full changelog here:

https://github.com/Kunena/Kunena-Forum/tree/5.2.6

Download:

Download K5.2.6 here: https://github.com/Kunena/Kunena-Forum/releases/tag/5.2.6

Donations

Any donations are needed for future support.

Log in to comment

xillibit's Avatar
xillibit replied the topic: #1 1 month 2 weeks ago

and there is some PHP RFC: Deprecations for PHP 8.1 to consider too wiki.php.net/rfc/deprecations_php_8_1



 

FYI: i have tried Php 8.1.0 Beta2 with Joomla! 4.0 updated from github, i have couple of fatal errors for now coming for Joomla!, so Joomla! 4.0 is not usable with Php 8.1.0
xillibit's Avatar
xillibit replied the topic: #2 1 month 3 weeks ago
Thanks for the info, we are still working on Kunena 6.0 : www.kunena.org/forum/76-Official-Announc...eased-for-joomla-4-0

We have tested Kunena 5.2.6 on Joomla! 3.10 (it will released as stable in same time than J!4.0) we don't have issue with it

I had seen the release of Php 8.1 in beta but i'am waiting final release before to make tests with it, Joomla! 4.0 stick with Php 7.2.5 as minimal version it will depends on extensions to have requirements like Php 7.3.x or Php 7.4.x as minimal
ssnobben's Avatar
ssnobben replied the topic: #3 1 month 3 weeks ago
And 17th August Joomla 4 stable will be released www.joomla.org/announcements/release-new...ble-17th-august.html

and there is some PHP RFC: Deprecations for PHP 8.1 to consider too wiki.php.net/rfc/deprecations_php_8_1
xillibit's Avatar
xillibit replied the topic: #4 1 month 4 weeks ago
Thanks i will fix that in the release article and changelog
larbut replied the topic: #5 1 month 4 weeks ago
Thank you!
Maybe mention in the release text that Blue Eagle 5 v 1.6.6 is required?
It only mentions 1.6.5 or higher.

The changelog for 1.6.6 also needs a minor update as it lists 1.6.5 twice.

-Lars