Introduction:

The Kunena team is thrilled to announce the final release of Kunena 5.2.1, a native Joomla extension for Joomla 3.9. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the last development stages.

You need Joomla 3.9 to run Kunena 5.2.1, the minimal requirement for Php has been increased to 7.0.4. Kunena 5.2.1 can runs too with Php 8.0.

What's different?

Upgrading to K 5.2.1 involves changes that may affect Kunena's interoperability with other extensions installed on your site. For this reason it is advisable that you first test K 5.2 on a test site before you upgrade your live production site(s). At this stage the team is not treating interoperability with other Joomla extensions as the topmost priority. The main priority at this time is about installation/upgrade and operability as a standalone Joomla component.

Main changes in K5.2.1 :

  • Remove Jrequest_allowraw
  • Remove StumbleUpon in jssocials.js else it stays displayed
  • install php 8
  • When allow_fopen_url is disabled not access page manage template
  • Catch exception on usage on stream on report stop forum space
  • CKeditor: make working correctly the font size option
  • [CKeditor] Summary of not working buttons
  • [CKEditor] PAdjust the dropdown lists of the Add Link dialog?
  • Keep selected text when using one of the kunena bbcodes
  • Veekee fr topic icon crypsis
  • Check that blue eagle 1.6 is allowed to be installed on K5.2
  • Check before install template that are compatible with k version
  • Undefined variable in bbcode/email and array string conversion
  • Kunena configuration wasn't displaying some values
  • Missing code in in edit.js to open/close quickreply
  • Template settings for BBCode are ineffective #7774 (#7801)

See full changelog here:

https://github.com/Kunena/Kunena-Forum/tree/5.2.1

Download:

Download K5.2.1 here: https://github.com/Kunena/Kunena-Forum/releases/tag/5.2.1

Donations

Any donations are needed for future support.

Log in to comment

xillibit's Avatar
xillibit replied the topic: #1 8 months 3 weeks ago
FYI: the automatic update is enabled to K5.2.1 for people uisng Kunena 5.2.0 and 5.1.19