Introduction

The Kunena team has now released Kunena 1.7.1 as a native Joomla extension for J! 1.5 and J! 1.7. This is a security release and replacement for all previous versions of Kunena and it is recommended that all users upgrade to Kunena 1.7.1 at the earliest opportunity.

In order to achieve interoperability with both of J! 1.5 and J! 1.7, several important matters in Kunena have been attended to before the next major release of Kunena 2.0 later this year. Some users of third-party templates written for older versions of Kunena will find that their templates may not work with this latest release because changes were necessary in order to fit with the new J! 1.7 CMS. In particular, many of the third-party templates written for K 1.6 in its early stages will cause problems. If in doubt, please contact the authors(s) responsible for those things.

Note: Joomla 1.6 is no longer officially supported.

At this time all previously-released add-on extensions for Kunena have been updated and will need to be separately installed. As with all other releases, K 1.7.1 is available for download on the download page.

AnchorHighlights

  • Single package for Joomla 1.5 and Joomla 1.7 (specifically, J! 1.5.25 and J! 1.7.3).
  • Improved access level support
  • Better integration with Community Builder and AlphaUserPoints
  • Fix some bugs encountered in previous release
  • Fix security issues:
    • JomSocial activity stream not to show restricted categories
    • Hide sensitive information from Kunena configuration report
    • Potential XSS exploit in canonical URLs

Find the full online README: Here

Find the full online CHANGELOG: Here

System Requirements

Joomla 1.5.25 or Joomla 1.7.3

Kunena 1.7 does not use jQuery and requires MooTools 1.2.4+. With the release of J! 1.5.25 and J! 1.7.3, the Mootools system library has been updated for Joomla compatibility with the latest web browsers Firefox 7 and Internet Explorer 9.

PHP 5.2.3

Kunena 1.7 requires PHP 5.2.3 or higher. In general we currently recommend PHP 5.3.6 due to its maturity.

MySQL 5

Kunena in general and especially version 1.7.x relies on advanced SQL features introduced in MySQL 5.0.x. MySQL 4.x is no longer support even though Joomla 1.5 itself can be run on certain versions of MySQL 4.x. The main difference is the amount of database workload generated by a forum component compared to the basic CMS functionality.Anchor

Third party components requirements

If you want to integrate JomSocial, Community Builder, uddeIM or Alpha User Points with Kunena, you must check with the developers of those extensions to ensure that you meet their requirements. The following list is only a guide and is subject to change without notice.

  • JomSocial 2.x.x
  • Community Builder 1.4 or 1.7 (J! 1.7)
  • UddeIm 2.x
  • Alpha User Points 1.5.12 (J! 1.5.x); 1.6.3 (J! /1.7)

While we will do all that we can to make sure that Kunena continues to work with these extensions listed above, there are no guarantees that future releases of those products will continue to be compatible with this release of Kunena.

AnchorThird party ACL components requirements

If you want use third party ACL components with Kunena 1.7.1 and Joomla! 1.5, you may use the following:

Language support

Kunena is designed to work in a number of non-English language scenarios. The availability of non-English translations of Kunena requires the availability as well as the ability of people to translate Kunena into non-English language packs. When new versions of Kunena become ready for public releases, sometimes it's not possible to include every possible translation of Kunena in time for the release. Sometimes it's also necessary to remove certain languages from Kunena for technical reasons. Therefore, before upgrading to the latest version of Kunena, it is essential that you should first check the release notes of that version to see if your language is included. If a language pack is not available at the time of the release of a new version of Kunena, when the language becomes available, the language pack will be available for download on the forum.

It is possible that a language available in an older version of Kunena will not be available in the version that you intend to upgrade to. We remind you to first check the release notes.

Downloading Kunena

Find the latest installation package files here: View Packages

We use the power of Github as our public source code repository. We encourage all users and open source developers to help develop fixes, features and enhancements to the existing code base. If you are interested in contributing, please provide a patch or enhanced branch and we will be happy to consider it for inclusion in the main code branch (quality and feature completeness permitting).

Find the GIT source code repository here: Browse source code

The only official Kunena distributions are available from the links above or directly at www.kunena.org. There are currently no officially endorsed alternative download mirrors supported; users are encouraged to visit www.kunena.org for the latest version of all available Kunena packages.

Anchor

Compatibility with Third-party Kunena Templates

Compatibility with Third-party Kunena Modules

Kunena 1.7.x now provides an updated API for easily creating modules or plug-ins. The Kunena team has created a few new plug-ins and modules which leverage the new API and can be used with K 1.6 and K 1.7. These extensions can be found in the Kunena Extension Directory. If in doubt, please contact the authors(s) responsible for those things.

Installing or Upgrading Kunena

Be sure your setup meets or exceeds the minimum Technical Requirements or the install/upgrade process will fail. If it fails, your data will be left untouched.

To install Kunena, make sure you read our Installation Instructions before beginning. To upgrade Kunena from previous versions (including FireBoard), make sure you read the Upgrade Instructions.

The Kunena installer now handles both installs and upgrades of existing installations without the need for user intervention, manual SQL execution, or migration procedures. It also keeps a detailed log of all Kunena versions installed on your site in order to perform incremental upgrades as necessary. This means that a site administrator doesn't have to worry about complicated installation or upgrade procedures.

We stress the importance of backups before and after any upgrade process. Never perform an install or upgrade without a full backup.

Log in to comment

sozzled's Avatar
sozzled replied the topic: #1 10 years 9 months ago

sunny33days wrote: What was the answer to your upgrade question?

The answer is to the question is contained in the article that we're discussing Please read the whole article. The article tells you to read K 1.6 and K 1.7 Upgrade Guide . The upgrade guide tells you what you should do and what you can expect.
sunny33days replied the topic: #2 10 years 9 months ago
What was the answer to your upgrade question? I also need to upgrade, but am afraid I'll lose my past posts.
tbross replied the topic: #3 10 years 9 months ago
I want to be able to notify people on a listserv when a new topic/posting has been made. I undersatnd people can subscribe to topics but this is not enough. I want the members of the listserv to know when there is a new topic so they can go and subscribe. I can't see any way to do this.
Thanks,
Ted
billco replied the topic: #4 10 years 9 months ago
Hi, I want to update from v1.6.1. Do I just install v1.7.1 over the top and it keeps all previos posts and settings?

I am integrated with CB also. Will that be affected?

Thanks in advance, for your reply.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 150M

This message contains confidential information

Joomla default template details : rt_panacea_j15 | author: RocketTheme, LLC | version: 1.5.3 | creationdate: July 19, 2010

Kunena version detailled: Installed version: 1.6.1 | Build: 3858 | Version name: Timu | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.4) | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.1)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Enabled (Version : 1.6.0-RC2) | Kunena Login: Disabled or not installed

Nihil replied the topic: #5 10 years 9 months ago

sozzled wrote: Kunena 1.7.1 plus Kunena Discuss 1.7.1


Thank you. This is good stuff!