Introduction

The Kunena Team has now released Kunena 1.6.5 as a native Joomla extension for J! 1.5.23, J! 1.6.6 and J! 1.7.0. This is a maintenance release for Kunena 1.6 and all users are recommended to upgrade to Kunena 1.6.5. Backup and testing are strongly recommended!

K 1.6.5 makes all previous releases of Kunena obsolete and all users of prior Kunena releases are urged to upgrade as soon as possible.

In order to achieve interoperability with all of J! 1.5, J! 1.6 and J! 1.7, much of the recent work has focused on fixing several important matters in Kunena before the next major release of Kunena 2.0 later this year. Some users of third-party templates written for older versions of Kunena will find that their templates may not work with this latest release because changes were necessary in order to fit with the new J! 1.6/1.7 CMS.

There are still a few outstanding matters that have prevented K 1.6 meeting all our expectations to take full advantage of all the features of J! 1.6 or J! 1.7. As with other Joomla extensions, the Kunena project is not alone in this situation. During our extensive testing of K 1.6.5 the project team has discovered several issues with the Joomla 1.6 core and these were reported to the Joomla development team; several other changes were requested, too, but these did not make it into the release of J! 1.7. Rather than wait for the Joomla development team address these outstanding concerns it was decided that it was better to release a version of Kunena that handles most of what Joomla 1.6/1.7 were capable of providing. There is still further work needed to complete this task and we're continuing to work with Joomla developers to resolve those outstanding matters. If you are in any doubt about whether J! 1.6 or J! 1.7 are right for you, you should test K 1.6.5 on J! 1.6.6 or J! 1.7.0. to form your own opinion of what is best for your needs or whether you should use something else.

At this time there are no new releases of add-on extensions for Kunena. As with all other releases, K 1.6.5 is available for download on the download page.

AnchorHighlights

  • Added Joomla! 1.7 support and improved Joomla! 1.6 support
  • Improved sh404SEF support (also updated sh404SEF plugin for Kunena)
  • Allow user to use his own lightbox javascript (fixes some issues with Joomla templates/modules)
  • Beginnings of RTL support (not yet complete)
  • Misc CSS fixes
  • Fixed search in user list and corrected user count in front page
  • Fixed some issues in CommunityBuilder and JomSocial integration
  • Fixed various bugs in polls, user moderation, attachments, RSS, templating etc

Find the full online README: Here

Find the full online CHANGELOG: Here

System Requirements

Joomla 1.5.23, Joomla 1.6.6 or Joomla 1.7.0 Minimum Version Required (Mootools 1.2.5)

Kunena 1.6.x no longer uses jQuery and requires MooTools 1.2.4+. With the release of Joomla 1.5.23 and Joomla 1.6.5, the Mootools system library has been updated for Joomla compatibility with the latest web browsers Firefox 4 and Internet Explorer 9.

Because of the XSS security vulnerability identified by the Joomla team, if people are using J! 1.6 and cannot update to J! 1.7.0 they should use J! 1.6.6.

PHP 5.2.3

Kunena 1.6.x requires PHP 5.2.3 or higher. We have also tested it on PHP 5.3.x. In general we currently recommend PHP 5.2.x due to its maturity.Anchor

MySQL 5.0.0

Kunena in general and especially version 1.6.x relies on advanced SQL features introduced in MySQL 5.0.x. MySQL 4.x is no longer support even though Joomla 1.5 itself can be run on certain versions of MySQL 4.x. The main difference is the amount of database workload generated by a forum component compared to the basic CMS functionality.Anchor

Third party components requirements

If you want to integrate JomSocial, Community Builder, uddeIM or Alpha User Points with Kunena, you must check with the developers of those extensions to ensure that you meet their requirements. The following list is only a guide and is subject to change without notice.

  • JomSocial 2.x.x
  • Community Builer 1.4
  • UddeIm 2.x
  • Alpha User Points 1.5.12 (J! 1.5.x); 1.6.3 (J! 1.6/1.7)

While we will do all that we can to make sure that Kunena continues to work with these extensions listed above, there are no guarantees that future releases of those products will continue to be compatible with this release of Kunena.

AnchorThird party ACL components requirements

If you want use third party ACL components with Kunena 1.6.5 and Joomla! 1.5, you may use the following:

  • NoixACL 2.0.6 - not officially supported and will be removed from future versions of Kunena
  • JXtended Control 1.0.7
  • ArtofUser 1.0.5

Downloading Kunena

Find the latest installation package files here: View Packages

We use the power of Github as our public source code repository. We encourage all users and open source developers to help develop fixes, features and enhancements to the existing code base. If you are interested in contributing, please provide a patch or enhanced branch and we will be happy to consider it for inclusion in the main code branch (quality and feature completeness permitting).

Find the GIT source code repository here: Browse source code

The only official Kunena distributions are available from the links above or directly at www.kunena.org. There are currently no officially endorsed alternative download mirrors supported; users are encouraged to visit www.kunena.org for the latest version of all available Kunena packages.

Anchor

Compatibility with Third-party Kunena Templates


All the logic has been removed from the template to make it much easier for template designers to create Kunena templates.

Check out the short guide on how to quickly customize a Kunena 1.6 template in just a few minutes: http://www.kunena.org/forum/159-common-questions/53519-the-5-minute-quick-and-dirty-kunena-16-template

More tutorials and instructions are available in the forums to make template for Kunena 1.6.x.

Compatibility with Third-party Kunena Modules

Kunena 1.6.x now provides an updated API for easily creating modules or plug-ins. The Kunena team has created a few new plug-ins and modules which leverage the new API and can be used with Kunena 1.6.x. These extensions can be found in the Kunena Extension Directory: http://www.kunena.org/kedAnchor

Installing or Upgrading Kunena

Be sure your setup meets or exceeds the minimum Technical Requirements or the install/upgrade process will fail. If it fails, your data will be left untouched.

To install Kunena, make sure you read our Installation Instructions before beginning. To upgrade Kunena from previous versions (including FireBoard), make sure you read the Upgrade Instructions.

The Kunena installer now handles both installs and upgrades of existing installations without the need for user intervention, manual SQL execution, or migration procedures. It also keeps a detailed log of all Kunena versions installed on your site in order to perform incremental upgrades as necessary. This means that a site administrator doesn't have to worry about complicated installation or upgrade procedures.

We would like to underscore the importance of backups before and after any upgrade process. Never perform an install or upgrade without a full backup.Anchor

Credits

An open source project like Kunena requires the dedication and investment of personal time from various contributors. This version of Kunena Forum has been made possible by the following contributors:

  • fxstein Kunena developer and admin of http://www.starVmax.com/forum/
  • Matias Kunena developer
  • severdia - Kunena developer, Joomla Leadership Team Member, and admin of PlayShakespeare.com
  • xillibit Kunena developer
  • @quila Kunena contributor
  • 810 Kunena contributor
  • alakentu Kunena moderator
  • svanschu Kunena contributor
  • Rich Kunena moderator
  • sozzled Kunena moderator

Special thanks go to Beat and the CB Testing team, LittleJohn, GoremanX, madLyfe, Mortti, and BoardBoss for their significant contributions to Kunena. In addition many members, past and present, of http://www.Kunena.org have contributed and helped make this a more stable and bugfree version. Our thanks go out to all contributors of Kunena!

Language credits

English translation was made by the Kunena Team with many suggestions and corrections from our community. We also like to give special thanks to all our translators, who have worked hard to localize Kunena in their own languages.

Language support for this release

Arabic, Bahasa Indonesia, Catalan, Chinese (Taiwan), Danish, Dutch, English (US), Finnish, French, German, Greek, Hungarian, Lithuanian, Polish, Russian, Spanish, Taiwanese, Thai, Turkish

Log in to comment

cavusoglu28's Avatar
cavusoglu28 replied the topic: #1 11 years 1 month ago
thank you
xillibit's Avatar
xillibit replied the topic: #2 11 years 1 month ago
Hello,

Do you a screenshot to see exactly the issue ?
renejdm's Avatar
renejdm replied the topic: #3 11 years 1 month ago
I just installed the latest version of Kunena on Windows 7 (localhost) with PHP 5.3.5. It looks good in IE9 but the text is blurred in FireFox 6
joomlaman's Avatar
joomlaman replied the topic: #4 11 years 1 month ago
hi dears
in kunena team

Thank you for providing the best Joomla extension(kunena forum)

Good luck
ravi.grt replied the topic: #5 11 years 1 month ago
Thanks for your time and bringing out a great product!!