Kunena 7.1 Beta 4 Released for Joomla! 5.4.x and 6.x
- Details
Introduction:
The Kunena team is thrilled to announce the fourth public beta release of Kunena 7.1, a native Joomla extension for Joomla! 5.4 and Joomla 6.x. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage. Kunena 7.0 works on Joomla! 6.0 natively without the needs of compat plugin.
The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 7.1.0 B1 is in testing phase and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 7.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.
Kunena 7.1 has been designed to work on Joomla! 5.4 and 6.0, the requirements are the followings :- Php 8.3.0
- MariaDb 10.4 or MySQL 8.0.13
- Bootstrap 5.x
The work done in Kunena 7.1 is mostly to update the code base:
- Remove deprecated code which are planned to be removed in Joomla! 7.0 (replace triggerEvent)
- Add a way to store the notifications to be send later with the Kunena task plugin
- Some improvements on the code to optimise a bit the speed
- Refactor the queries to use Joomla! database query way
- Add a new setting to choose to display brithdate or age in the user profile
- Allow with a plugin (will be available later in subcription page) to add new social in user profile and remove socials network
- Some improvements on SCeditor : add undo plugin and allow to handle some others parameters on inserting an image (thanks to joomod)
Download:
Download K7.1.0 Beta4 here: https://github.com/Kunena/Kunena-Forum/releases/tag/7.1-Beta4
Donations
Any donations are needed for future support.
Discuss this article
That’s why I wanted to give Joomla 6.1.3 a go, but that option was taken away from me.Still unable to reproduce. Table is created on my testsite with Joomla 6.1.4.
Database collation check: The collation of your table fields are correct
Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
This message contains confidential informationhtaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload:
Kunena menu details:
Warning: Spoiler!
Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02
Kunena default template details : Aurelia | author: Kunena Team | version: 7.1.0-BETA4 | creationdate: 2026-09-29
Kunena template params:
Warning: Spoiler!
Kunena version detailed: Kunena 7.1.0-BETA4 | 2026-09-29 [ BETA4 ]
| Kunena detailed configuration:| Kunena integration settings:Warning: Spoiler!| Joomla! detailed language files installed:Warning: Spoiler!Warning: Spoiler!
Third-party components: UddeIm 4.0
Third-party SEF components: None
Plugins: None
Modules: Kunena Latest 6.2.2 | Kunena Search 6.2.2
Kunena 7.1 Beta 3 Released for Joomla! 5.4.x and 6.x
- Details
Introduction:
The Kunena team is thrilled to announce the third public beta release of Kunena 7.1, a native Joomla extension for Joomla! 5.4 and Joomla 6.x. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage. Kunena 7.0 works on Joomla! 6.0 natively without the needs of compat plugin.
The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 7.1.0 B1 is in testing phase and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 7.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.
Kunena 7.1 has been designed to work on Joomla! 5.4 and 6.0, the requirements are the followings :- Php 8.3.0
- MariaDb 10.4 or MySQL 8.0.13
- Bootstrap 5.x
The work done in Kunena 7.1 is mostly to update the code base:
- Remove deprecated code which are planned to be removed in Joomla! 7.0 (replace triggerEvent)
- Add a way to store the notifications to be send later with the Kunena task plugin
- Some improvements on the code to optimise a bit the speed
- Refactor the queries to use Joomla! database query way
- Add a new setting to choose to display brithdate or age in the user profile
- Allow with a plugin (will be available later in subcription page) to add new social in user profile (still on work in progress)
- Some improvements on SCeditor : add undo plugin and allow to handle some others parameters on inserting an image (thanks to joomod)
Download:
Download K7.1.0 Beta3 here: https://github.com/Kunena/Kunena-Forum/releases/tag/7.1-Beta3
Donations
Any donations are needed for future support.
Discuss this article
If you want to make your own modifications, that's of course up to you. But please don't report bugs here that aren't actual bugs, but the result of your own tinkering. Doing so wastes the valuable time of volunteers who try to help users and reproduce genuine bugs. And this isn't the first time you've come here with a problem you caused yourself.
If you think it would be useful to have Kunena's database tables show up under System/Maintenance/Database, it would be better to open a well-substantiated feature request on GitHub, so the developers can judge whether it makes sense to implement this in a future version.
As a test, I replaced the character ` with the character ´ in the very first line of the file “7.1.0-Alpha1-DEV.sql”.
The error message now read: “The table ‘jom6_kunena_notifications_mailsqueue(‘” does not exist. (From file: “7.1.0-ALPHA1-DEV.sql”.) to a modified message: “The table ‘\“jom6_kunena_notifications_mailsqueue\”’ does not exist. (From file: “7.1.0-ALPHA1-DEV.sql”.)” The single quote was missing.
The database error appears to lie in this file. I undid the changes and added a space after the top line.
After that, no further database errors were displayed.
I then added the space to all test versions and no longer receive any error messages.
Could you check your database's #__schemas table for a leftover/outdated row for com_kunena? If there is one, that's likely the cause - you can just delete it.
As for the database error, I described it in post #235310 on the first page.
System/Maintenance/Database/Extensions:Database/Kunena
WarningThere are tables that are not up to date.
I get this error in every BETA version.
I then changed the collation in the database for all four versions from utf8mb4_uca1400_ai_ci to utf8mb4_unicode_ci.
I then cleared the browser cache and restarted the computer.
After that, I installed BETA versions 1 to 4 in the four test installations, and the “#__kunena_notifications_mailsqueue” table was installed in all four of them.
However, the database error stating that the table was not installed persists in all four test installations.
My PHP version is 8.4.24
It seems now that MariaDB doesn't like mix of collations on tables : github.com/matomo-org/matomo/issues/22536
I set up a test version of Kunena 7.0.9 and changed the entire collation in the database to `utf8mb4_uca1400_ai_ci`.
I then installed Kunena 7.1 BETA4-DEV_2026-09-19.
In the database, the table `__kunena_notifications_mailsqueue` was created, but with the collation set to `unicode_ci`
I then repeated the same test, but this time without changing the collation in Kunena 7.0.9, and on this occasion the table `__kunena_notifications_mailsqueue` was not created in the database.
Strange!
Incidentally, database error messages were present in both tests.
I’ll test again straight away with 7.1 BETA4-DEV_2026-09-20.
The Kunena dashboard shows ‘Mails Queue’ with 75 items.
However, there is no corresponding table for this in the database.
In phpMyAdmin, different collations are displayed for the databases.
My database version:
I’ve noticed that the collation ‘utf8mb4_uca1400_ai_ci’ appears very frequently in version 7.1.
Could this be causing some errors?
In my commit yerstayday, it was missing the file 7.1.0-BETA1-DEV.sql : update.kunena.org/nightlybuilds/pkg_kune...4-DEV_2026-09-19.zip
Are-you on mariadb or mysql ? And on which version ?
I then reinstalled the Kunena 7.0.9 backup and used it to install the file pkg_kunena_v7.1.0-BETA4_DEV_2026-09-18_2.zip.
The two database errors occurred again, but this time the file ‘__kunena_notifications_mailsqueue’ was not installed.
Previously, it had been installed in BETA1, BETA2, BETA3 and BETA4.
I have added sql files for BETA1, BETA2 and BETA3 : update.kunena.org/nightlybuilds/pkg_kune...DEV_2026-09-18_2.zip
I then installed the test versions Kunena 7.1 BETA1, BETA2, BETA3 and BETA4 on these installations.
The error “Unknown column ‘status’ in ‘SET’” only occurred in the BETA3 version.
The database error “jom6_kunena_notifications_mailsqueue(” does not exist. (From file: “7.1.0-ALPHA1-DEV.sql”) has been present since version BETA1
Actually, the closing single quote ‘ should be before the parenthesis, not after it.
I’ve unzipped the entire installation programme and searched through it, but haven’t found the relevant section.
Perhaps two characters before the parenthesis have been swapped somewhere – ´ and `?
Hello,When installing Kunena 7.1 Beta 3 over Kunena 7.0.9, I get an error message.
Kunena 7.1 Beta 3 is installed and has been working without any errors so far.
I have made a fix for that, you can try with the beta4 developpement build : update.kunena.org/nightlybuilds/pkg_kune...4-DEV_2026-09-18.zip
I then deleted the contents of the backup directory and the database, installed the backup using Kunena 7.0.9, and then installed Kunena 7.1 BETA 3.
The installation error reappeared, as did the two database errors. One of the database errors could be resolved using “repair”, but the missing table could not.
When I took a closer look at the error message, I noticed that there is an opening bracket after “_mailsqueue(” in the message, which is probably the reason for the error message.
- Die Datenbankschemaversion (6.0.0-RC1-DEV) passt nicht zur Manifest-Version (7.1.0-ALPHA1-DEV).
- Die Tabelle „'jom6_kunena_notifications_mailsqueue('“ existiert nicht. (Von Datei: „7.1.0-ALPHA1-DEV.sql“.)
- 34 Datenbankänderungen wurden überprüft.
- 5 Datenbankänderungen hatten keinen Einfluss auf die Struktur der Datenbanktabellen und wurden deshalb übersprungen.
Kunena 6.4.14 security release for Joomla! 5.0/5.1/5.2/5.3/5.4/6.0/6.1
- Details
Introduction:
The Kunena team is thrilled to announce the fourteenth release (security release) of Kunena 6.4, a native Joomla extension for Joomla! 5.0, 5.1, 5.2, 5.3, 5.4, 6.0 and 6.1. It needs the compatbility plugin to be enabled to be installed on Joomla! 6.0.x, this release (K6.4.13) is offered for people already on Joomla! 6.0 to be able to update to K7.0.x. For people still on K6.3.x, the update to K6.4.x version isn't proposed because some users has still Joomla! 4.4.x.
We are changed translation platform, we are now moved to crowdin for this release and the next releases : crowdin kunena. The translators are still needed to update the languages on crowdin because some aren't enough translated.
The security support of Kunena 6.4.x will end by december 2026 so please think to upgrade to Kunena 7.0.
The support for Joomla! 6.1 has been added in this release with plugin compatibility mode to allow upgrade to Kunena 7.0. Kunena 6.4 has been designed to work on Joomla! 5.0 and later, the requirements are the followings :- Php 8.1.0 to Php 8.4.x
- MySQL 8.0.13 to MySQL 9.2.0
- Bootstrap 5.1
The work done in Kunena 6.4 is the following:
- Some security issues fixed - thanks to ruud to have reported them
- Some security issues fixed - thanks to pbugbounty to have reported them
- Removing CMSObject extends to some Kunena classes to comply with removed things planned for Joomla! 6.0 (thanks to svanschu)
- Allow to be used on php 8.4 if you are on Joomla! 5.2.x, it will give some deprecated errors messages
- Replace some deprecated usage of methods Joomla! of getError(), getDBO() and Toolbar::getInstance()
- Allow avif and webp to be added in attachment
Download:
Download K6.4.14 security release here: https://github.com/Kunena/Kunena-Forum/releases/tag/6.4.14
This means that the Kunena 6.3 series is approching the end of life and will be discountinued, with the future release of K6.4 in stable there won't be new versions of K6.3 after that.Donations
Any donations are needed for future support.
Discuss this article
update.kunena.org/6.4/pkg_kunena_languages.xml
When checking I discovered that downloadurl is not correct:
Kunena 7.0.9 security release for Joomla! 5.4, 6.0 and 6.1
- Details
Introduction:
The Kunena team is thrilled to announce the ninth maintenance release of Kunena 7.0, a native Joomla extension for Joomla! 5.4, Joomla 6.x and Joomla! 6.1. Kunena 7.0 works on Joomla! 6.0 natively without the needs of compat plugin.
For people which wants help for translations, Kunena 7.0 files can be translated on crowdin : crowdin kunena
Kunena 7.0 has been designed to work on Joomla! 5.4, 6.0 and 6.1, the minimal requirements are the followings :- Php 8.2.0
- MariaDb 10.4 or MySQL 8.0.13
- Bootstrap 5.x
The work done in Kunena 7.0 is mostly to update the code base:
- Refactor all the code of plugin integration to be in Joomla! 6.0 by working with events and to drop the parts which was planned to be removed in this Joomla! version (thanks to ruud)
- New: scheduled task purge trashbin (thanks to ruud)
- Changes on the installer script to be able to work on Joomla! 6.0
- Make user type on whoisonline widget as links to open the userlist filtered
- Remove most of the deprecated code
- Refactor captcha handling conform with Joomla! 5.x and 6.0
New features:
The Kunena system plugin check on registration and on login if the user is in stopforumspam database and prevent them to make these actions
The Kunena configuraion has been converted to be the same that others configurations page in the Joomla! way
Download:
Download K7.0.9 stable here: https://github.com/Kunena/Kunena-Forum/releases/tag/7.0.9
Donations
Any donations are needed for future support.