Welcome, Guest
Username: Password: Remember me
Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

TOPIC: [Bug] Search Plugin has issues

[Bug] Search Plugin has issues 3 years 7 months ago #1

1. I noted that in the xml and php files, once the plugin is referred as "kunena" and once as "kunenasearch". This inconsistency causes the backend parameters to not display and the language file to not load properly.
2. Fixing those above, saved all issues except an error on searching:
Warning: Invalid argument supplied for foreach() in /home/***/plugins/search/kunenasearch.php on line 142
This basically means there is very probably an SQL error in the query.
The administrator has disabled public write access.

[Bug] Search Plugin has issues 3 years 7 months ago #2

Hello,

Thanks for the report, i will look this issue
  • xillibit
  • xillibit's Avatar
  • OFFLINE
  • Kunena Developer
  • I'am busy, we are busy, it's a busy business
  • Posts: 8209
  • Thank you received: 712
I don't provide support by PM, because this can be useful for someone else.
The administrator has disabled public write access.

[Bug] Search Plugin has issues 3 years 6 months ago #3

i have this error when trying the kunenasearch plugin in localhost :
Parse error: parse error, expecting `T_VARIABLE' or `'$'' in C:\xampp\htdocs\individual\forum\plugins\search\kunenasearch.php on line 149

bug?
  • sasuke
  • sasuke's Avatar
  • OFFLINE
  • New Member
  • Posts: 7
The administrator has disabled public write access.

[Bug] Search Plugin has issues 3 years 6 months ago #4

okay it's weird. when i install the kunenasearch plugin, it said : plugin installed succesfully.
when i see the file kunenasearch.php in \plugins\search, the file only has 149 lines (i checked the extracted zip files, the kunenasearch.php has 157 lines). So i have to copy the missing codes directly. Now the plugin not showing any errors anymore (like my previous post), but its still not showing the search result from kunena.
im using : plg_kunenasearch_v1.6.0-RC2_b94_2010-08-31
with kunena com_kunena_v1.6.0-RC3_b3539_2010-09-20

thankyou
  • sasuke
  • sasuke's Avatar
  • OFFLINE
  • New Member
  • Posts: 7
The administrator has disabled public write access.

[Bug] Search Plugin has issues 3 years 5 months ago #5

Same here.
Tried many things to get a search working.
Now i have exacly the same message.
/home/***/plugins/search/kunenasearch.php on line 142
Please let me know if you find a solution.
  • Startpuntict
  • Startpuntict's Avatar
  • OFFLINE
  • New Member
  • Posts: 6
  • Thank you received: 1
Last Edit: 3 years 5 months ago by Startpuntict.
The administrator has disabled public write access.
Time to create page: 0.213 seconds