×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 3.0 and later versions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Kunena Discuss Error: Rendering Error in layout Topic/Item

More
3 months 3 weeks ago - 3 months 3 weeks ago #1 by Sokrates
The Kunena Discuss is displayed before Read More in the Article Newsflash Module and "Rendering Error in layout Topic/Item: Call to a member function getIcon() on null. Please enable debug mode for more information." The error occur when the Article Newsflash Module is shown on a page that does not have any articles to be commented. The error do not occur when the Article Newsflash Module is shown on on a page where a single article is shown in stead of the blog view. It doesn't matter if I add the category of the page and a Kunena Discuss category and link them for the category.

I've tested to show the Article Newsflash Module on another menu page showing a single article and the error appears there too, so it seems that this error only appear when displaying the Article Newsflash Module on a page where a single article is show.

Kunena Discuss debug:

[KunenaDiscuss debug: onPrepareContent.Parent category ID is: 9 ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 73 is in the category map using Kunena category 46 ]
[KunenaDiscuss debug: onPrepareContent: we are viewing an article. ]
[KunenaDiscuss debug: onPrepareContent: Article 159 ]
[KunenaDiscuss debug: onPrepareContent: Custom Topics disabled ]
[KunenaDiscuss debug: showPlugin: Loading Stored Topic 12 ]
[KunenaDiscuss debug: showPlugin: Close time by last post ]
[KunenaDiscuss debug: showPlugin: Displaying form ]
[KunenaDiscuss debug: showTopic: Rendering discussion ]

I'm running: Joomla 3.9.19, Protostar template, Kunena 5.1.16, Kunena Discuss 5.1.2

Any idea why this error occur and how to solve it?
Last edit: 3 months 3 weeks ago by Sokrates.

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #2 by rich

Please enable debug mode for more information.

I think you should enable the Kunena debug and also additionally also Joomla debug. Set the error report to maximum for Joomla debug (Global Configuration -> tab Server). Maybe you get more precise error message.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.070 seconds