×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 3.0 and later versions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Kunena Discuss 3.0.1: Fatal error: Call to a member function reorder() on a non-object in ../administrator/components/com_content/models/article.php on line 617

More
6 years 7 months ago #21 by sozzled
I have marked this topic as resolved, renamed the subject, and made the topic "sticky" for the benefit of others who encounter the same issue.

In reviewing this topic, I came across a couple of other matters that may be of interest to N6REJ and to gray:

@N6REJ: Your configuration report, posted nearly 3 weeks ago, shows that you are using the JomSocial - Kunena Groups 2.0.3 plugin. This plugin does not work with K 3.0.4 and you should immediately uninistall (or upgrade) it; contact JomSocial for further information (see also To what extent does K 3.0 support Jomsocial ).

@gray: Your configuration report, posted a few hours ago, shows that you are using the plugins, JomSocial - My Kunena Forum Menu 2.0.3, JomSocial - My Kunena Forum Posts 2.0.3 and JomSocial - Kunena Groups 2.0.3. These plugins do not work with K 3.0.4 and you should immediately uninistall (or upgrade) them; contact JomSocial for further information (see also To what extent does K 3.0 support Jomsocial ).

N6REJ wrote:

Why on some installs and not others?

This is a good question! Although xillibit has provided us with a fix - one that I hope will be incorporated into the next release of Kunena Discuss (whenever that may be) - and although other people who do not use Kunena have also encountered the same problem , the only other common factor that I can deduce is some involvement with JomSocial.

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago - 6 years 7 months ago #22 by xillibit
I have provided a temporary fix but it's not done in correct way, i need to find if the issue isn't into Jomsocial itself

There is a JTable include path somewhere which call \components\com_community\tables\featured.php, so it fail to save the article

I don't provide support by PM, because this can be useful for someone else.
Last edit: 6 years 7 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #23 by N6REJ

xillibit wrote: In kunenadiscuss plugin there was a constructor method which call parent::construct(), when i have removed that it's worked.

I have looked default content plugin shipped with J!2.5 and 3.2 and there aren't constructor method.


If you rename this file it works : \components\com_community\tables\featured.php, i don't understand why JTable::getInstance() load the Jomsocial table file instead to load the right one from Joomla! :S

can you communicate this to jomsocial plz. They tend to not listen to me.

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago - 6 years 7 months ago #24 by xillibit
I have re-tested with Jomsocial 3.1.0.3, Joomla! 3.2.2, Kunena discuss 3.0.1 and i'am not encounter the issue, the issue seems to happen only with previous versions of jomsocial

I don't provide support by PM, because this can be useful for someone else.
Last edit: 6 years 7 months ago by xillibit.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.083 seconds