×
Kunena 5.1 Released (13 May 2018)

The Kunena team is pleased to announce Kunena 5.1.0 [K 5.1.0].
Please read the blog post for information: www.kunena.org/blog/192-kunena-5-1-released

×

Please Read This First:


This category is only for reporting defects with K 3.0.

Do not use this category:
  • to ask general questions about how to use K 3.0 or to ask when new versions of Kunena will be released;
  • to ask about other (older) versions of Kunena; or
  • if you have tried to install K 3.0 on J! 1.5; or
  • if you installed K 3.0 on a live, production site and you want your site restored to its previous state; or
  • if this website ( www.kunena.org ) works but works differently to how you expected.

You must include your K 3.0 configuration report; if you do not include your configuration report, your topic may be closed (locked) or deleted without any further warnings from the moderators.

Topics that have been closed (resolved) will be archived and no further discussion on those topics will be allowed.

Question Page does not reload after sending a post

More
2 years 8 months ago #21 by 810
don't know. There is no error message, but its working? then you can leave it disabled.

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #22 by chris9044
No unfortnatelly it is still the same error. When I click on "Send" the page seem to doesn't do anything, it just stays as the "Send" Button didn't work instead of switching to the sent post. So people think the post is not sent and click a second or third time on "Send" resulting in multiple posts in the forum. Like this the people mind to use the forum at all...

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #23 by chris9044
And if I disable the Kunena - Joomla Integration Plug-in it works perfect for me, but the access rigth system doesn't work anymore, so my users can't access the forum.

Thanks for further help!

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #24 by chris9044
Can anybody help me? The forum looses the users...

Thanks in advance!

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #25 by 810
The only you can try is creating a test site

Copy joomla files
Then import the database
setup the configuration.php on the root (to access database/website)
Install kunena.

Check if its working.

If working, then install your other components/plugins one by one. until its broken. Then you know where the issue is.

If not working, then there is a issue with database or server setting

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #26 by chris9044
Thanks for your answer. But I found out, that there is definitive no relation to another plug-in because of this error. Here the reason why:

First I started to switch off the Option "Activate Access Control" (or so, I have the german version) in the Kunena - Joomla Integration Plug-In.

Result: It worked for all forums, but only the members with "Moderation" - Access Level could see the forums. So I found out that it must have to do something with the access-control of Kunena. But with switched off the Option Access Control in the "Kunena - Joomla Integration" Plug-In there was no way to give access to my registred users to the forums.

Then I switched on the access control again and while trying I made a new forum and see: everything worked without problems in this new forum. But in the old forums I had the same problem again (not switching to the post after sending the post), and they have exactly the same settings...!

So it means: For new forums everything works well. For existing forums the error appears as sson as I activate the option access control in the "Kunena - Joomla Integration" Plug-In. As soon as I deactivate this option it works but my users have no entry anymore to the forums.

I know I could now make new forums and move all existing posts in this forums. But I have hundreds of posts and they are referenced with the URL in other sections so I would cut that links. And I also have installed Kunena Latest Module for each of the 24 forums and would have to change them as well. Means many hours of work. And last but not least: the users have mail-subscriptions on the forums and would loose them all. To instruct them to subscribe again would make me loose some users.

Is there another thing which could solve this problem?

Thans for your further answer!

Best Regards
Chris

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #27 by sozzled
I have stayed out of this topic for a couple of reasons:

1) The topic talks about a "defect" in K 3.0. The developers stated over one month ago at the time of the release of K 4.0.5:

K 3.0 is no longer an active project and support for K 3.X will cease on 31 August 2015.


Therefore the category could be locked at any time and I would not be able to give you my thoughts.

2) I do not know if this is a defect with Kunena or a problem caused by using Community Builder. Evidently the developers and moderators have been unable to help you find the cause of the problem as well. There is a separate category where people can discuss problems they may have using Kunena with Community Builder.

In my opinion it may be better to move this topic to the Community Builder category. Of course I cannot move this topic for you (and you cannot move this topic yourself) but you can ask the moderators to move the topic for you.

I understand that some people will have difficulty using the Kunena - Community Builder integration plugin . I admit that I have not used Community Builder for some years and I am not well versed in answering questions about this component.

Access control can be particularly troublesome.

Some years ago, when there was no serious access control in J! 1.5, Community Builder provided a way for people to secure their forum categories. Since J! 1.6, there has been less need to rely on Community Builder's access control mechanism. Kunena relies on Joomla's ACL access control.

Some people believe they can use Community Builder instead of Joomla to control access to their website assets. I make no comment about that.

If you look at just about any of the posts I have written on this forum, I recommend the following forum integration settings (if you are using Community Builder) shown in red text below:

Kunena - AlphaUserPoints Disabled
Kunena - Community Builder Enabled: access=0 login=0 activity=0 avatar=1 profile=1 private=0
Kunena - Gravatar Disabled
Kunena - JomSocial Disabled
Kunena - Joomla Enabled: access=1 login=1
Kunena - Kunena Enabled: avatar=0 profile=0
Kunena - UddeIM Enabled: private=1

You should also be using the latest version of Community Builder (version 2.0.10)

If you require help with Community Builder, perhaps the first place to start is with the good people at Joomlapolis

When you wrote that you were having problems with your "old [categories]", perhaps a good place to start is to look at the permissions for those categories with the Kunena Category Manager. When you say that these are "old [categories]", are they old because you migrated your website from J! 1.5? Perhaps some things were not properly finalised as part of that Joomla migration?

I do not think you will need to move topics from your "old [categories]" to the newer categories. I do not think you will need to have to ask your users to re-subscribe, either.

I will do the best I can help you but I believe I have given you a few things to think about as a start.

The first suggestion I would make is that you ask the forum moderators to move this topic to the Community Builder category and, that way, we will not lose the ability to keep giving you the help that you have asked for. The moderators will not move this topic because I have suggested it; the moderators here do not agree with most of my suggestions as to where topics should be located. :)

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #28 by chris9044
Dear sozzled

1) In the beginning of the problem I used K3 but I updated now to K4.05, where I still have this problem, so maybe the topic should be moved to Kunena 4.0 Support Forum

2) I have CB 2.0.10 installed and used exactly the same settings as you recommend

But even when I switch CB-Integration completly off it doesn't work, so it will be no CB-Issue. It seems to work with CB but I don't want to do the access control with CB.

The permissions for the old and new categories in the category manager are exactly the same.

The "old" forums have been migrated from 1.5 - you're rigth with that. But they worked without problems after the migration one year ago. I didn't changed anything at or just before that moment the problem occured. But I don't now if maybe the provider changed to a newer version of php. But this shouldn't be a problem or?

Best regards
Chris

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #29 by sozzled
I will let you decide how you want to have this topic relocated. I believe your problem is related to a post J! 1.5 site migration issue. I have written before about post-migration issues in this forum and elsewhere.

If you want a response to a problem caused by K 4.0.5 then, by all means, have the topic moved into the "reporting defects" category and let the developers try to help you there.

If, as I suspect, the problem is caused by Community Builder then the "CB" category is better, in my opinion, and I may be able to assist you there.

I have studied this topic and the only configuration report I have seen is in the first post. Therefore, unless I saw an updated configuration report from you, I would only be guessing as to what you might try next.

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #30 by chris9044
As I wrote it will be most probably a K4.05 Issue, because it happens also without using CB plugin but I cannot move it there myself. I'm wondering why you suspect a migration problem. It worked a year without problems before the error appeared and if I open a new forum it works as well. So if its a migration problem, than it would be in the settings of the "old" forums. But if I give the access rights to CB than it works, so this is curious.

I think it has to do with the access-right check, which Kunena performs. After this check and the sending of the post it stops somewhere and not forward the site after to the sent post out of some reason.

Here the configuration report (after I switched the CB-Plugin on for the avatar):
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 50000 seconds | Max execution memory: 120M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : SustainCo-Intranet | author: Design72 | version: 2.5.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.5 | creationdate: 2015-08-17

Kunena version detailed: Kunena 4.0.5 | 2015-08-17 [ Turnau ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1 | UddeIM 3.7

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.1.1

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.121 seconds