×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

× Topics that are moved into this category are considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Important New post always defaults to anonymous user?

More
4 years 3 months ago - 4 years 3 months ago #11 by sozzled

bolla wrote: If this is a :S feature of Kunena, it is a really confusing feature.

You are probably right and, perhaps, these anonymous posting settings are a bit confusing. I was confused because you edited your message in msg #3 after I replied.

There are two settings in the Kunena category manager that control anonymous posts:
  1. Category Manager » <category> » Category Settings » Allow anonymous messages = No Yes
  2. Category Manager » <category> » Category Settings » By default post replies as = Registered User | Anonymous

The second setting only works if the first setting is true.

If you have the following values
  1. Category Manager » <category> » Category Settings » Allow anonymous messages = Yes
  2. Category Manager » <category> » Category Settings » By default post replies as = Registered User

this is what people will see when they create a new message in that <category>



These are the settings that you showed us in msg #3 of this topic. In this case, the new message is not posted "anonymously".

If you want the message to be posted anonymously then you need to check the box labelled "This post contains sensitive information. Remove all user information from this post."

But you are right. There are some issues when people reply to topics that were created after a topic was created anonymously. To be honest with you, I spent about 30 minutes testing things out - I have not experimented much with the anonymous feature because I don't have a personal need for this in everyday use - and it would probably take me a few hours to summarise my findings. I don't really think it's worth all of that effort.

I will concede that there may be a defect in the way that this works. It is possible that there is a bug that you found. When you consider that K 3.0 has existed for nearly 12 months and this is the first time I have read about someone having a problem with this feature, that tells me that the feature is not often used or no-one else has taken the time to report the fault.

bolla wrote: Never mind, I just removed the Kunena menu item "New Post" from the Kunena top menu. Now, by forcing my users to select a specific category first, then "New Post" allows [anonymous posting the way that I want it to work].

Quite right, too. For a number of reasons, we removed the New Topic menu item from the forum at this site. When I set up Kunena on my own websites, I remove the New Topic menu item, too. You may have discovered another reason why it is a good idea to not have the New Topic menu item. :)

I have moved this topic to our "reporting defects" category and I will encourage the development team to check out your claims and advise the community what, if anything, needs to be done. In the meantime, you have found a workaround to the issue and I wish to place on record our appreciation for bringing this matter to our attention.
Attachments:
Last edit: 4 years 3 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.160 seconds