Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Solved Succecfully installed but NO kunena at components

More
5 months 2 days ago - 5 months 1 day ago #41 by uzbaby
 Thank you very much!I exportet kunena files only. You can see the selection in the attached file.Then I start to import them to the site.Here is my kunena data SQL file. Maybe there is some problem?

This message contains confidential information
Attachments:
Last edit: 5 months 1 day ago by rich. Reason: Link made invisible

Please Log in or Create an account to join the conversation.

More
5 months 2 days ago - 5 months 2 days ago #42 by Leen
Hello  I think your link is not safe to show  sql data publicly put it between the secret tags or delete it.

L.v.d.A
Last edit: 5 months 2 days ago by Leen.

Please Log in or Create an account to join the conversation.

More
5 months 1 day ago #43 by rich

Go to your created database with the old tables. Select only these Kunena tables (see picture). Then scroll down and select Export in the dropdown menu and click OK

You have exported again the complete database. I had written that you have to scroll down and click on Export in the drop-down menu. If you click on Export at the top, the selection is no longer valid and everything is exported.

The second problem is that your database is extremely large and the upload limit of phpMyAdmin is exceeded. You have to export the Kunena tables as a .zip file, otherwise you cannot import them into the Joomla 4 database. 

Hint: I understand why you want to do it yourself, but I won't take responsibility if something goes wrong.

Please Log in or Create an account to join the conversation.

More
5 months 1 day ago - 5 months 1 day ago #44 by uzbaby
Thank you so much Rich! YOu are a genius! Thank you very much
Leen thank you too!

But now I have some strange behavior in my forum.
I cannot write posts
Cannot open new thread
Cannot see subcategories list

This is the main page with all categories: www.uzbaby.uz/forum
But when you go to subcategories it shows pages list and nothing else (there are no subcategories list but there is pages list): www.uzbaby.uz/component/kunena/konkurslar
Can you please help please

Screen of the subcategories page and screen of the Kunena admin dashboard page 
Attachments:
Last edit: 5 months 1 day ago by uzbaby.

Please Log in or Create an account to join the conversation.

More
5 months 1 day ago - 5 months 1 day ago #45 by Leen
good to hear you've made some progress.
Perhaps it would be useful to place a new kunena Report Configuration Anonymous here.
make sure you always make a backup (akeeba) so that this version is now also saved.
Have you looked at Kunena templats to see if it is standard and if necessary confirm it again there.
Furthermore, you have already synchronized the users with Kunena tools.
And take a look at Kuneatools Diagnosis what it says there.

L.v.d.A
Attachments:
Last edit: 5 months 1 day ago by Leen.

Please Log in or Create an account to join the conversation.

More
5 months 19 hours ago #46 by rich

And take a look at Kuneatools Diagnosis what it says there.

Do not click on Repair in the diagnostic! Otherwise all pictures and avatars will be gone and you will have to re-import the Kunena tables. Only experienced users should use this option as this tool removes data from the database!

1. please create a configuration report
2. unzip the backup file on your PC.
3. copy the Attachments and Avatars folders (path is /media/kunena) and copy these folders over the folders on your website (it is the same path /media/kunena).

Note: It seems that you did not remove some extensions (like uddeim) before migration. Extensions that have not been adapted to Joomla 4.x generate errors.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #47 by uzbaby
Thank you very much!
I copied Attachments and Avatars folders to my site /media/kunena
As for uddeim I deleted it several years ago. I don't know why it is still there
Here is my configuration report:

This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 512M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.2 | creationdate: 2022-08-15

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.2 | 2022-08-15 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None




But I really cannot post any post and still do not see any subcategories
Please please please

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago - 4 months 4 weeks ago #48 by Leen
Hello,

in your configuration report:
can be seen that the kunena Aurelia template may not be set as default yet.
select it again as default and then click the default button.
and also something went wrong with your kuena menu
so look in your main menu of the website see if there are those forum menu items if good you have to throw them in the trash
and empty trash then in kunena>tools
Restore Kunenamenu and then publish this forum item in your main menu again
look at Create the Kunena menu

L.v.d.A
Attachments:
Last edit: 4 months 4 weeks ago by Leen.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #49 by rich
Yes, Leen is right the missing menu items are the problem. Kunena only works properly when these are present in the Kunena Menu.
1. First create a database backup of your complete Joomla 4 site. Since this is too large to import it back with phpMyAdmin in an emergency, you can split it. First mark only the Joomla tables and export them and then all Kunena tables. 
2. Delete all Kunena menu items.
3. Trash all existing menus and menu items that relate to your Kunena forum.
4. Remove these menu items from the trash.
5. Go from Kunena Dashboard to Tools and restore the Kunena menu
6. Go to the main menu and publish the automatically created menu item.
After that the forum should work.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #50 by uzbaby
Thank you very much! But now there is no forum at all.
Here are the screens:
#1 Screen. Page where you can see that I did created according to this: Go from Kunena Dashboard to Tools and restore the Kunena menu (I trashed and deleted Trash for Kunena Menus before that).
#2 Screen. After publishing Menu I see only empty Forum.
#3 Screen. My Kunena Dashboard screen after all.

Also I will add Configuration Report after all:

This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 512M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.2 | creationdate: 2022-08-15

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.2 | 2022-08-15 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.469 seconds