×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Error in msqli.php file: Unknown column 'undefined' in 'where clause'

More
1 month 5 hours ago #11 by rich
I've now tested with Maria database MySQL version: 5.5.5-10.1.40 but can't to reproduce this error.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #12 by xillibit

mbistato wrote: Hi there,

I installed the 5.1.15 Kunena version on Joomla 3.9.10 and I got the error

Exception throw at line 665 in file /home/usivunqc/public_html/libraries/joomla/database/driver/mysqli.php with message Unknown column 'undefined' in 'where clause'

as I try to upload any attachment. The result is that the file is not attached.

Does anyone know how to fix it?


Thank you.

Hello,

I'am restarting from the begining, is-it possible please to have a FTP access to your site to try to figure which query is failing ? Or maybe you can set up a test site like that i can look on FTP ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #13 by mbistato
Hi xillibit,

here you go

This message contains confidential information


Thank you once again.

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #14 by xillibit
Hello,

When i connect to your FTP account, it just goes to an empty but not to the website directory. And in the same is it possible to have an account to you forum ? like that i can try in the same time

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 weeks 12 hours ago #15 by mbistato

xillibit wrote: Hello,

When i connect to your FTP account, it just goes to an empty but not to the website directory. And in the same is it possible to have an account to you forum ? like that i can try in the same time


I fixed the issue so you can now access via FTP.
To create an account on my forum I need your email address.

Thanks

Please Log in or Create an account to join the conversation.

More
2 weeks 10 hours ago #16 by rich

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #17 by mbistato
Account created.

This message contains confidential information

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #18 by xillibit

mbistato wrote:

xillibit wrote: Hello,

When i connect to your FTP account, it just goes to an empty but not to the website directory. And in the same is it possible to have an account to you forum ? like that i can try in the same time


I fixed the issue so you can now access via FTP.
To create an account on my forum I need your email address.

Thanks

Hello,

I have just tried to connect to your FTP by it goes not at root of Joomla! directory but at an another place

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #19 by mbistato
Hi,

I'm very sorry but I've just realised that the directory path was wrong so I sorted it out. Now it should be ok.
Let me know if not.

Thanks.

Please Log in or Create an account to join the conversation.

More
5 days 13 hours ago - 5 days 13 hours ago #20 by xillibit
Hello,

It fails when submit on this query :
SELECT * FROM xxxx_kunena_attachments WHERE id IN (undefined)

but at this first place it fails because it doesn't get the file size of uploaded file, the file seems to be uploaded in /tmp/uploads with right in 644 but no size is returned. So it could be the default right of file aren't enough, then nothing is moved under media/kunena/attachments/userid, the no id are returned for attachment and it fails at the end with the query above

I don't provide support by PM, because this can be useful for someone else.
Last edit: 5 days 13 hours ago by xillibit.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.074 seconds