×
Kunena 5.1.3 Released (19 Aug 2018)

The Kunena team has announce the arrival of Kunena 5.1.3 [K 5.1.3] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a maintenance release.

Question Error page when clicking on some categories

More
3 weeks 6 days ago #11 by rich

How come that with Kunena 5.0.14 (on my joomla 3.8.11 website) , the forum works perfectly and not with the 5.1.3 ? So weird.
Well, if you see anything else that could be wrong, I am all ears because it's beyond me.

Errors in the menu structure often do not occur immediately. But at some point they make themselves felt.

But this is not the problem now. Your configuration report shows htaccess: Missing. So it seems, the htacces is the problem. Therefore a backend access for me will not help. You must repair your .htaccess file.
The root folder is the folder where you've installed your Joomla. In your case it's the folder named Joomla.
Try it with the content from the original htaccess file from Joomla.

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #12 by fabio42170
What do you mean by "Try it with the content from the original htaccess file from Joomla." ?
Should I :
1/ Place the original joomla .htaccess file (I copied what you gave me in a file which I renamed to ".htaccess") inside my joomla folder ? I did it and I still get the error message ...
2/ Place the original jooma .htaccess file outside my joomla folder, which makes no sense then because the configuration would be wrong ... and anyway, I tried and got a 404 error page.
For the moment, I left the original .htaccess file inside my joomla folder so you can check.
Should I configure something inside my .htaccess before placing it inside my joomla folder ?
To be continued ...

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #13 by rich

copied what you gave me in a file which I renamed to ".htaccess"

Yes, thats correct. Afterwards empty all caches. If it still not work, go to the Joomla Global Configuration and disable Search Engine Friendly URLs.
Then go in the frontend back to Home and afterwards again in your Forum and try if it works.
Please add again a configuration report, so I can see whether the htacces is displayed.

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago - 3 weeks 6 days ago #14 by fabio42170
Did all you told me. I still get the error message. With SEF on or off. I systematically cleared the cache to test this.
Here's my report :
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : g5_helium | author: RocketTheme, LLC | version: 5.4.24 | creationdate: July 4, 2018

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.3 | creationdate: 2018-08-19

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.3 | 2018-08-19 [ Dione ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


And by the way, this is the contents of the .htaccess which is at the root of my joomla folder :
##
# @package Joomla
# @copyright Copyright (C) 2005 - 2018 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line 'Options +FollowSymLinks' may cause problems with some server configurations.
# It is required for the use of mod_rewrite, but it may have already been set by your
# server administrator in a way that disallows changing it in this .htaccess file.
# If using it causes your site to produce an error, comment it out (add # to the
# beginning of the line), reload your site in your browser and test your sef urls. If
# they work, then it has been set by your server administrator and you do not need to
# set it here.
##

## No directory listings
<IfModule autoindex>
IndexIgnore *
</IfModule>

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
# Block any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root home page
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment the following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
Last edit: 3 weeks 6 days ago by fabio42170.

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #15 by rich
The .htacces exists now. But I found another thing on your page. It's not possible to call your main domain. You get a redirect to yourwebpageaddress.fr/joomla/index.php
Maybe this is the fault. Can you disable this redirect please and afterwards to test again? This redirect can be via a plugin or also in the htaccess in the main domain. If does not help I've no idea anymore.

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #16 by fabio42170
A few questions before I detail my settings.

But I found another thing on your page

What page ? When I am on the 4u2speak main page after clicking on the 4u2speak menu link in the main menu ? Or the page which I should get to when I click on one section ?

It's not possible to call your main domain

I don't understand what you mean as I'm not tech-savvy.

You get a redirect to yourwebpageaddress.fr/joomla/index.php

At what moment ? When I click on the title of a section ?

And to complete your explanations, my general question is : how do you manage to see all this ? I tried to use the firebug extension to follow my network connections and links but this was not helpful or I may not know how to use that smartly. Have you got any tips/tools on how to detect what you detected (the redirect in particular) ?

Finally, to answer your questions :
- I don't have any .htaccess on my main domain. The only one I have is the one I copied from you and placed in my joomla folder. My configuration has never changed since I've been using joomla, and my provider is serious enough (OVH), they never interfere with scripts. My previous 2.5 joomla website on this server used to work great with the config I had.
- I went through all plugins but none of them have parameters which force a redirect. The only one that could have been suspected was the native joomla redirect plugin but disabling it did not change anything.

Well, thanks in advance for your precious answers.
Meanwhile if you can't help me no more, I'll sadly revert back to 5.0.14 and try in the years to come to try the major updates to finally hope something will work out someday...
Fabio

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago - 3 weeks 6 days ago #17 by rich
I had tried it only via the browser address. If you enter only the address "yourwebpage.fr" in the browser you get a redirect to "yourwebpage.fr/joomla/index.php". Thats I meant. Why it is so?
Last edit: 3 weeks 6 days ago by rich.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #18 by fabio42170
Well, apparently, this is not uncommon as you can read here :
stackoverflow.com/questions/21186428/joo...php-added-to-the-url
Some tutorials offer the possibility to hide the "index.php" (like here : www.joomlart.com/tutorials/joomla-tutori...-index-php-from-urls ) but I've never found sites encouraging to systematically redirect to the main domain (ex : www.mysite.com ), as this causes problems when joomla needs other pages to work (for ex, the admin page, which calls for administration/index.php), that's why I do feel unwilling to modify my .htaccess to include redirects ...
I've browsed through my configuration.php file and no value is set. Nowhere in the joomla config can you see a parameter (unless I'm mistaken) which redirects you to your domain. My htaccess does not point to the index.php either. So, I suppose it is a set server parameter. In fact, I've always had this before, so I can't really guess why it is so.
Fabio

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago - 3 weeks 5 days ago #19 by fabio42170
I investigated further by changing my SEF settings in joomla :
SEF : no

When I click on the name of a category (like "suggest" for example) this is where I get redirected :
https://www.4u2learn.fr/joomla/index.php?option=com_kunena&view=category&catid=5&Itemid=615
And it works

When I click on the name of a section (say "general" for example) this is where I end up :
https://www.4u2learn.fr/joomla/index.php?option=com_kunena&view=category&catid=4&Itemid=615
And there's the error message
In the address above, is there anything wrong in the url that could cause the error message ?
Thanks in advance
Last edit: 3 weeks 5 days ago by fabio42170.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #20 by 810
url looks ok to me.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.130 seconds