×
Blue Eagle (1.5.0) for K5.1 is released (Yesterday)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

Solved Links to Attached PDF's all lead to 404 Page

More
3 weeks 2 hours ago - 2 weeks 6 days ago #1 by mdfavionics
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 100M | Max file upload: 50M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : J51_Letterpress | author: Joomla51 | version: 1.2 | creationdate: June 2013

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.1 | creationdate: 2018-06-10

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.1 | 2018-06-10 [ Belinda ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.1.0

Modules: Kunena Latest 5.1.0 | Kunena Stats 5.1.0 | Kunena Login 5.1.0 | Kunena Search 5.1.0



I'm not sure what update caused my PDF links to all fail. To rule out a server change (year+ ago) I added a new PDF attachment to a post.
Same fault.
Files are present in Kunena media attachments file on server.
Last edit: 2 weeks 6 days ago by mdfavionics.

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago - 2 weeks 6 days ago #2 by mdfavionics
This browser does not support PDFs. Please download the PDF to view it: Download PDF.
The above is the message displayed on any post with a PDF. To verify the problem is not browser related, I tried with several browsers on both Linux and Windows Computers.
A post from years ago is an example, rotate.aero/forum/ata-24-electrical-gene...aircraft-power-pdf#7
I deleted the old file and reinserted a new one....... same results.
Last edit: 2 weeks 6 days ago by mdfavionics.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #3 by rich
This bug is already fixed. You can install Kunena nightly build or you change one line in the pdf.php

Path is /components/com_kunena/template/system/layouts/bbcode/attachment/pdf.php

Change the line 16
from
$location   = \Joomla\CMS\Uri\Uri::root() . $attachment->getUrl();
to
$location   = $attachment->getUrl();

github.com/Kunena/Kunena-Forum/commit/ab...8f8b690c7e4a63a53f6f
The following user(s) said Thank You: mdfavionics

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #4 by mdfavionics
Problem solved..... Thank you.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.128 seconds