×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Cannot create new topic - Fatal Error: Class 'KunenaSpamRecaptcha' not found

More
2 years 9 months ago - 2 years 9 months ago #11 by oestek
I noticed that the Kunena documentation references the reCaptcha settings and shows the image with the public key, etc:, but I have no options for those.

From the documentation: (IGNORE THE RED BOX, that is from the documentation and does not apply to this example)


My setting options:

Is my control panel missing some code?
Attachments:
Last edit: 2 years 9 months ago by oestek.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #12 by rich

... and shows the image with the public key, etc:, but I have no options for those.


This option was still displayed with older Kunena 4.0 and is complete removed in Kunena 5.0. I've changed the image now.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #13 by oestek
Update: The fatal error appears when a "new topic" or "create reply" is attempted, but not when the "quick reply" button is selected.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #14 by oestek
Still open to suggestions on this Fatal Error, we are still receiving it.

Thank you!

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #15 by rich
You use Joomla Key Captcha on your page. Maybe there is a conflict? If the reCaptcha plugin is enabled, then disable this plugin and change the setting in Kunena (tab security) to:
Display Captcha for : = Guest Users and Registered Users
CAPTCHA Challenge for Users = 0

Then empty the cache and try it again.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #16 by oestek
Thanks. I did as you suggested but still see the error.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #17 by oestek
Hello,

I have still made no progress on this error. What can I be checking for? I've been through every extension / module and we still have the 500 server error. I've checked permissions, updates, and everything I can think of. Really appreciate any thoughts.

Thanks!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.3 | creationdate: 2016-10-23

Kunena version detailed: Kunena 5.0.3 | 2016-10-23 [ Dibatag ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.0.1 | Content - Kunena Discuss 5.0.1

Modules: Kunena Latest 5.0.1 | Kunena Stats 5.0.1 | Kunena Login 5.0.1

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #18 by 810
maybe missing table for joomla recaptcha.

try on subdomain, new joomla install. Then copy the kunena tables. Then install kunena package.

Set the site configuration. And see if its works now.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.136 seconds