×
Kunena 5.1 RC 3 Released (16 Feb 2018)

The Kunena team is proud to announce the arrival of Kunena 5.1.0 RC3 [K 5.1.0] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a RC release.

Question Getting 404 errors when trying to view any forum topics.

More
7 months 1 week ago #1 by nemmar
nemmar created the topic: Getting 404 errors when trying to view any forum topics.
Hi,

I have K 5.0.10 and I am getting 404 errors when I try to view any of the forum topics. You can view my main forum page www.05clonetest.nemmar.net/forum
If you drill down to view any of the topics, you will get the 404 error. Can you tell me what could be wrong?

Thanks.

Here is my Kunena config report:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 45 seconds | Max execution memory: 512M | Max file upload: 24M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : RSJuno! | author: RSJoomla! | version: 2.0.27 | creationdate: June 2015

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.2 | creationdate: 2017-01-09

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.0.10 | 2017-06-30 [ Junco ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.0.3 | Content - Kunena Discuss 5.0.3

Modules: Kunena Latest 5.0.3 | Kunena Stats 5.0.3 | Kunena Login 5.0.3 | Kunena Search 5.0.3

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago #2 by rich
rich replied the topic: Getting 404 errors when trying to view any forum topics.
Your link to the forum goes to a non existing menu item. You have no menu item with the ID 1929 (should be the Index).
Go in backend to "Menus -> Kunena Menu" and create the menu item Index (Menu Item Type = Category List) again. Then choose at the menu item "Forum" the menu item Index as targed.

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago #3 by nemmar
nemmar replied the topic: Getting 404 errors when trying to view any forum topics.
Hi rich,
I tested out your recommendation but it didn't fix the 404 errors. I haven't changed those menus in a long time so the problem must have been something that started recently during a Kunena update or a Joomla update to 3.7.3.
I tested out using the Kunena Home and Kunena Category List (with Top Level) menu items in the Kunena menu, and then I pointed the "Forum" menu item alias in the main menu to that Forum Home/Index/Category List menu item. But I still get 404 errors when I try to click and view any topics in the forum.

What can I test out to try and fix this?

Thanks.

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago #4 by rich
rich replied the topic: Getting 404 errors when trying to view any forum topics.

I haven't changed those menus in a long time so the problem must have been something that started recently during a Kunena update or a Joomla update to 3.7.3.

Incorrectly created menu items do not always have an immediate effect. But at some point the error becomes noticeable. And it may be that it is after an update. Please see also docs.kunena.org/en/troubleshooting/menu-issues and docs.kunena.org/en/faq/kunena-menu


The menu item in the main menu was correctly. The menu item "Forum" in the kunena menu has no target, as you can see in the image from your configuration report.
Number 1 is the menu item in the main menu. It linked to the kunena menu item "Forum" 1927 (number 2). That is the menu item Home Page and would be so far correctly. But this menu item "Forum" linked to the menu item 1929 (number 3). And this submenu item lacks (see left side, red marked).

Attachments:

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago #5 by nemmar
nemmar replied the topic: Getting 404 errors when trying to view any forum topics.
Hi rich,
Have other Kunena users been reporting this problem? Or is this something that is unusual with the updated forums?

I read those two help doc pages but didn't find a solution but I also didn't try deleting all my Kunena menus and then re-creating them. I'm having this problem on all my Kunena forums on all my Joomla websites, so I'm hoping I don't have to delete and re-create all the menus manually.
docs.kunena.org/en/troubleshooting/menu-issues This help doc mentions: "The Kunena menu is a set of tabs that appears across the top of the forum pages. In some cases, this menu does not appear for a variety of causes." But my Kunena menu tabs do display so I don't think this help doc is the solution.
docs.kunena.org/en/faq/kunena-menu This help doc has one option to "Restore Kunena Menu" but then I will lose all my existing Kunena menus, which I'm hoping isn't my only option.

I have the Kunena Discuss plugin enabled. Could that have something to do with the 404 errors?
I deleted the forum home tab Kunena menu item and emptied the trash. But that didn't fix the problem either.
Here are the menu screenshots of what I have now and it did not fix the problem. What possible solutions are there for me to figure out why all my Kunena forums on all my sites are having this problem?
Screenshots:
drive.google.com/file/d/0BwXZzY2mIiORdkN...b28/view?usp=sharing
drive.google.com/file/d/0BwXZzY2mIiORNS1...cTQ/view?usp=sharing
drive.google.com/file/d/0BwXZzY2mIiORMHg...aFk/view?usp=sharing

Thanks.

Please Log in or Create an account to join the conversation.

More
7 months 5 days ago #6 by rich
rich replied the topic: Getting 404 errors when trying to view any forum topics.

Have other Kunena users been reporting this problem? Or is this something that is unusual with the updated forums?

There have been similar problems, but the cause were extensions which you have not installed.

I have the Kunena Discuss plugin enabled. Could that have something to do with the 404 errors?

Disable the plugin and you will see it.

This help doc has one option to "Restore Kunena Menu" but then I will lose all my existing Kunena menus, which I'm hoping isn't my only option.

If you have not a test page, then set your focus at the moment only to a single page. There is no guarantee, if you delete and recreate all menus, whether it works afterwards. But then you have certainty and you could to spare a lot of work with error search.
Your menu items (according to the screenshots) are again wrong configured. The link in the main menu has no target ID, and the menu item "Home Page" in the kunena menu linked to himself.

Please Log in or Create an account to join the conversation.

More
7 months 5 days ago #7 by nemmar
nemmar replied the topic: Getting 404 errors when trying to view any forum topics.
Hi rich,
I tested again by deleting the Kunena menu forum home item and the main menu forum alias. Then I re-created them after clearing the trash. I tested both the Kunena menu forum item as the "Home" menu type and the "Category List" menu type. But nothing corrects the problem. I also disabled Kunena Discuss plugin during all testing and that didn't fix the problem either.
I'm not having any problems with my other menu navigation items on my sites, so it must be a conflict with J3.73 and the Kunena menu. Is there a Kunena expert that I can email my SU login to so they could test to find out what the cause is?

Thanks.

Please Log in or Create an account to join the conversation.

More
7 months 5 days ago #8 by rich
rich replied the topic: Getting 404 errors when trying to view any forum topics.

I tested again by deleting the Kunena menu forum home item and the main menu forum alias. Then I re-created them after clearing the trash. I tested both the Kunena menu forum item as the "Home" menu type and the "Category List" menu type. But nothing corrects the problem.

It makes no sense if you try always the same. Either you delete radically all menu items or you searching further. If you create a database backup previously, you have the deleted menus within 2 min back if it also with new menus not work.

But I see a further problem. In your configuration report is a mix between old version of Kunena and new version. Could it be, you have still adaptations from early versions? In your configuration report are options, which long time ago removed from Kunena. Empty also the cache before you test again.

Please Log in or Create an account to join the conversation.

More
7 months 5 days ago #9 by nemmar
nemmar replied the topic: Getting 404 errors when trying to view any forum topics.
Hi rich,

1) Is there something I can do to remove the "old verion" of Kunena that you said is in my config report? I only update Kunena using the normal update feature of the extension. So I don't know how the old version is still there.

2) I deleted all the Kunena menu items, then I emptied that trash and the cache. Then I created a new Kunena menu item and I tested this with "Kunena Home" and "Kunena Category List" menus. But I still get the 404 errors.

I have Discuss plugin disabled but one thing I noticed is that the 404 errors are due to URL's that have the beginning part listing the forum navigation URLs, but the ending part appears to be the Joomla article navigation URLs. For example:
www.my domain name/forum-alias/health-safety-mold-mildew/12577-selling-home-may-be-influenced-by-what-buyers-can-t-see-2009-06-19
The ending of the URL is the Joomla article URL: 12577-selling-home-may-be-influenced-by-what-buyers-can-t-see-2009-06-19
Is is possible that the Kunena Discuss plugin created the bug when it added the topics to the forum? For example, I had Discuss plugin set to create the topic for each article on the first visit. I later changed that to first reply but that plugin is now disabled for this testing.

Thanks.

Please Log in or Create an account to join the conversation.

More
7 months 2 days ago #10 by rich
rich replied the topic: Getting 404 errors when trying to view any forum topics.
If you want I can do a look. But create a full backup previously. You can send the access data to [email protected]*kunena.org (address without star).

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.148 seconds