×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Problems with Image Attachments

More
3 years 3 months ago - 3 years 3 months ago #11 by ssh
Replied by ssh on topic Problems with Image Attachments

paul123 wrote:
image-2-3-4-5-6-7-8-9-10-11-12-13-14-15-16-17-18-19-20-21-22-23-24-25-26-27-28-29-30-31-32-33-34-35-36-37-38-39-40-41-42-43-44-45-46-47-48-49-50-51-52-53-54-55-56-57-58-59-60-61-62-63-64-65-66-67-68-69-70-71-72-73-74-75-76-77-78-79-80-81-82-83-84-85.jpeg

Naturally, this causes all sorts of problems with moving files, as the filename is too long to be used on any windows system. This really could do with being fixed so either then numbers increment in a more simple way, or even so images get a random string of characters added.


I can also confirm this bug.
And guess what?
I also comes in a different flavor like .doc


Attachments:
Last edit: 3 years 3 months ago by ssh.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #12 by WolfgangOWL

810 wrote: @WolfgangOWL I have also added flip now, so all orientation are now working, please test if ok:
github.com/Kunena/Kunena-Forum/pull/4182


Thanks. I tested and all orientations are working fine. I ignored the "flipped" ore "mirrored" information in my version because I thought that if this flag is set this must have be done on purpose. Well, maybe I am wrong.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #13 by WolfgangOWL
I found another issue with uploading images. With Blue Eagle uploaded images were inserted in one column. Now, with Crypsis attachments are inserted in one line. This looks weird if you upload a mix of small and big images in one post. Of course this can be fixed if you insert a line break after each attachment manually. But our average user doesn't think about it when uploading images.

To insert a line break on upload automatically I added cr/lf in line 8 of upload.main.js
$('#kbbcode-message').val(value + ' [attachment=' + attachid + ']' + filename + '[/attachment]' + String.fromCharCode(13) + String.fromCharCode(10));

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #14 by xillibit

ssh wrote:

paul123 wrote:
image-2-3-4-5-6-7-8-9-10-11-12-13-14-15-16-17-18-19-20-21-22-23-24-25-26-27-28-29-30-31-32-33-34-35-36-37-38-39-40-41-42-43-44-45-46-47-48-49-50-51-52-53-54-55-56-57-58-59-60-61-62-63-64-65-66-67-68-69-70-71-72-73-74-75-76-77-78-79-80-81-82-83-84-85.jpeg

Naturally, this causes all sorts of problems with moving files, as the filename is too long to be used on any windows system. This really could do with being fixed so either then numbers increment in a more simple way, or even so images get a random string of characters added.


I can also confirm this bug.
And guess what?
I also comes in a different flavor like .doc


Are-you able to reproduce this issue on others devices than iphone ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #15 by ssh
Replied by ssh on topic Problems with Image Attachments

xillibit wrote: Are-you able to reproduce this issue on others devices than iphone ?


I think this problem does not exist anymore in K.5.0.RC5+Crypsis
According to my records, the last time I had this issue was 11November2015
At that time I was using K.4.x+Blue Eagle

Maybe @paul123 has a different experience regarding this.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #16 by xillibit
Else i can set something with timestamp to differenciate the attachments : my_attach-1470214959.jpg, my_attach-1470214995.jpg, my_attach-1470215025.jpg ...

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #17 by ssh
Replied by ssh on topic Problems with Image Attachments
@paul123
I think @xillibit is waiting an answer from you.

For me, I haven't seen this bug again, I think it doesn't exist anymore in K.5.xxx

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.132 seconds