Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Question Error when editing user profile

  • Pinkeltje
  • Pinkeltje's Avatar Topic Author
  • Offline
  • Premium Member
  • Trying to find an answer before asking
More
2 weeks 5 days ago - 2 weeks 5 days ago #1 by Pinkeltje
When editing user profile and trying to save, this error appears:

Unknown column 'bsky_app' in 'field list'Error on saving profile

I guess there is an error in line 264 of kunena.install.upgrade.xml
Code:
 ALTER TABLE `#__kunena_users` ADD `bsky_app` varchar(75) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NULL AFTER `reddit`
I think it should be
Code:
 ALTER TABLE `#__kunena_users` ADD `bsky_app` VARCHAR(75) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NULL DEFAULT NULL AFTER `reddit`;
Last edit: 2 weeks 5 days ago by Pinkeltje.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #2 by Gindi
Are you editing your own profile or a user profile?
I have edited my own profile and saved it without an error message.
The entries for 'bsky_app' are OK in the database.

 

Gindi

Please Log in or Create an account to join the conversation.

  • Pinkeltje
  • Pinkeltje's Avatar Topic Author
  • Offline
  • Premium Member
  • Trying to find an answer before asking
More
2 weeks 4 days ago #3 by Pinkeltje
It was my own profile. Added the record manually to the database and now it's ok.

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #4 by xillibit
The query had been tested on phpmyadmin before but sometimes there are diffrences between Mysql and MariaDB

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Pinkeltje
  • Pinkeltje's Avatar Topic Author
  • Offline
  • Premium Member
  • Trying to find an answer before asking
More
2 weeks 4 days ago - 2 weeks 4 days ago #5 by Pinkeltje
I have MariaDB. Query didn't work either, so added the field manually. This was on my testsite. Then I ran the recorded query in phpmyadmin on my live site.
And yes, i used my own table prefix when running the query.
Last edit: 2 weeks 4 days ago by Pinkeltje.

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago - 2 weeks 4 days ago #6 by xillibit
I have tested the query on Phpmyadmin on MariaDB 11.3.2 :
Code:
ALTER TABLE `nxah1_kunena_users` ADD `bsky_app` varchar(75) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NULL AFTER `reddit`;
, i haven't encountered issues

After the updrade to Kunena 6.3.0, did-you have opened the Kunena dashboard ?

I don't provide support by PM, because this can be useful for someone else.
Last edit: 2 weeks 4 days ago by xillibit.

Please Log in or Create an account to join the conversation.

  • Pinkeltje
  • Pinkeltje's Avatar Topic Author
  • Offline
  • Premium Member
  • Trying to find an answer before asking
More
2 weeks 4 days ago #7 by Pinkeltje
I didn't open the dashboard,  allways forget as it doesn't make sense to me. But if I'm the only one consider it solved.

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #8 by Gindi
It makes sense to open the kunena dashboard after an update, because this will update the manifest version of the Kunena Forum in the database.

gindi
 

Please Log in or Create an account to join the conversation.

More
4 days 19 hours ago #9 by cybersalt
Thanks for posting this - it worked for me. I made this video to help others finding this deploy the fix.



Tim Davis
Basic Joomla Tutorials YouTube Channel:
Cybersalt Consulting:

Please Log in or Create an account to join the conversation.

Time to create page: 0.624 seconds