Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Question Error Messages after J3 to J4 upgrade

More
1 month 2 weeks ago - 1 month 2 weeks ago #11 by Leen
mm it might have something to do with (SQL version is 5.744).
If I test the one used here locally in wampserver, I also get a message specified was to long at certain sites.
But after switching to the standard template, have you assigned it to all pages?
And I understand that you can access the backend?
If you go to the System Dashboard > Extensions: Discover
and when you press the 'Search' button, more updates will come up?
and also try this at Extensions: Update

L.v.d.A
Attachments:
Last edit: 1 month 2 weeks ago by Leen.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #12 by AlexRag
I've taken the steps as you suggested but I still, see messages like these on the front end:  "Rendering Error in layout Widget/Announcement: Cannot use object of type stdClass as an array."    No topics appear at all.   

It seems to have something to do with the database upgrade and perhaps not all the Kunena tables were converted properly.   The first error I saw (shown ealier in this thread) was that the "specified key was too long" so not sure if it that related to utf8mb4 or something else.

Is it possible the tables did not convert properly causing them to be corrupted?  I fear I may have to completely wipe Kunena and start with a fresh install. 
 
Last edit: 1 month 2 weeks ago by AlexRag.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #13 by TonyChiao
Tried but did not work.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #14 by TonyChiao
Found a link explains why,  hatchjs.com/cannot-use-object-of-type-stdclass-as-array/ but nothing related to Kunena.
Last edit: 1 month 2 weeks ago by TonyChiao.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #15 by TonyChiao
Did you find this line ? "../public_html/libraries/kunena/src/Config/KunenaConfig.php (1803)"

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #16 by AlexRag
So the huge lingering issues that I cannot get to the bottom off are:

Front End: "Cannot use object of type stdClass as an array'

Backend: "Specified key is too long; Max key length is 1000 bytes".   (Occurs when tables updated during install of Kunena 6.25.   J3 version was uninstalled prior to J4 upgrade)

I've dome some tests on a cleaner instal (removing J3 tables) and i STILL get errors so seems like no confidence this will work either.

But yes, a better understanding about what these errors means and if they are related is vital to figure this out.  

 
Last edit: 1 month 2 weeks ago by AlexRag.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #17 by AlexRag
[SOLVED] Error Message:  Cannot use object of type stdClass as an array'     See solution here: 
www.kunena.org/forum/k-6-2-0-support/168...lass-as-array#231095

I installed Kunena 6.24 and the front end error message has gone away and the forum loads fine now.  

That said, I a still seeing "Specified key is too long; Max key length is 1000 bytes" upon installation of 6.24

Please Log in or Create an account to join the conversation.

Time to create page: 0.503 seconds