×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

Question Problems after updating to 5.2

More
3 months 2 weeks ago #11 by SBott
Hi,
I disabled the JCH Optimize plugin, then deleted the cache. The problems are still there, though, with the same behavior.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #12 by rich
Replied by rich on topic Problems after updating to 5.2
Please, would you create an account for me? An account for the frontend (Registered user) would be enough. You can use the confidential tags for the access data (padlock symbol in the editor), then are this info visible only for you and moderators here.
[confidential][/confidential]

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #13 by SBott
Ok,
I created a "registered user" for you:
This message contains confidential information

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago - 3 months 2 weeks ago #14 by rich
Replied by rich on topic Problems after updating to 5.2
Maybe I found the problem. The login works only via the main page login module, because the captcha isn't displayed in the forum, so you can't to enter the invoice result.
Test it, f it works if you disable your captcha plugin(s).
In your configuration report I see, you've chosen CAPTCHA Challenge for Users = 3 So I think, maybe my 3 test topics are pending messages and must be approved by a moderator (if yes please delete these).
Last edit: 3 months 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #15 by SBott
I disabled the "Captcha - ReCAPTCHA" plugin. That didn't change anything though.
I also checked the setting "moderate new users", but it is set to 0, so that should work.
I changed the setting "captcha challenge for users" to 0, too. This shouldn't have been a problem as "display captcha" was already set to "for noone" (if I understand this correctly). Anyway, that also didn't help unfortunately.
Hmm - just to check - if topics would have to be moderated before they appear - where would I have to go to do this?

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #16 by rich
Replied by rich on topic Problems after updating to 5.2
If topics should be moderated, you can set this also for single categories (see image). And pending messages will be displayed on the index page.

That seemed to have worked, and the posts in the forum are displayed again. However, it is not possible to post answers (redirects to 404 error message) or to create new topics (redirects to "current threads", but new thread does not exist).

That's not an error, because guests have no access for some things. But all your menus are available for guests and that's a misconfiguration, because the users think, they are logged in. But in fact, they are guests and therefore the 404 error because the guests have no rights for some actions.
Menu items like Unread, New Topic, No Replies, My Topics and Profile are default only for registered users available.

 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #17 by SBott
There are no pending message on the index page.
I did not try any of these actions (reply, new topic) as a guest, but with my admin account. I does not work for the admin, and it does not work for registered users.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #18 by rich
Replied by rich on topic Problems after updating to 5.2

I did not try any of these actions (reply, new topic) as a guest, but with my admin account. I does not work for the admin, and it does not work for registered users.

After login, I got no 404 errors on your page.

I can't make sense of your homepage. My browser tool and also the source code of your page shows all linked addresses with html at the end. But if you click on it, it will removed  this ending from the browser address.
Have you enabled this option in your Joomla SEO configuration? Or have you enabled the redirect plugin? If yes, disable this and test your page again.

It seems, your Joomla template shows no alert messages on top. Switch during the tests to the default template Protostar and read the message on top when you have tried to create a topic.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #19 by SBott
The 404 error only appears when trying to write a "quick reply".
When trying to post a new topic or a regular answer, you just end up in the list of topics and nothing happened - no answer or new topic was posted.
---
Disabling the "add file ending to URLs" option in the Joomla configuration didn't help.
The "URL rewriting" option is also used, but I cannot just turn this off - it is required for the website. The old version of the forum didn't have any problems with these settings, by the way.
Switching to the Protostar template and then trying to post a new topic did not display any message at the top.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #20 by rich
Replied by rich on topic Problems after updating to 5.2
In your configuration report I see, the captcha is enabled for guests and registered users. CAPTCHA Challenge for Users = 3. That's why I could not send a message, because it lacks the math field.
Maybe I had right, as I suspected after the first login in your page, that the captcha causes the problem. Random has a user reported today a similar problem (see here) .

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.957 seconds