Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved The editor text field isn't available after upgrade to 5.2.7

More
2 years 5 months ago - 2 years 5 months ago #11 by xillibit
Hello,

I don't find something related to your error :

TypeError: Cannot  read properties of undefined (reading 'replace')

In custom config of CKeditor that your are using, do-you have set an another language than en-GB ?

I don't provide support by PM, because this can be useful for someone else.
Last edit: 2 years 5 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #12 by guidocx84

Hello,

I don't find something related to your error :

TypeError: Cannot  read properties of undefined (reading 'replace')

In custom config of CKeditor that your are using, do-you have set an another language than en-GB ?
Hi! No, I didn't change anything inside the configuration file. I copied the ckeditor_config.js and I renamed the file as customckeditor_config.js, then I uploaded it.

The cloned custom file works only with Kunena 5.2.6 ckeditor.js but I noticed also that the settings that I defined in BBCode tab of Crypsis (e.g. I disabled "Align left", "Align right", "Center" and "Justify" buttons) were ignored, similar to other buttons that I disabled from backend.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #13 by rich
This error message is not the same as the one you first posted. This one it seems indicates a conflict with TapaTalk. 

I noticed also that the settings that I defined in BBCode tab of Crypsis (e.g. I disabled "Align left", "Align right", "Center" and "Justify" buttons) were ignored, similar to other buttons that I disabled from backend.

This setting is only for the BBCode editor. For the CKEditor you can create the custom configuration file.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #14 by guidocx84

This error message is not the same as the one you first posted. This one it seems indicates a conflict with TapaTalk. 

No Rich, sorry. The error message is exactly the same. The difference between the first screenshot and the second one is that in the second one there is also a Tapatalk Missing Image error (do not consider it).

I noticed also that the settings that I defined in BBCode tab of Crypsis (e.g. I disabled "Align left", "Align right", "Center" and "Justify" buttons) were ignored, similar to other buttons that I disabled from backend.

This setting is only for the BBCode editor. For the CKEditor you can create the custom configuration file.

In my Kunena 5.2.6 production environment I removed those buttons using the backoffice interface. I'm pretty sure about this.

This is my production CKEditor custom file (it doesn't work with Kunena 5.2.7):
Code:
/**  * @license Copyright (c) 2003-2021, CKSource - Frederico Knabben. All rights reserved.  * For licensing, see https://ckeditor.com/legal/ckeditor-oss-license  */ CKEDITOR.editorConfig = function( config ) {     // Define changes to default configuration here. For example:     // config.language = 'fr';     // config.uiColor = '#AADC6E';     // config.skin = 'moono-lisa';     config.scayt_autoStartup = true;     config.scayt_sLang = 'it_IT';          config.smiley_descriptions="";     config.toolbarGroups = [         { name: 'document', groups: [ 'mode', 'document', 'doctools' ] },         { name: 'clipboard', groups: [ 'clipboard', 'undo' ] },         { name: 'editing', groups: [ 'find', 'selection', 'spellchecker', 'editing' ] },         { name: 'forms', groups: [ 'forms' ] },         { name: 'basicstyles', groups: [ 'basicstyles', 'cleanup' ] },         { name: 'paragraph', groups: [ 'list', 'indent', 'blocks', 'align', 'bidi', 'paragraph' ] },         { name: 'links', groups: [ 'links' ] },         { name: 'insert', groups: [ 'insert' ] },         { name: 'social', groups: [ 'social' ] },         { name: 'styles', groups: [ 'styles' ] },         { name: 'colors', groups: [ 'colors' ] },         { name: 'tools', groups: [ 'tools' ] },         { name: 'others', groups: [ 'others' ] },         { name: 'about', groups: [ 'about' ] }     ];     var remove_buttons_url_image = Joomla.getOptions('com_kunena.ckeditor_remove_buttons_url_image');     if(Joomla.getOptions('com_kunena.ckeditor_buttons_configuration') !== undefined && remove_buttons_url_image===undefined)     {         config.removeButtons = 'Anchor,Paste,Styles,Format,Font,BGColor,Copy,Outdent,Indent,' + Joomla.getOptions('com_kunena.ckeditor_buttons_configuration');     }     else     {         if (remove_buttons_url_image)         {             config.removeButtons = 'Anchor,Paste,Styles,Format,Font,BGColor,Image,Link,Unlink,Copy,Outdent,Indent';         }         else         {             config.removeButtons = 'Anchor,Paste,Styles,Format,Font,BGColor,Copy,Outdent,Indent';         }     }     config.extraPlugins = 'ebay,twitter,instagram,map,soundcloud,video,confidential,hidetext,spoiler,code,polls';     var emoticons = Joomla.getOptions('com_kunena.ckeditor_emoticons');     var obj = jQuery.parseJSON( emoticons );     var list_emoticons = ;     jQuery.each(obj, function( index, value ) {         list_emoticons.push(value);     });     if (Joomla.getOptions('com_kunena.ckeditor_subfolder')!==undefined)     {         config.smiley_path = Joomla.getOptions('com_kunena.ckeditor_subfolder')+'/media/kunena/emoticons/';     }     else     {         config.smiley_path = '/media/kunena/emoticons/';     }     config.smiley_images = list_emoticons;     config.linkDefaultProtocol= 'https://'     // Define font sizes in percent values.     config.fontSize_sizes= "50/50%;85/85%;100/100%;150/150%;200/200%";     // Set the skin if it's defined in the params settings of the template     if (Joomla.getOptions('com_kunena.ckeditor_skiname') !== null)     {         config.skin = Joomla.getOptions('com_kunena.ckeditor_skiname');     }          // Disable SpellChecker from Ckeditor to let the brower handle it     config.disableNativeSpellChecker = false; }; CKEDITOR.lang.languages={"af":1,"sq":1,"ar":1,"az":1,"eu":1,"bn":1,"bs":1,"bg":1,"ca":1,"zh-cn":1,"zh":1,"hr":1,"cs":1,"da":1,"nl":1,"en":1,"en-au":1,"en-ca":1,"en-gb":1,"eo":1,"et":1,"fo":1,"fi":1,"fr":1,"fr-ca":1,"gl":1,"ka":1,"de":1,"de-ch":1,"el":1,"gu":1,"he":1,"hi":1,"hu":1,"is":1,"id":1,"it":1,"ja":1,"km":1,"ko":1,"ku":1,"lv":1,"lt":1,"mk":1,"ms":1,"mn":1,"no":1,"nb":1,"oc":1,"fa":1,"pl":1,"pt-br":1,"pt":1,"ro":1,"ru":1,"sr":1,"sr-latn":1,"si":1,"sk":1,"sl":1,"es":1,"es-mx":1,"sv":1,"tt":1,"th":1,"tr":1,"ug":1,"uk":1,"vi":1,"cy":1}

Thanks.
Last edit: 2 years 5 months ago by guidocx84.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #15 by xillibit
I have tested your custom ckeditor config :
  • You have an issue at this line
    Code:
    var list_emoticons = ;
    just look how it wrote in the original ckeditor configuration in Kunena
  • With this line
    Code:
    CKEDITOR.lang.languages={"af":1,"sq":1,"ar":1,"az":1,"eu":1,"bn":1,"bs":1,"bg":1,"ca":1,"zh-cn":1,"zh":1,"hr":1,"cs":1,"da":1,"nl":1,"en":1,"en-au":1,"en-ca":1,"en-gb":1,"eo":1,"et":1,"fo":1,"fi":1,"fr":1,"fr-ca":1,"gl":1,"ka":1,"de":1,"de-ch":1,"el":1,"gu":1,"he":1,"hi":1,"hu":1,"is":1,"id":1,"it":1,"ja":1,"km":1,"ko":1,"ku":1,"lv":1,"lt":1,"mk":1,"ms":1,"mn":1,"no":1,"nb":1,"oc":1,"fa":1,"pl":1,"pt-br":1,"pt":1,"ro":1,"ru":1,"sr":1,"sr-latn":1,"si":1,"sk":1,"sl":1,"es":1,"es-mx":1,"sv":1,"tt":1,"th":1,"tr":1,"ug":1,"uk":1,"vi":1,"cy":1}
    ckeditor try to load others languages, i have only en file available so i need to disable that line to make it work

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #16 by guidocx84
I don't know why, but when I copied and pasted here the code, it changed... This is my actual production configuration:
Code:
var list_emoticons = [];

But please, come back to post #12 of this topic. Restart from there. Did you try in a test environment if you have the same issue that I reported?

If I try to use a custom file copied exactly from the original ckeditor_config.js and simply renamed customckeditor_config.js, it doesn't work until I overwrite the ckeditor.js founded in 5.2.7 with the one copied from the previous version 5.2.6.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #17 by xillibit
Hello,

Can-you give please in attachments your custom ckeditor configuration like that i can test on my side ? I will restart from the post #12 of this topic

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #18 by guidocx84

Hello,

Can-you give please in attachments your custom ckeditor configuration like that i can test on my side ? I will restart from the post #12 of this topic
Find attached the files:

1. ckeditor.js (the standard file that I found in Kunena 5.2.7 package).
2. customckeditor_config.js (a renamed clone of ckeditor_config.js that I found in Kunena 5.2.7 package).

And this is my Crypsis 5.2.7 configuration:

Thank you very much ;)
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #19 by guidocx84
OK! I found the problem!

In my /media/kunena/core/js/lang I have an en.js file that is not the one contained in kunena 5.2.7 package (I noticed looking at the KB dimensions of that file comparing with the installation package).

During the update process from Kunena 5.2.6 to 5.2.7, the en.js file probably was not overwritten...

I overwrote the en.js file with the right one and now, with the files that I attached to you in the previous post, it works also for me!

Thanks 
Last edit: 2 years 5 months ago by guidocx84.
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

Time to create page: 0.564 seconds