×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

Solved Cannot attach jpg - mime type error

More
2 months 3 weeks ago #11 by jtcarlin
I continue to test. I am testing every jpg from August 2020, that I have imported into Windows 10 from my Iphone. These images have not been altered other than being transferred. 75% of the jpg's will not attach and get the error. 25% of jpg's will attach just fine. Pictures that were taken back to back, one works, and one does not.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #12 by jtcarlin
I can confirm that prior to upgrading to Kunena 5.2 images were successfully attached, that are not able to be attached now. I have proven this with testing multiple images.

Example: I updated to Kunena 5.2 on Jan 1, 2021. In actuality, I probably missed 5.2 and upgraded straight to 5.2.1 based on availability timeline. I was able to download a users attachment from their id directory in attachments from Dec 12, 2020 from the server. I then tried to attach that same picture, and received the error.

For the past few weeks, I can see that very few jpg's from phones have been attached. Many of my users are taking screenshots of their photos and then uploading those - which works in every case I have tried / seen so far.

Nothing else has changed on my vps except for Joomla and kunena updates.....and some other updates such as akeeba etc.

I will note again that I have no problems uploading any of these images in the joomla backend.  Also to clarify, this has nothing to do with image insertion, its upon selecting the image to attach.
Last edit: 2 months 3 weeks ago by jtcarlin.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #13 by rich
Please upload again here the zip file only as attachment, as you can see, your previous file is not displayed.
www.kunena.org/forum/k-5-2-support/16067...error?start=0#215554
I found it only, because I've edited your message and clicked on the attachment button. Maybe it was only random, but it could also be a hint to this bug if it happens again.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #14 by jtcarlin
ok I will try to insert it too - event though I know with a zip there is nothing to show. 

File Attachment:

File Name: IMG_1403_2...1-28.zip
File Size:779 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #15 by jtcarlin
And here I will attach without inserting - since I could actually see it in the previous msg.
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #16 by rich

I would be more than happy to setup an account for you on my site to see.

You can use the confidential tags (padlock symbol in the editor), then are this info visible only for you and moderators here.
[confidential][/confidential]
An account for the frontend (Registered user) would be enough.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #17 by jtcarlin
ok here you go.

This message contains confidential information

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #18 by rich
Addition:

Perhaps it is because the file info are deactivated on your server

This was my first answer in this topic. Has your server been upgraded? Kunena needs the Fileinfos.
As far as I remember, it's the first configuration report, where I see that these fileinfo isn't installed.
max_execution_time >= 30
memory_limit >= 32M (>= 64M recommended) - depends on other Joomla extensions used
allow_url_fopen = on
upload_max_filesize >= 4M
GD Library (>=2.0), fileinfo, DOM, Mbstring, JSON support installed and OpenSSL only to embedded tweets
github.com/Kunena/Kunena-Forum/blob/K5.2/README.md
Last edit: 2 months 3 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #19 by jtcarlin
The server was not upgraded.  I am sorry, I not not understand when you made that initial comment.  I understand now the the fileinfo extension was not installed.  I re-provisioned and everythign appears to be working now.  I am sorry for the trouble.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #20 by rich
No problem, the most important thing is that the cause has been found.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.079 seconds