×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged K3.0 installation fails with message "Warning: Invalid argument supplied for foreach() in ../administrator/components/com_kunena/install/schema.php on line 296"

More
7 years 1 month ago #11 by sozzled
*** Topics merged ***

G'day, topwebs, and welcome to the forum.

Similar cases to yours have been discussed in this topic. It would seem that most people resolve their problems by repeating the installation process again.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #12 by topwebs

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #13 by drocksvold
I received the following error messages while trying to install Kunena 3.0.2 on a Joomla 3 install:
Kunena Installation Failed!

Sorry, installation failed with following error:

Warning: DOMDocument::load() [domdocument.load]: I/O warning : failed to load external entity "/home/spence13/public_html/administrator/KPATH_ADMIN/install/install.xml" in /home/spence13/public_html/administrator/components/com_kunena/install/schema.php on line 206

Warning: Invalid argument supplied for foreach() in /home/spence13/public_html/administrator/components/com_kunena/install/schema.php on line 296

Fatal error: Class 'KunenaRoute' not found in /home/spence13/public_html/administrator/components/com_kunena/install/sql/install/php/sampledata.php on line 147

What I found was that when I disbaled the System-Cache and jch-optimize plugins it worked just fine.

I figured I would try to save the next person who ran into this issue...

Dustin
The following user(s) said Thank You: margsot

Please Log in or Create an account to join the conversation.

More
More
7 years 5 days ago #15 by Amema
I have tried to install K3 on a J2.5 site and had no illusions of it working on a new J3 site, but tried nevertheless.

I got (probably) the same error message as drocksvold: I didn't save the error message but recognize a few numbers etc. I decided to give up and go EasyDiscuss instead.

Just for the heck of it I read a few more messages about installation problems and with one finger raised I just tried installing K3 again, without any changes to my system. And it worked...

Will see if everything seems to be ok, but the install message was all green.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago - 6 years 11 months ago #16 by loppan
EDIT :

I had the same problem, but after several install attempts it just started working, magically. Cool, looking forward to check out Kunena!
Last edit: 6 years 11 months ago by loppan.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds