×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Question Kunena Installation und PHP Anforderungen

More
9 years 6 months ago - 9 years 6 months ago #1 by d3Xter
hallo!

ich hab ein dickes problem und weiß nicht mehr weiter...

ich möchte gern auf meinem joomla 1.5 ein kunena 1.6.3 forum installieren
aber leider bricht die installation ab weil meine php-version 5.2.0-8 etch8 ist, verlangt wird 5.2.3

hab daraufhin mein provider gefragt wegen einem php-update aber leider geht das nicht.
es geht nur mit einer server-neuinsatllation und das möchte ich nicht unbedingt weil,
ich auf dem server noch 2 andere webseiten und ein webinterface online habe :unsure:
das alles wieder neu hochzuladen und einzurichten (ordner-rechte und so) würde tage dauern,
und von der wartezeit der serverneueinrichtung und meinen ausfällen ganz abgesehen

zweites problem ist, das es (fast) keine alternativen zu kunena, bzw foren für joomla gibt
und es auch so gut wie keine forensoftware gibt die sich mit community builder "versteht"
das was es sonst noch an foren gibt ist "alt" und wird nicht mehr supportet

meine frage, gibt es nicht eine möglichkeit die php-versionsabfrage bei der kunena installion zu umgehen??
ich mein, meine php version ist ja fast identisch aber eben nur fast :blush:
würde das gerne mal ausprobieren und es einfach drauf ankommen lassen
aber ich weiß halt nicht wie :(


PS: meine bitte an das kunena-team, nimmt diesen "installations-stop" raus aus der komponente, sämtliche andere joomla komponenten haben sowas auch nicht, es genügt wenn es ein hinweis (mit empfehlung) bleibt! jeder user sollte selbst entscheiden können ob er es "versucht"
ich habe zb auch den CBE bei mir installiert und dieser verlangt sogar php 5.2.6 und läuft bei mir problemlos!

gruß
dexter
Last edit: 9 years 6 months ago by d3Xter.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #2 by rich
Erstmal herzlich willkommen d3Xter!

Ein bisschen verwundert bin ich schon, wenn ein Update nicht möglich sein sollte. Da wird dir auch Joomla 1.6 einen Strich durch die Rechnung machen, falls du mal aktualisieren willst.

Ob du Kunena fehlerfrei zum Laufen bringen wirst, bezweifle ich, aber es gibt schon einen Weg, es zu versuchen. Du kannst dir auf deinem PC Xampp installieren und eine geklonte Webseite darauf einrichten. Kunena installieren und wieder hochladen.
Wenn du die Möglichkeit hast, auf deinem Server eine weitere Datenbank einzurichten, würde ich dir empfehlen, dass du zum Testen eine eigene Seite anlegst, um den laufenden Betrieb deiner Liveseite nicht zu stören.

PS: meine bitte an das kunena-team, nimmt diesen "installations-stop" raus aus der komponente, sämtliche andere joomla komponenten haben sowas auch nicht, es genügt wenn es ein hinweis (mit empfehlung) bleibt! jeder user sollte selbst entscheiden können ob er es "versucht"

Das wäre wahrscheinlich keine so gute Idee, da viele diese Meldung einfach missachten - und dann hier im Forum um Hilfe "schreien" würden

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago - 9 years 6 months ago #3 by d3Xter
hallo rich
danke ertsmal für deine antwort :)

ja es ist leider so, ich habe debian auf meinem server und die höchste "authorisierte" php version ist (immer noch) 5.2.0 ! wenn ich ein neues php einrichte bedeutet das, dass ich ein anderes betriebssystem brauche!
und die arbeit möchte ich mir nun nicht wirklich machen :sick:

deswegen kann ich es nicht so ganz nachvollziehen das solche strammen php-versionsbedingungen an kunena geknüft sind
das php 5.2.0 läuft absolut perfekt und ich hatte bis jetzt noch nie ärger mit anderen neuen joomla-komponenten

ich habe jetzt, um überhaupt voranzukommen, das kunena 1.5.13 installiert
die seite die ich damit verwenden will ist noch nicht "regulär" online, sie ist momentan noch im aufbau und soll wenn sie fertig ist eine andere joomla-webpage erstezen

ich finde schon das man den "installations-stop" weglassen könnte oder wenigstes die debian-user noch mit einbezieht und das php-minimum der kunena-version auf 5.2.0 setzt solange es kein author. update für debian gibt ;)

gruß
dexter
Last edit: 9 years 6 months ago by d3Xter.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #4 by rich
Den Installationsstop könntest du ja mit einer lokalen Installation und hochladen umgehen, wenn es dann laufen sollte. Naja, beim nächsten Kunena Upgrade hättest du wohl wieder das selbe Problem. Laut "wiki" können mit veralteten Versionen fatale Fehler auftreten. Aber ich kann mich ja mal erkundigen.

ich habe jetzt, um überhaupt voranzukommen, das kunena 1.5.13 installiert

Du solltest auf jeden Fall Kunena 1.5.14 nehmen, bei dieser Version wurde eine kritische Sicherheitslücke geschlossen.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago - 9 years 6 months ago #5 by d3Xter
hi rich :)

sry das ich ein wenig dumm frage :whistle:

dann kann ich also mein kunena 1.5.12 (nicht 1.5.13 wie ich erst sagte) auf die aktuelle 1.6 updaten in dem ich die bestehenden kunena daten hochlade/überschreibe?

gibt es für das "updaten" wo eine anleitung?
alles was ich an anleitungen gefunden habe, ist eine sehr allgemein gehalten und knappe installations anleitung im wiki, die aber leider nicht speziell auf das "updaten" eingeht

ähmm, wenn das nicht klappt mit meinem update auf 1.6, wo bekomme ich die update-dateien für 1.5.12 auf .14 her? im download-bereich seh ich sowas nicht :dry:

oder muss jedensmal beim update das komplette kunena neu??? irgendwie steh ich ein wenig aufm schlauch :unsure:

gruß
Last edit: 9 years 6 months ago by d3Xter.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago - 9 years 6 months ago #6 by rich
Ja, du hast es richtig erkannt, 1.5.14 ist ein komplettes Paket. Es wird über 1.5.12 drüber installiert.
Bei einem Upgrade auf 1.6 wird dir bei der Installation auch die Option "Migrate von Kunena 1.5.x" angeboten. Diese wählst du aus. Der Installationsvorgang ist eigentlich selbsterklärend und du kannst nicht viel falsch machen. Kunena 1.6 einfach über den Joomla Installer installieren.
Aber auch da wird der Installations-stop dazwischen funken, wenn du es direkt am Server upgraden willst.
Last edit: 9 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.087 seconds