×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Solved [Gelöst] 1.6 RC Fehler

More
9 years 1 month ago - 9 years 1 month ago #1 by TTS
[Gelöst] 1.6 RC Fehler was created by TTS
Da mein Englisch nicht so perfekt ist, setze ich die von mir entdeckten Fehler mal hier rein:


- Wenn man das Forum als Unterkategorie einrichtet, springt Kunena beim Navigieren als Hauptkategorie rein.

Bsp.: Hauptkategorie ist Community, darunter das Forum

Klicke ich auf einen Link innerhalb des Forums, ist die Kategorie Community verschwunden und das Forum die Hauptkategorie.

Das ist insoweit problematisch, da die Moduleinstellungen somit nicht mehr greifen und es in den Breadcrumbs nicht schön aussieht.


- Ich hatte in einen geschützen Bereich einmal 13 Besucher, bin jedoch der einzige mit Zugangsberechtigung.


- Beim Installieren gab es insoweit Probleme, da ich parallel JomSocial laufen habe und nach der Installation eine weiße Seite angezeigt bekam. Erst als ich im Adminbereich in den Einstellungen Messages JomSocial zuwies, war alles in Ordnung.


Ansonsten sieht die 1.6er Version schon sehr vielversprechend aus!

Edit: Wenn man über das Joomla Menü auf die Kunena Startseite verlinkt (in dem Fall wie oben erwähnt als Submenu), dann sind die Reiter (Kunena Menu) nicht sichtbar und werden es erst, wenn ich innerhalb des Forums weiterklicke.
Last edit: 9 years 1 month ago by fxstein.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #2 by rich
Replied by rich on topic [Gelöst] 1.6 RC Fehler
Hallo TTS,
lösche mal im Menümanager sämtliche Einträge/Menüs, welche zum Forum führen und auch das komplette Kunena-menü. Wichtig, auch im Trash-menü musst du diese anschließend löschen. Danach lässt du in der Kunena Konsole ein neues Menü erstellen "Menü erstellen". Danach müsste es funktionieren.

Beim Installieren gab es insoweit Probleme, da ich parallel JomSocial laufen habe und nach der Installation eine weiße Seite angezeigt bekam. Erst als ich im Adminbereich in den Einstellungen Messages JomSocial zuwies, war alles in Ordnung.

Danke, das ist gut zu wissen.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #3 by TTS
Replied by TTS on topic [Gelöst] 1.6 RC Fehler
Zunächst mal Danke für deine Hilfe!

Es hat jetzt soweit geklappt, dass ich, nachdem ich ein Menü in der Kunena-Konsole erstellt habe, ein neues Kunena-Menu erhalten habe und einen Eintrag im Main-Menü, welches ich auch meiner Oberkategorie "Community" zuordnen konnte.

Zwar sind jetzt die Kunena-Menü-Reiter von Beginn an da, aber bei den Breadcrumbs und bei den Urls springt Kunena beim Herumklicken noch aus der Community heraus und verkauft sich wieder als Oberkategorie.
Last edit: 9 years 1 month ago by TTS.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #4 by rich
Replied by rich on topic [Gelöst] 1.6 RC Fehler

Wenn man das Forum als Unterkategorie einrichtet, springt Kunena beim Navigieren als Hauptkategorie rein.

Hier kann ich dir nicht ganz folgen. Du hast das Hauptforum als Unterkategorie eingerichtet? Oder wie ist das zu verstehen? Kann man eventuell einen Blick auf dein Forum werfen?

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #5 by TTS
Replied by TTS on topic [Gelöst] 1.6 RC Fehler

rich wrote: Hier kann ich dir nicht ganz folgen. Du hast das Hauptforum als Unterkategorie eingerichtet? Oder wie ist das zu verstehen? Kann man eventuell einen Blick auf dein Forum werfen?


Genau! Hauptkategorie ist Community und das Forum als Sub eingerichtet.

Ich habe mal Screenshots gemacht.

Attachments:
Last edit: 9 years 1 month ago by TTS.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #6 by rich
Replied by rich on topic [Gelöst] 1.6 RC Fehler
Ja, jetzt weiß ich, was du meinst. Wenn du den Pfad unbedingt so haben willst, dann musst du ein zweites Community-Menü in das Kunena-Menü kopieren.

Wenn das geschehen ist, gehst du ins Kunena Menü, klickst auf "Forum" und anschließend wählst du bei "Übergeordneter Eintrag:" Community aus. Dann sollte dein Pfad stimmen.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #7 by rich
Replied by rich on topic [Gelöst] 1.6 RC Fehler
Nachtrag:

Das dupliziere des Community-Menü kannst du dir ersparen, wenn du nur ein einziges benötigst. Da kannst du gleich das vorhandene Menü dorthin verschieben. Ich war von meiner Seite ausgegangen, wo die Voraussetzungen nicht die selben sind.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #8 by TTS
Replied by TTS on topic [Gelöst] 1.6 RC Fehler
Jetzt passt es! Danke!

Habe einfach im Kunena Menü "Community" angelegt und wie du gesagt hast, Kunena im Kunena-Menü der Community untergeordnet. Das Main-Menü habe ich so belassen. Jetzt wird alles richtig angezeigt.

Kleine Schritte, aber große für die Menschheit ;)

Jetzt steht das Forum bereit, um auch auf der Live-Site übertragen zu werden (hatte es bisher nur zu Testzwecken auf einer Demo-Plattform). Lediglich das Latest-Modul fehlt nur noch.

Edit: Ich bin schon richtig in die 1.6er Version verliebt, da alles so drin ist, wie ich mir ein Forum vorstelle.

Edit 2: Es werden im Forum 13 Besucher (stetig steigend) angezeigt, was aber nicht sein kann, da die Seite im geschützten Bereich liegt und ich der einzige mit Zugang bin.
Last edit: 9 years 1 month ago by TTS.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #9 by rich
Replied by rich on topic [Gelöst] 1.6 RC Fehler
Ja, das meinte ich auch so, nur anstatt neu anlegen, einfach kopieren. :)
Vielleicht hatte ich es auch etwas schlecht erklärt.
Das mit den Besucherzahlen ist bekannt (vielleicht werden die Aufrufe mitgezählt), ich weiß aber nicht, ob es bei der kommenden RC2 schon beseitigt ist.
Last edit: 9 years 1 month ago by rich. Reason: Ergänzung geschrieben

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #10 by TTS
Replied by TTS on topic [Gelöst] 1.6 RC Fehler
Danke für die Info! Und auch für deine Hilfe!

Wobei, es sieht immer toll aus, wenn viele Besucher drauf sind ;)

Weißt du über das Latest Modul bescheid? Ich habe irgendwo hier im Forum gelesen, dass sich wohl die Tage diesbezüglich was tun wird.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.103 seconds