Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved Adding Kunena topics via SQL injection

More
2 years 10 months ago #11 by antifm
DAM!!!

Under Kunena Diagnostics tools, it found TWO broken links. I decided to have Kunena remove them and of course, it REMOVED the two topics i am trying to create lol

Ok so the links are broken, But why?

Please Log in or Create an account to join the conversation.

More
2 years 10 months ago #12 by rich

Under Kunena Diagnostics tools, it found TWO broken links.

In your case, this tool may not be able to fix it.
If an assignment is missing, it is recognized all affected entries as orphaned and orphaned entries are removed.
Example, the table #__com_kunena_topics contains a wrong category IP, it has effect to the tables #__com_kunena_user_topics, #__com_kunena_messages, #__com_kunena_message_txt
They are all now orphaned and listed in this tool.
It's better, you use it as a guide and check the listed errors in the database.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #13 by antifm
So those two topics i created. I created them again, adjusting the TIMESTAMP by several numbers.
Again when i went to the front of kunena, i clicked the SUBJECT and it brought me to that same error as before. However this time, i did not delete them.

I left them there, got busy with  many other things (obviously its been 3 weeks) and i just checked on them yesterday and wa-da-ya-know?
the subjects were still there as i left them but i tried to enter,,,.....and IT WORKED!!!

Soooooo apparently the TIMESTAMP I am using is too close in the NOW time i guess by several hours, for the links to actually work correctly.

My server time i set for New York Time (+5GMT)
my location right now is TEXAS (Central US Time) and there must be some conflict somewhere.

Bottom line is, if i want them to appear and work instantly, ill need to really drill down on the timestamp.
But these particular subjects i want to inject, well they can sit in a "hidden" forum area for 30 days until they actually work, and i just make them public.

I guess my SQL command is working, mostly.

Please Log in or Create an account to join the conversation.

Time to create page: 2.147 seconds