×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question 0 users 0 guests

More
2 months 5 days ago #11 by rich
Replied by rich on topic 0 users 0 guests

romagromov wrote: I already posted screenshot above.
One more time:



So, Joomla module works fine.

Sorry, I had overlooked this. Can you put a link to your forum please?

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago #12 by Slacker
Replied by Slacker on topic 0 users 0 guests
Have you controlled the Kunena tables in the database and especially kunena_sessions table? You can do this with phpmyadmin. If kunena-session table is corrupt omline will not work.

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago #13 by romagromov
Replied by romagromov on topic 0 users 0 guests

Slacker wrote: Have you controlled the Kunena tables in the database and especially kunena_sessions table? You can do this with phpmyadmin. If kunena-session table is corrupt omline will not work.


Yes. I checked kunena_sessions table. Everything fine.

Download Free Software for Windows absolutly free.

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago - 2 months 7 hours ago #14 by romagromov
Replied by romagromov on topic 0 users 0 guests
This is some kind of mysticism...
I created clean Joomla Site and installed Kunena.
Then I copied DB from problem site to clean site - everything fine, block correct displays online users.
So, issue is not related to Mysql.
Ok, then I copied com_kunena from problem site to clean site - All OK.
So, issue is not related to template or any other files.
Next, I disabled all modules on problem site - still have issue.
Then I disabled all plugins on problem site - still have issue.
So, I'm confused. I don't know how to find reason of problem.
I also found, that besides Online users Kunena does not displays Legend (Site Administrator Global Moderator Moderator Banned User Guest)...

Download Free Software for Windows absolutly free.
Last edit: 2 months 7 hours ago by romagromov.

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #15 by rich
Replied by rich on topic 0 users 0 guests

Slacker wrote: Have you checked session life time in Kunena Configuration? I have 1800 seconds. Joomla online shows those who visits Joomla, whereas Kunena online shows those in forum. Checked my site just and half was in the forum.

romagromov wrote: Sometime everything was fine.
I never changed Kunena settings.
After the next update (I don't know which exact), this data was broken.

Have you changed the session live time in Joomla? It must be the same live time. If you change the live time in Joomla, you must adjust the time also in Kunena.

This is some kind of mysticism...
I createв clean Joomla Site and installed Kunena.
Then I copied DB from problem site to clean site - everything fine, block correct displays online users.
So, issue is not related to Mysql.
Ok, then I copied com_kunena from problem site to clean site - All OK.
So, issue is not related to template or any other files.
Next, I disabled all modules on problem site - still have issue.
Then I disabled all plugins on problem site - still have issue.
So, I'm confused. I don't know how to find reason of problem.
I also found, that besides Online users Kunena does not displays Legend (Site Administrator Global Moderator Moderator Banned User Guest)...

hmm.. It seems, you have almost everything tested what is possible. Have you also tried to reinstall Kunena on your live site? Maybe the current installation contain a corrupt file.

Please Log in or Create an account to join the conversation.

More
2 months 7 hours ago #16 by romagromov
Replied by romagromov on topic 0 users 0 guests

Have you changed the session live time in Joomla? It must be the same live time. If you change the live time in Joomla, you must adjust the time also in Kunena.

It seems yes. I had different Session Lifetime.

But now I fixed this - but issue is not gone.






hmm.. It seems, you have almost everything tested what is possible. Have you also tried to reinstall Kunena on your live site? Maybe the current installation contain a corrupt file.


Yes. And I already updated and reinstalled Kunena on my site - no results.

Download Free Software for Windows absolutly free.

Please Log in or Create an account to join the conversation.

More
1 month 4 weeks ago #17 by romagromov
Replied by romagromov on topic 0 users 0 guests
Ok, I found reason of problem.
When Shared Sessions option enabled - Kunena does not displays online users and legend.

Hope you'll fix it.

Download Free Software for Windows absolutly free.

Please Log in or Create an account to join the conversation.

More
1 month 4 weeks ago #18 by rich
Replied by rich on topic 0 users 0 guests
Thanks for the information. If you read the tooltip on this option you see this:

When enabled, a user's session is shared between the frontend and administrator sections of the site. Note that changing this value will invalidate all existing sessions on the site.

Probably is this the cause.

Please Log in or Create an account to join the conversation.

More
1 month 4 weeks ago #19 by Slacker
Replied by Slacker on topic 0 users 0 guests
Shared sessions means that admin is logged in also in frontend. Right?

Please Log in or Create an account to join the conversation.

More
1 month 4 weeks ago #20 by rich
Replied by rich on topic 0 users 0 guests

Slacker wrote: Shared sessions means that admin is logged in also in frontend. Right?

Yes, that's correct, it's no matter if the admin login/logout in the front- or backend. It always applies to both accesses at the same time.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.103 seconds