Kunena 6.3.0 released

The Kunena team has announce the arrival of Kunena 6.3.0 [K 6.3.0] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 and issues discovered during the last development stages of K 6.3

Please Read This First:


Please read the guides posted as sticky topics in this category. For a quicker response, please give as much information to help us understand the problem (see How To Ask Questions The Smart Way and What information should I include when I ask for help (including how to post my configuration report)? ).

This category is only for reporting defects with K 2.0 Please read, before you post, Before you post your question, read this first .

Do not use this category:
  • if this website ( www.kunena.org ) works but works differently to how you expected
  • for requests to add or remove the standard features of Kunena;
  • for questions commonly asked or "how to" in nature (see the FAQs menu tab above);
  • for help with Kunena versions that are not the latest stable release; or
  • for general Joomla or website administration matters

You must include your K 2.0 configuration report; if you do not include your configuration report, your topic may be closed (locked) or deleted without any further warnings from the moderators.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

Merged Typo in helper.php causes problem with reverse ordering (last post first)

More
11 years 2 months ago #11 by sozzled
dz15fr: si tu as l'intention d'écrire en français "J'ai le même problème", alors je vais te dire, en anglais, à lire "I have the same problem ..." . English only in this category, please.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #12 by dz15fr
Désolé, j'ai bien lu et compris la leçon. Je vais poster dans la partie francophone et bien comme il faut cette fois-ci.

Sorry, I have read and understood the lesson. I'll post in the French part and the proper way this time.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #13 by Shimei
I am having the same error: Warning: Invalid argument supplied for foreach() in /administrator/Components/com_kunena/libraries/forum/message/helper.php on line 212

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : yoo_catalyst | author: YOOtheme | version: 1.0.7 | creationdate: July 2012

Kunena default template details : Tigra | author: Tigra Team | version: 2.0.1 | creationdate: 2012-08-15

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.6.2

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4 | Content - Kunena Discuss 2.0.4 | JomSocial - My Kunena Forum Menu 2.0.4 | JomSocial - My Kunena Forum Posts 2.0.4 | JomSocial - Kunena Groups 2.0.4

Modules: Kunena Latest 2.0.4 | Kunena Login 2.0.4

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #14 by GJSchaller
I'm seeing the same issue on my own forums. It wasn't happening for a while, then it started this morning. I'm not 100% sure what changed - another admin made a number of changes to the menu system, but nothing overly drastic.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : khronos-2columnconditionaltables | author: Geoffrey Schaller | version: 1.0.0 | creationdate: 20th September 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.4 | creationdate: 2013-01-18

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4 | Content - Kunena Discuss 2.0.4

Modules: Kunena Login 2.0.4


Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #15 by GJSchaller
More information to recreate this:

We enabled the plugin for our documentation site, and set it to "Create Topic On: First Visit".

After a ton of topics with no discussion were generated, I got feedback that it looked odd to have so many empty topics, and was asked to change the setting, and clear out the old topics. I changed it to "First Reply," and deleted (perm.) all of the topics with no replies that had been created. At this point, that's when the error began.

When I switch the plugin back to "Create Topic On: First Visit", the error vanishes. If I change it back to First Reply, the error only appears on articles that have no post - as soon as the post is created, the error vanishes.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #16 by jpc0480
Any news on this? I have just installed the Discuss plugin and have mine set to create topic on first reply. Tried switching to first view and nothing changed still getting the same error:

Warning: Invalid argument supplied for foreach() in
administrator/components/com_kunena/libraries/forum/message/helper.php on line 212

I am using the latest of both Kunena and the Discuss plugin.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : gantry | author: RocketTheme, LLC | version: 4.1.5 | creationdate: January 18, 2013

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.4 | creationdate: 2013-01-18

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9 | UddeIM 2.8

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4 | Content - Kunena Discuss 2.0.4

Modules: Kunena Latest 2.0.4 | Kunena Stats 2.0.4 | Kunena Search 2.0.4


Kunena 3.0.4
CB 1.9.1
Joomla 2.5.18
Last edit: 11 years 2 months ago by jpc0480.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #17 by ratter
Oops, I have a same issue in case discuss plugin enabled, and appears only for logged super user.
Other users can't see that warning message.
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 180 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : yroad | author: Mike Kanunnikov | version: 1.0.0 | creationdate: 18-12-2013

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.4 | creationdate: 2013-01-18

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: AlphaUserPoints 1.6.4 | CommunityBuilder 1.9 | UddeIM 2.9

Third-party SEF components: None

Plugins: Content - Kunena Discuss 2.0.4

Modules: Kunena Latest 2.0.4 | Kunena Search 2.0.4

Last edit: 11 years 2 months ago by ratter.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #18 by xillibit
Last time, when i have tried i wans't able to reproduce the issue

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #19 by ratter
Last edit: 11 years 2 months ago by ratter.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #20 by GJSchaller

xillibit wrote: Last time, when i have tried i wans't able to reproduce the issue


Xillibit, check my post above (#15) - that may be the trigger you're missing.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

Time to create page: 0.627 seconds