Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K 2.0.2, K 2.0.3: problems with preview

More
10 years 3 months ago #41 by xillibit

810 wrote: Open k2.0.1 package and extract the blue_eagle template.

then check the preview.

Not sure if the things about preview are located in the template

I don't find which fix has been added in Kunena 2.0.2 and which affects preview :(

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #42 by TKtemp

xillibit wrote:

810 wrote: Open k2.0.1 package and extract the blue_eagle template.

then check the preview.

Not sure if the things about preview are located in the template

I don't find which fix has been added in Kunena 2.0.2 and which affects preview :(

Well, function for preview is in the file:
components -> com_kunena -> lib -> kunena.bbcode.js.php
Code:
function kPreviewHelper() { if (_previewActive == true){ previewRequest = new Request.JSON({url: "<?php echo KunenaRoute::_('index.php?option=com_kunena&view=topic&layout=edit&format=raw');?>", onSuccess: function(response){ var __message = document.id("kbbcode-preview"); if (__message) { __message.set("html", response.preview); __message.fireEvent('updated'); } }}).post({body: document.id("kbbcode-message").get("value") }); } }

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #43 by xillibit
Someone can try to install Kunena 2.0.1 and just apply this fix : github.com/Kunena/Kunena-2.0/commit/957b...a6f3e31a75473281f5a3

I want to be sur that this fix is causing the issue

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #44 by deltafidesign
I've found the plugin that generate the issue: Kunena plugin for Community Builder
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #45 by xillibit
Thanks for report, i will try to reproduce the issue on my local machine

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago - 10 years 3 months ago #46 by roland_d_alsace

deltafidesign wrote: I've found the plugin that generate the issue: Kunena plugin for Community Builder


Hi deltafidesign and "Bravo!"

...I confirm it's this plugin.
Last edit: 10 years 3 months ago by roland_d_alsace.
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #47 by xillibit
@deltafidesign and @roland_d_alsace : can-you post here your Kunena report configuration settings ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago - 10 years 3 months ago #48 by roland_d_alsace
Hi Xillibit.

You cannot reproduce the problem ?

If you want i make you a copy of my web site with an admin and ftp access, where you can make all the test you want ?

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 384M | Max file upload: 8M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : pneuboat_boating_2012_2 | author: Angie Radtke | version: 2.5.0 | creationdate: 25 November 2009

Kunena default template details : kunena pneuboat 2012 | author: Ordi Genie | version: 1.0 | creationdate: 2011-08-05

Kunena version detailed: Kunena 2.0.2 | 2012-09-02 [ Botschafter ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1

Third-party SEF components: None

Plugins: Content - Kunena Discuss 2.0.2

Modules: Kunena Latest 2.0.2 | Kunena Stats 2.0.2 | Kunena Search 2.0.2

Last edit: 10 years 3 months ago by roland_d_alsace.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago - 10 years 3 months ago #49 by sozzled
roland_d_alsace: These are the plugin settings in your case:

Kunena - AlphaUserPoints Disabled
Kunena - Community Builder Enabled: access=1 login=1 activity=1 avatar=1 profile=1 private=1
Kunena - Gravatar Disabled
Kunena - JomSocial Disabled
Kunena - Joomla Enabled: access=1 login=1
Kunena - Kunena Enabled: avatar=1 profile=1
Kunena - UddeIM Disabled

As you can see from the way that I've colour-coded the information, there are some "conflicting" settings. Perhaps it would help if you changed the settings so that you only used CB for the the login, avatar and profile and use Joomla for access.

The setting for CB's private message requires additional software to make this work. I do not know whether CB still has a private message feature. That's something you might like to ask the folks at Joomlapolis about. If you do not have the CB "private messaging system" software add-on installed on your site, you should disable this option.

This may or may not solve the problem but I would like you to try these settings to see if it works in your case.
Last edit: 10 years 3 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 3 months ago #50 by roland_d_alsace
Hi sozzled and thanks for your work.

I have made the change that you suggest, but the problem is the same.

What do you think about my suggest in my post above ?

Here my new K config...

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 384M | Max file upload: 8M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : pneuboat_boating_2012_2 | author: Angie Radtke | version: 2.5.0 | creationdate: 25 November 2009

Kunena default template details : kunena pneuboat 2012 | author: Ordi Genie | version: 1.0 | creationdate: 2011-08-05

Kunena version detailed: Kunena 2.0.2 | 2012-09-02 [ Botschafter ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1

Third-party SEF components: None

Plugins: Content - Kunena Discuss 2.0.2

Modules: Kunena Latest 2.0.2 | Kunena Stats 2.0.2 | Kunena Search 2.0.2

Please Log in or Create an account to join the conversation.

Time to create page: 0.435 seconds