×
Kunena 5.2.8 released and Blue eagle 1.6.7 released (02 Jan 2022)

The Kunena team has announce the arrival of Kunena 5.2.8 [K 5.2.8] which is now available for download as a native Joomla extension for J! 3.10/3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

If you are using blue template you need to update to 1.6.7 version to ensure to have a compatible version with K5.2.8.

Important note: (07 Jan 2022) If you have created a Kunena custom.css, create a backup of it. Due to an error, this file will be deleted during an upgrade.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Kunena Login module: redirection problem

More
9 years 8 months ago #11 by camel007
Yes i am, and was working ok before the upgrade?

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #12 by sozzled
Can you provide other members of the community with any information about how you have configured your website? What versions of software are you using, the Kunena Login module, etc. ... anything that might assist others to help you? Perhaps there is a defect in the design of Kunena Login 2.0.1 but I am not familiar with the configuration issues that you're asking about.

Perhaps, as xillibit wrote earlier in this topic, the issue has been identified and resolved for K 2.0.2? :unsure:
Last edit: 9 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #13 by webiedesign
Here are mine:


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_terrantribune_j25 | author: | version: 1 | creationdate:

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1

Third-party SEF components: None

Plugins: None

Modules: Kunena Login 2.0.1

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #14 by sozzled
So where do you have this page redirection issue? When users login on your homepage (where you have published the Kunena Login module) or when they login on the forum page (where you are not using the Kunena Login module). I am trying to understand how the Kunena Login module is failing to redirect.

On your forum page, the redirection is managed (according to your configuration report) by the Joomla login module.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #15 by webiedesign
All the categories of the Forum are limited to a custom Joomla group, so users must login (from the home page) to even see any content in the forum. Public visitors just see the Forum header basically.

When they login from the Kunena module on the home page, I have the module set to redirect them to a public article that has an overview of features of the site, but when people login from the module it does not redirect there, it just stays on the home page.

I also have a logout redirection in the module configuration to take them to a public page that basically thanks them for visiting, and that doesn't redirect them there either.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #16 by sozzled
Thank you for helping me to understand better about the issues you are having with your site login. Can you please show us exactly what module settings you are using for the Kunena Login module.

Perhaps, if you do not want your users to login from the forum page, you should disable the login form on the forum page? But the issue here is, I think, that redirection on login and logout is being overridden via the settings you're using on the Joomla login module. Can we compare those settings, please?

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #17 by webiedesign
I am uncertain on how/where to disable the login on the forum page. People never land there without logging in from the home page, since the link on the menu only displays when somebody has logged in. I looked through the configuration settings but nothing seemed to stand out that controlled this.

I have attached an image of the Kunena login module settings.


Attachments:
Last edit: 9 years 8 months ago by sozzled. Reason: Display attached image

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #18 by sozzled

webiedesign wrote: I am uncertain on how/where to disable the login on the forum page. People never land there without logging in from the home page, since the link on the menu only displays when somebody has logged in.

Perhaps, but, if you go to your forum page you will clearly see the login form if you are not logged in: (go to http://<your site>/index.php?option=com_kunena>. To hide this login form see Hide / Disable login .

But, as I mentioned a few posts ago, there may be an issue here that xillibit has identified but I cannot see on GitHub where the matter has been reported.
Last edit: 9 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #19 by webiedesign
I tried this (thank you for your help), but unfortunately it prevent me from logging in at all through the Kunena login module.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #20 by ppsberlin
Just upgraded to kunena 2.02 and sad enough - it´s still the same :S

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.182 seconds