×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

Merged K 2.0 general menu issues

More
8 years 9 months ago #51 by jenfar
no I'm using a template from www.joomladesigns.co.uk/. With the default menu created by Kunena I have no problems with the Kunena tabs appearing. But when I create a custom menu and select Kunena the tabs are missing once the user ends up on the Kunena page.

I should also add signing in or out of the forum has no effect on the above equation.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #52 by keithyoung89
jenfar: your issue seems similar but not quite the same. I am using the default Kunena menu and the issue happens.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #53 by arosscpa
Replied by arosscpa on topic The Kunena 2.0 Menu
It's been over a week since one of the volunteers indicated that they were writing a new edition of the Kunena Menu article for the Kunena Wiki, and they would need 16 hours to complete it. (For those having trouble locating the article entitled "The Kunena Menu," it may be that you are looking under "M" for "menu," rather than "T" for "the" in the Wiki article index. While a new page has been started, I could identify no new information as of one-half hour ago.

What I do note is that we were told a new revision of the software needed to be installed. Whatever problems Kunena 2.01 might have addressed, the menu issue with the missing tabs is not one of them.

This clearly is not an isolated issue, nor is it a 3rd party template issue. I am using the Blue Eagle template that accompanies the extension download, and I cannot get the tabs to appear using that basic install with no 3rd party templates or 3rd party Kunena extensions.

Could some one please just explain how to get the missing tabs to appear as they ought after one has installed Kunena 2.01 without error or incident. My configuration settings report follows.

One other issue: Can we please NOT refer to Kunena 2.x as K2.x? It may seem a minor point, but for those of us using the CCK called K2 it adds a totally unnecessary level of confusion. And, yes, I will make that issue its own topic.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 660 seconds | Max execution memory: 512M | Max file upload: 360M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ca_faith_j25 | author: CloudAccess.net | version: 1.0.3 | creationdate: may 09, 2011

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.8.1

Third-party SEF components: AceSEF 2.5.2

Plugins: Content - Kunena Discuss 2.0.1 | JomSocial - My Kunena Forum Menu 2.0.1 | JomSocial - My Kunena Forum Posts 2.0.1 | JomSocial - Kunena Groups 2.0.1

Modules: Kunena Latest 2.0.1 | Kunena Stats 2.0.1 | Kunena Login 2.0.1 | Kunena Search 2.0.1

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago - 8 years 9 months ago #54 by sozzled
Replied by sozzled on topic The Kunena 2.0 Menu
I have been very busy for the past three months (and I have enough work to keep me busy for the next 6 months). When I find a spare two days I will continue to work, as my time and energy permits, to update the documentation Wiki.

If someone wants me to drop everything else and finish the job that's OK with me but something has to "give". You should understand something very important:

There is no company behind Kunena; everyone who contributes to Kunena is a hobbyist, enthusiast or professional web developer who gives their time freely to this project - volunteers every one of us. Our hope is to make Kunena the most reliable, scalable, durable and robust forum component for Joomla that we can make it and to give people the best solution to meeting their forum needs. The forum is a self-help community-driven resource for users to help one another. Our job, in moderating the forum, is not necessarily to answer every question but, rather, to point people in the right direction where they can find the answers.

We are doing our best. I cannot give you an absolute definite timeframe when I will finish the job I started. On the other hand, if people would like to write to me with information that they think would help the documentation, they can write to us (our e-mail addresses are on the team page). Please be patient. Thank you. B)

I agree with you about using the abbreviation K 2.x instead of "Kunena version 2.x" but, just like everyone else, I think we should be allowed a little latitude instead of being pedantic about the unfortunate abbreviation. When I want to refer to "Kunena version 2.x" I write K 2.x. When I want to refer to the Joomla extension with a similar name, I write K2. The difference is in the italics. ;)

To restore your standard Kunena menu, use the Forum Tools » Menu Trash facility. Simple and it takes one mouse-click. After that, publish the menu item created for you in your top-level/main menu and you're all done. There is a topic in the K 2.0 General Questions category that discusses it. Search the forum and you will usually find the answers you are looking for. I hope that helps.
Last edit: 8 years 9 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago - 8 years 9 months ago #55 by arosscpa
Replied by arosscpa on topic The Kunena 2.0 Menu
First, I owe Sozzled an apology: MEA CULPA! MEA CULPA! MEA MAXIMA CULPA! I am sorry; in my frustration and ignorance I took a lot of my frustration out on you, and I apologize.

Second, for those having similar issues after upgrading to Kunena 2.0 or 2.0.1, you must 1) go into the plugins submenu under extensions. 2) Type "FORUM" into the Filter box and then hit "SEARCH." 3) For any plugins that are disabled/unpublished (showing a red button with a white dot) you must select them by checking the box on the far left. Once they are all selected, hit the enable button (green button with white check mark.) Do not leave any plugin with the word "forum" in it disabled when you leave the plugins page. I also recommend going into Kunena/Template Manager, going to the bottom right of the page, and selecting "NO" to the question about integrating the Blue Eagle Template with your site template.

There is still one issue left after doing all this. The tabs show as white on white in the template I am using, which is a CloudAccess/Rocket Theme template and may be specific to certain template designs. I will try and change the forum template to a basic Joomla template. If this works I will post that information in case it helps any one else.

Again, my sincerest apologies to Sozzled, and I hope this information is helpful to others.
Last edit: 8 years 9 months ago by arosscpa.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #56 by arosscpa
Replied by arosscpa on topic The Kunena 2.0 Menu
Yes, the white on white tabs are a function of the template, not anything to do with Kunena itself. The easiest fix is to use the Atomic template that accompanies each Joomla installation. In the alternative, and if you have sufficient skill, or know someone that does, you can change the CSS for your menu template.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago - 8 years 9 months ago #57 by betteryouthanme
same problem here. i'm using JSN Dome template. The menu vanishs after updating Kunena. Trash menu dosn't help.
And if you go to a board category manually the menu appears again. But when i'm using the main link to my forum (in my main menu) the Kunena menu is not displayed, exactly like in the posts above.

Two things fill the mind with ever new and increasing wonder and awe - the starry heavens above me and the moral law within me. Immanuel Kant
Last edit: 8 years 9 months ago by betteryouthanme.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago - 8 years 9 months ago #58 by sozzled
Replied by sozzled on topic The Kunena 2.0 Menu
aarosscpa: Apology accepted humbly. I have actually been trying to get help (myself) from my colleagues that would answer your main question; viz. your missing menu.

In your case this is your Kunena menu structure (below):

Kunena menu details:
Warning: Spoiler!
You had two menu items in your (top-level) mainmenu module.

The first item (636) points to a non-existent target. You need to unpublish and remove this item.

The second item (764) points to (765) - it is an alias menu - and it needs to be published. You may want to rename this to "Let's Talk - FIFH Discussion Boards"

I did say that the Joomla menu system is a real pain in the neck.
Last edit: 8 years 9 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #59 by alsthom
Replied by alsthom on topic After upgrade - no Menu
Have you create a menu alias pointing to kunena?

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #60 by Matias
@keithyoung89: kunena_menu position doesn't exist in Kunena anymore, we are now rendering the menu for ourselves inside Kunena.

For everyone: configuration report of Kunena 2.0.1 contains all Kunena related menu items, so seeing it will help to solve your issues.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.260 seconds