×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× This category is for discussing issues with the K 2.0 Blue Eagle template.

As general background, My Joomla site template makes a mess of Kunena .

We do not answer questions about other templates for Kunena here.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Merged Change legend colours: Site Administrator, Global Moderator, etc.

More
6 years 5 months ago #11 by QuakeLive
Hi,

First of all, my english is bad and I apologize for that.

On this forum ( www.kunena.org/forum/ ) moderators, users, banned users, admins... have different colors of usernames.

On my forum (Kunena 2.0.4 | Blue Eagle 2.0), colors of usernames are the same, there is no difference between moderators, users, banned users, admins... Actually, the only difference is in ranking, but the colors of usernames are the same.

Can you help me to solve this little esthetic problem :)

Thanks in advance!

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #12 by Shimei
A browser like firefox has developer tools. It is pretty easy to find the template files using it to alter the colors. For example the following Screen Shot shows the template.css file and the lines where you can alter them.


Attachments:

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #13 by sozzled
The following user(s) said Thank You: QuakeLive

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #14 by QuakeLive

sozzled wrote: G'day, Woeler1, and welcome to Kunena.

To change the legend colours, add the following lines at the end of your Joomla site template CSS file:

/* COLOR ADMINISTRATOR AND MODERATOR
----------------------------------------------------------------------------------------------- */
 
#Kunena .kwho-admin {
	color: #FF0000 !important;
}
 
#Kunena .kwho-globalmoderator {
	color: #800000 !important;
}
 
#Kunena .kwho-moderator {
	color: #0000FF !important;
}
 
#Kunena .kwho-user {
	color: #5388B4 !important;
}
 
#Kunena .kwho-guest {
	color: #666666 !important;
}
 
#Kunena .kwho-banned {
	color: #A39D49 !important;
}
 
#Kunena .kwho-blocked {
	color: #ff0000 !important;
}
Change the values of "color" as you need them. :)

Ok, I tried this, and it didn't work. The colors are still the same for all users (Administrators, moderators, users, banned... ). For example, Administrator and Moderators have the same color as users. The only difference is in ranking, but the colors of usernames are the same.

Also, I cleared cache.

:(

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #15 by sozzled
QuakeLive: This issue should be able to be resolved by making changes to your Joomla site template CSS file - and you should read My Joomla site template makes a mess of Kunena .

I do not know how to fix this problem that you are having until I know two things:

1) the information from your Kunena configuration report; and
2) have you changed any of the originally-installed Kunena PHP or CSS files in any way at all?

Thank you.
The following user(s) said Thank You: QuakeLive

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago - 6 years 5 months ago #16 by QuakeLive

sozzled wrote: 1) the information from your Kunena configuration report;

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 24M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : mysite | author: JoomlaShine.com | version: 5.0.0 | creationdate: 03/15/2013

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.4 | creationdate: 2013-01-18

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None




sozzled wrote: 2) have you changed any of the originally-installed Kunena PHP or CSS files in any way at all?

I have changed kunena.default-min.css (components\com_kunena\template\blue_eagle\css)


#Kunena a:link, #Kunena a:visited, #Kunena a:active, #Kunena a:focus {
color: #5388b4!important;
background-color: transparent!important; << deleted this line (just this background-color: transparent!important;)


Second

#Kunena h2 span.kheadbtn a {
border-color: #FFF;
background-color: #5388B4; << here added what color;

Also, I have changed .ini language files located in en-GB (components\com_kunena\language\en-GB)
Last edit: 6 years 5 months ago by QuakeLive.

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #17 by sozzled
You are using a local site, like XAMPP or something, QuakeLive?
The following user(s) said Thank You: QuakeLive

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #18 by QuakeLive

sozzled wrote: You are using a local site, like XAMPP or something, QuakeLive?

I have created website on localhost using XAMPP, and now I am testing it before I upload it to a web-server (I want to make sure that everything is ok before it becomes publicly available, because I'm a perfectionist :pinch: ).

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #19 by sozzled
Please read this topic Support for PC-hosted websites (e.g. WAMP, XAMPP) which will help you understand why we cannot help you with your current problem.

Sorry about that.

Try to see if the problem continues to occur on a website that we can access.
The following user(s) said Thank You: QuakeLive

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #20 by QuakeLive

sozzled wrote: Please read this topic Support for PC-hosted websites (e.g. WAMP, XAMPP) which will help you understand why we cannot help you with your current problem.

Sorry about that.

Try to see if the problem continues to occur on a website that we can access.

OK, thank you very much sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds