×
Kunena 5.2.5 and Blue eagle 1.6.5 released (30 May 2021)

The Kunena team has announce the arrival of Kunena 5.2.5 [K 5.2.5] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.5

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

Solved [Resolved] Fatal error: Call to a member function authorisedLevels() on a non-object in /administrator/components/com_kunena/libraries/integration/joomla16/access.php on line 57

More
9 years 4 months ago #1 by mindriot
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 900 seconds | Max execution memory: 96M | Max file upload: 8M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : gk_gamebox | author: GavickPro | version: 2.1 | creationdate: 14 Sep 2011

Kunena default template details : nts_kcarbon | author: 9ThemeStore | version: 1.7.1 | creationdate: 2012-01-30

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: Jomsocial 2.4.2

Third-party SEF components: sh404sef: The file doesn't exist sh404sef.xml !

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Search 1.7.1 | My Kunena Forum Menu 1.7.1 | My Kunena Forum Posts 1.7.1 | Kunena Groups 1.7.1

Modules: Kunena Latest 1.6.4


Suddenly getting the following, not related to any changes, utterly confusing and enabling debug and error reporting doesnt produce any additional info.

500 Internal Server Error
Fatal Error was detected!

Fatal Error: Call to a member function authorisedLevels() on a non-object in components/com_kunena/libraries/integration/joomla16/access.php on line 57

The error was detected in the Kunena Component.

For support click here: Kunena Support

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #2 by mindriot
Seeing stuff like the following in the error logs regarding curl, strange thing is Ive got other sites on the server behaving just fine, this seems solely related to kunena, getting it on another site too :


Part of the message is hidden for the guests. Please log in or register to see it.
Last edit: 9 years 4 months ago by mindriot.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #3 by sozzled
Diagnosing HTTP 500 Internal Server Error problems is not easy. There is no prescribed way to go about these things. The error message indicates that there is an integration issue between Kunena and something else. I'm guessing that the "something else" is sh404SEF. Have you tried disabling sh404SEF for your Kunena pages or uninistalling sh404SEF completely?

I also suggest that you immediately upgrade Kunena Latest to version 1.7.2.

You have installed My Kunena Forum Menu 1.7.1, Kunena Groups 1.7.1, My Kunena Forum Posts 1.7.1. You need JomSocial to make these things work. Uninistall those plugins.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #4 by mindriot
I just noticed that but the module isnt in use so shouldnt be a probelem Im assuming, Ill uninstall it anyway, or at least thats what I installed recently.

The site also runs jomsocial 2.4, and the very latest sh404sef properly installed and set up, and all of it was just working just fine, thats what I dont get about this starting to happen suddenly.

turning sh404sef off doesnt have any effect. Im pursuing this with my host as well, its a new server Ive just finished setting up in conjunction with my host, just been running about 4 days but so far its been rock solid.
Last edit: 9 years 4 months ago by mindriot.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #5 by sozzled
Your configuration report does not show that you have JomSocial (any version) installed. Please do as I recommended and then post your updated config. report.I must be blind. I see that your report now shows you have JomSocial is installed and that you are using K 1.7.2! Ignore what I wrote before about the Kunena add-ons that handle JomSocial activity on your site.
Last edit: 9 years 4 months ago by sozzled.
The following user(s) said Thank You: mindriot

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #6 by mindriot
Youre getting snowblind looking at these reports with all the time you put in here :P

Ive tried enabling sh404sef, xipt etc, ive removed the old kunena latest, everythings the newest of its releases, joomla is up to date, the rest of the site functions fine, as do other sites using the same setups and extensions with integrations that this site and the other troubled site use. The only common factor seems to be kunena and that the issues cropped up afaik on both sites roughly the same time. The timing suggests to me its a server sided issue but just pursuing all possibilities.

Im not sure what to look at next, waiting for hosting support to respond, theyre usually pretty fast.
Last edit: 9 years 4 months ago by mindriot.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #7 by mindriot
It turns out there was an error in php.ini

The call to load the curl dll for windows systems had been uncommented, and naturally being a centos/cpanel server it wasnt finding it. This didnt seem to bother joomla or other extensions but it caused kunena to throw a fit.

Once commented out and the necessary items restarted everything appears to be fine.

Still getting 500 error on K1.7.2 on Joomla 1.5.25 site but nothing at all being reported in errors and nothing being fed into error logs :S

Happens when trying to view a thread :

pbmcltd.com/General-Discussion/21-Leading-Indicators.html
Last edit: 9 years 4 months ago by mindriot.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #8 by freeme
Hi - seems you found a solution as the link to the post, you published in your last mail, works. What was your solution?

I have the same issue. Using Joomla 2.5.1, Kunena 1.7.2. All of a sudden I get this error message: Fatal error: Call to a member function authorisedLevels() on a non-object in /administrator/components/com_kunena/libraries/integration/joomla16/access.php on line 57

Thx!
Last edit: 9 years 3 months ago by freeme.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #9 by mindriot
Hi, the Joomla 1.5 site came good after a short while but not immediately for some odd reason, whereas the fix resulted in the immediate rectification of the problem on the Joomla 2.5 site.

The cause of the problem was simple, a call to a curl dll line was uncommented in php, the call is only necessary on windows systems.

To clarify my server runs CentOS with WHM and CPanel, on linux the call for the dll isnt required (yet it caused upset to kunena). Further, my server runs Apache with SUphp, and I have it set to allow local php.ini files for my own individual sites. Somehow, probably my own fault, Id managed to uncomment the line in my master php.ini before I copied it to make local php.ini copies. These config files are hellishly sensetive to syntax and spelling, one tiny mistake can punish you, even simply using the wrong editor.

This was the line :
extension=php_curl.dll

and this is waht it should be on my type of server :
;extension=php_curl.dll

The preceding semi-colon is a comment, it comments out the line, effectively telling apache to ignore the line.

I have full access to everything as the entire server is mine (fully managed provider), however if youre hosted you probably wont have access to php.ini, and possibly not the ability to use local php.ini over-ride files, it depends what handler your server is configured to use for apache (causes different functionality), or indeed if its apache at all or a windows server using IIS

If you are using a shared hosting account you should pursue this with your hosting provider if youre sure its nothing directly related to your actions.
Last edit: 9 years 3 months ago by mindriot.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #10 by freeme
Mindriot, thank you for your extensive reply. Just looked at my site - it is working again. I dont understand the logic behind it - how is this possible? I didnt change anything.

My site is hosted by 1&1 Germany, probably the admin changed something and rechanged it last night...

As far as I understood, the problem was related to CURL. And you disabled CURL, then Kunena worked again.

Well, if I disable CURL, then I think have a problem with my SobiPro component, as it is requiring CURL as far as I remember.

Anyway - lets see if this occurs again. Thanks!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.229 seconds