×
Kunena 5.2.8 released and Blue eagle 1.6.7 released (02 Jan 2022)

The Kunena team has announce the arrival of Kunena 5.2.8 [K 5.2.8] which is now available for download as a native Joomla extension for J! 3.10/3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

If you are using blue template you need to update to 1.6.7 version to ensure to have a compatible version with K5.2.8.

Important note: (07 Jan 2022) If you have created a Kunena custom.css, create a backup of it. Due to an error, this file will be deleted during an upgrade.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

Question Internal server error

More
10 years 4 months ago #11 by Matias
Replied by Matias on topic Re: Internal server error
That message comes from server mis-configuration. It looks like you haven't any error documents set to the server.

I think I found out what causes Kunena to create so many topics. Try to edit file plugins/content/kunenadiscuss/kunenadiscuss.php and replace
function plgContentKunenaDiscuss(&$subject, $params) {
 
		$this->_app = JFactory::getApplication ( 'site' );
with this:
function plgContentKunenaDiscuss(&$subject, $params) {
 
		$this->_app = JFactory::getApplication ();
		if ($this->_app->isAdmin()) return;

I hope it fixes your issue!

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #12 by erkan
Replied by erkan on topic Re: Internal server error
No it still doesn´t work. But the strange thing is that it works on my test site which is a duplicate of my real site with a few modifications. I will compare the two sites and see if I can find what makes the plugin work on the test site.

I still get the internal server error message.
Last edit: 10 years 4 months ago by erkan.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #13 by Matias
Replied by Matias on topic Re: Internal server error
Please update this topic when you find out. You should also set up test domain into your server so you can test changes in live environment.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #14 by badabugs
Replied by badabugs on topic Re: Internal server error
Hi Matias,

I think I found out what causes Kunena to create so many topics. Try to edit file plugins/content/kunenadiscuss/kunenadiscuss.php and replace

function plgContentKunenaDiscuss(&$subject, $params) {

$this->_app = JFactory::getApplication ( 'site' );


with this:

function plgContentKunenaDiscuss(&$subject, $params) {

$this->_app = JFactory::getApplication ();
if ($this->_app->isAdmin()) return;


it didn't fix the issue.

I saw something strange, threads that were created have an old date ... (for me, it the 12th august)

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #15 by Matias
Replied by Matias on topic Re: Internal server error
Yes, Kunena Discuss uses the date from the article by default.

Which issue wasn't fixed by this change?

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #16 by badabugs
Replied by badabugs on topic Re: Internal server error
No changes for me :

when I try to add a comment in the discuss plugin I get an internal server error and 125 topics is created in my forum


when activity stream is enabled .

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #17 by Mortti
Replied by Mortti on topic Re: Internal server error
Why you don't say/give your information, it's still mystery for me what looks in here... google? it's never as bad?

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #18 by erkan
Replied by erkan on topic Re: Internal server error
I have now compared my test site and my live site and I still don´t know why the plugin works in my test site but not on my live site.

Jomsocial activity stream intergration is enabled on my test site and the K disucss plugin works anyway but it don´t on my live site.

The only difference between my live site and my test site is that the test site have Jomsocial Profil Types fron JoomlaXI and PayPlans installed. And my test site is on another domain but it is still the same webhost.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #19 by badabugs
Replied by badabugs on topic Re: Internal server error
This is my apache error log from wamp when there's the issue :

[Fri Sep 02 13:57:33 2011] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Sep 02 13:57:33 2011] [notice] Apache/2.2.11 (Win32) PHP/5.3.0 configured -- resuming normal operations
[Fri Sep 02 13:57:33 2011] [notice] Server built: Dec 10 2008 00:10:06
[Fri Sep 02 13:57:33 2011] [notice] Parent: Created child process 1580
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Child process is running
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Acquired the start mutex.
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Starting 64 worker threads.
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Starting thread to listen on port 80.

Any idea ?

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #20 by xillibit
Replied by xillibit on topic Re: Internal server error

badabugs wrote: This is my apache error log from wamp when there's the issue :

[Fri Sep 02 13:57:33 2011] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Sep 02 13:57:33 2011] [notice] Apache/2.2.11 (Win32) PHP/5.3.0 configured -- resuming normal operations
[Fri Sep 02 13:57:33 2011] [notice] Server built: Dec 10 2008 00:10:06
[Fri Sep 02 13:57:33 2011] [notice] Parent: Created child process 1580
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Child process is running
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Acquired the start mutex.
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Starting 64 worker threads.
[Fri Sep 02 13:57:33 2011] [notice] Child 1580: Starting thread to listen on port 80.

Any idea ?

This do not help, this isn't errors messages but just message about start of apache...

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.083 seconds