×
Kunena 5.2.8 released and Blue eagle 1.6.7 released (02 Jan 2022)

The Kunena team has announce the arrival of Kunena 5.2.8 [K 5.2.8] which is now available for download as a native Joomla extension for J! 3.10/3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

If you are using blue template you need to update to 1.6.7 version to ensure to have a compatible version with K5.2.8.

Important note: (07 Jan 2022) If you have created a Kunena custom.css, create a backup of it. Due to an error, this file will be deleted during an upgrade.

Solved Joomla 4.0.4 und Kunena 6.0.0-BETA4 Kategorien/Themen springen zwischen Template

More
2 months 4 weeks ago - 2 months 4 weeks ago #1 by Gindi
Ich habe Kunena 4.0.4 und Kunena 6.0.0-BETA4 neu installiert und die Datenbankeinträge von Kunena und den Usern aus der Version Joomla 3.10.3 importiert, Soweit alles OK.
Wenn ich auf der Userseite das Forum starte, wird alles auf der gesamten Breite angezeigt. Das bleibt auch so wenn ich die Sektion und die Kategorie anwähle. Wenn die Kategorie mehrere Seiten hat und ich klicke auf die zweite Seite, bin ich im Cassiopeia Template, d.h. links und rechts sind die Module der Startseite und in der Mitte ist das Forum. Wenn ich auf die nächste Seite oder wieder zurück gehen will, bekomme ich die Meldung:
404 View nicht gefunden [Name, Typ, Präfix]: topic, html, site
Wenn ich statt dessen den "Seite Zurück Pfeil" des Browser anklicke, komme ich wieder auf die normale "Aurelia" Anzeige zurück.
Zwei mal klicken ist ok, beim dritten Klick bin ich bei Cassiopeia.
Ich habe mal den Konfigurationsreport angehängt, vielleicht hilft er.

Gruß gindi
Last edit: 2 months 4 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #2 by Gindi
Ich habe das ganze nochmal am Beispiel Recent Topics durchgespielt. Vorher hatte ich bei Joomla und im Forum den Debug Modus aktiviert.
Beim Forumstart wurde mir in Recent Topics ein Thema mit mehreren Seiten angezeigt. Beim Klick auf das Thema wurden alle Beiträge und Bilder dieser Seite angezeigt. Beim Klick auf Seite 2 kam ich auf Cassiopeia und die Forumseite wurde in der Mitte angezeigt. Rechts und links waren die Joomla Module. Dann habe ich nach unten gescrollt und auf die Forumseite 3 geklickt. Dann kam wieder die Fehlermeldung:
404 View nicht gefunden [Name, Typ, Präfix]: topic, html, site
Weiter wurde angezeigt:
Call stack
# Function Location
1 () JROOT/libraries/src/MVC/Controller/BaseController.php:898
2 Joomla\CMS\MVC\Controller\BaseController->getView() JROOT/libraries/src/MVC/Controller/BaseController.php:641
3 Joomla\CMS\MVC\Controller\BaseController->display() JROOT/components/com_content/src/Controller/DisplayController.php:125
4 Joomla\Component\Content\Site\Controller\DisplayController->display() JROOT/libraries/src/MVC/Controller/BaseController.php:730
5 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/libraries/src/Dispatcher/ComponentDispatcher.php:146
6 Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch() JROOT/components/com_content/src/Dispatcher/Dispatcher.php:55
7 Joomla\Component\Content\Site\Dispatcher\Dispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:389
8 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/SiteApplication.php:206
9 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/SiteApplication.php:245
10 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:278
11 Joomla\CMS\Application\CMSApplication->execute() JROOT/includes/app.php:63
12 require_once() JROOT/index.php:32

Das ist wahrscheinlich die Joomla Fehlermeldung weil Joomla Cassiopeia die Forumseite 3 nicht gefunden hat.
Vielleicht hilft es trotzdem bei der Fehlersuche.
Gruß gindi

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #3 by rich
Vorweg, ich habe deinen Konfigurationsbericht entfernt, denn er war kaputt. Du darfst diesen nur direkt einfügen und danach den Beitrag speichern.
Hast du bei deinem Kunena-Menü etwas verändert? Lösche das Kunena-Menü und lasse dann ein neues erstellen, dann sollte dein Template-Problem weg sein.
Der Bug mit der Navigation ist uns bekannt.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #4 by Gindi
Wie in Beitrag #1 schon geschrieben hatte ich alles neu installiert, das Forum im Main Menü veröffentlicht und Menüeintragstyp Menüeintrag-Alias mit Forum verlinkt. So weit, so gut.
Ich habe jetzt den Eintrag "Forum" im Main-Menü gelöscht, die Menüs im Kunena-Forum komplett gelöscht und in der Toolbox ein neues Menü erstellen lassen. Das habe ich im Main-Menü sichtbar gemacht und Menüeintragstyp Menüeintrag-Alias mit Forum verlinkt.
Wenn ich auf der Startseite im Main-Menü das Forum anklicke, werden mir die Recent Topics angezeigt (das ist so eingestellt). Klicke ich auf ein Thema, wird es in voller Breite angezeigt. Klicke ich auf Seite 2 des Themas, bin ich wieder bei Cassiopeia. Klicke ich auf Seite 1 oder Seite 3 des Themas, kommt die Meldung: 404 View nicht gefunden [Name, Typ, Präfix]: topic, html, site
Es ist also alles wieder so wie in Beitrag #1 geschrieben.

Gruß gindi

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #5 by rich
Was passiert, wenn du im Kunena-Menü den ersten Menüpunkt „Forum“ als Startseite (mit einem Klick rechts auf den Kreis) markierst?

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago - 2 months 3 weeks ago #6 by Gindi
DANKE! Das war die Lösung.
Jetzt kann ich mich in allen Sektionen, allen Kategorien und allen Beiträge durch alle Seiten klicken und es wird alles über die ganze Bildschirmbreite angezeigt.
Gruß gindi

Nachtrag: Heute Morgen hat die Website (auf localhost) nach dem starten nicht die Startseite vom Joomla angezeigt sondern die Forumseite "Recent Topics". Ich habe dann allen Cache gelöscht, den Browsercache und die localhost Cookies gelöscht und die Seite neu gestartet und bin wieder bei "Recent Topics" gelandet.
 
Last edit: 2 months 3 weeks ago by Gindi.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #7 by Gindi
Ich habe jetzt wieder die normale Startseite von Joomla aktiviert.
Bei weiteren Tests habe ich festgestellt, daß der gleiche Beitrag unterschiedlich angezeigt werden kann.
So wird der Beitrag in Aurelia angezeigt:
https://localhost/Joomla404Kunena/index.php/forum/10-Informationen-und-Fragen-zum-Forum/3820-fragen-zum-forum
So wird er in Cassiopeia angezeigt:
https://localhost/Joomla404Kunena/index.php/component/kunena/10-Informationen-und-Fragen-zum-Forum/3820-fragen-zum-forum?Itemid=101

Wenn ich in den Breadcrumbs von Kunena auf "Fragen zum Forum" klicke, kann ich zwischen beiden Anzeigen hin und her schalten.
"Fragen zum Forum" wird bei Kunena als Link dargestellt, bei Joomla nicht.

Gruß gindi
 

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #8 by rich
Wir wissen es bereits, wodurch diese Fehler auftreten, daher bringt es nichts, wenn wir darüber erneut diskutieren. Entweder wartest du, bis dieser Fehler behoben ist, oder du versuchst es mit dieser Notlösung: www.kunena.org/forum/36-German/163148-li...orrekt-in-seo#219835

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #9 by Gindi
Da werde ich wohl warten müssen bis der Fehler behoben ist, denn bei mir funktioniert die Notlösung nicht.

Gruß gindi

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago - 2 months 1 week ago #10 by rich
Es scheint sich um einen Joomla Bug zu handeln. Hier gibt es eine Diskussion darüber: github.com/joomla/joomla-cms/issues/35463
Last edit: 2 months 1 week ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.126 seconds